summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaymon MARNADI <darwinskernel@gmail.com>2021-10-06 13:49:45 -0400
committerFlorian Schmaus <flow@gentoo.org>2021-11-29 16:41:56 +0100
commit90bcb1fdec53af57cc4bfeb67975c633b7f9cf4e (patch)
tree796ac29abaca2cc620f36506ffa044de95242765 /app-admin/mkosi/mkosi-11.ebuild
parentmail-client/roundcube: 1.5.1 version bump (diff)
downloadgentoo-90bcb1fdec53af57cc4bfeb67975c633b7f9cf4e.tar.gz
gentoo-90bcb1fdec53af57cc4bfeb67975c633b7f9cf4e.tar.bz2
gentoo-90bcb1fdec53af57cc4bfeb67975c633b7f9cf4e.zip
app-admin/mkosi: add mkosi
... in anticipation of the PR for gentoo support [upstream-pr] getting closer to being merged. [upstream-pr] https://github.com/systemd/mkosi/pull/717 Signed-off-by: Paymon MARANDI <darwinskernel@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/22509 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-admin/mkosi/mkosi-11.ebuild')
-rw-r--r--app-admin/mkosi/mkosi-11.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-admin/mkosi/mkosi-11.ebuild b/app-admin/mkosi/mkosi-11.ebuild
new file mode 100644
index 000000000000..2c90bec35ee1
--- /dev/null
+++ b/app-admin/mkosi/mkosi-11.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Build Bespoke OS Images"
+HOMEPAGE="https://github.com/systemd/mkosi"
+SRC_URI="https://github.com/systemd/mkosi/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+RDEPEND="
+ sys-apps/portage
+ sys-apps/systemd
+ dev-vcs/git
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "For debian support: " dev-util/debootstrap
+}