summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-03-31 20:27:46 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-03-31 20:27:46 +0200
commit6ac8fe80aa81d19f535ebe76154bc64cae2e4ba1 (patch)
tree5d1db24d00d753c149f2ffe5b8cc9c913660ca17 /app-admin/kubectx
parentmedia-gfx/sane-frontends: stable 1.0.14-r3 for ppc64, bug #647524 (diff)
downloadgentoo-6ac8fe80aa81d19f535ebe76154bc64cae2e4ba1.tar.gz
gentoo-6ac8fe80aa81d19f535ebe76154bc64cae2e4ba1.tar.bz2
gentoo-6ac8fe80aa81d19f535ebe76154bc64cae2e4ba1.zip
app-admin/kubectx: Version bump to 0.4.1
Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'app-admin/kubectx')
-rw-r--r--app-admin/kubectx/Manifest1
-rw-r--r--app-admin/kubectx/kubectx-0.4.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/kubectx/Manifest b/app-admin/kubectx/Manifest
index 828e2504fe40..7e085c934a07 100644
--- a/app-admin/kubectx/Manifest
+++ b/app-admin/kubectx/Manifest
@@ -1 +1,2 @@
DIST kubectx-0.4.0_p20180118.tar.gz 398084 BLAKE2B fda8cae93e221fc4732b7cedbd44465541cdd7f31b29fbbfde781ea34b2c2d644ad6735d6bf7fa1ebcf04cc2b9dc3ac8e883808cd04c8a256b004a3293cee240 SHA512 04123596724dfc4dacc0beb578c716a3909d98d7df7dbf3c1439b5bb29ac14ea7b366be3e2252550ed89474c58ce83b028af79b0cd288f1ecd62c6c3f2729f62
+DIST kubectx-0.4.1.tar.gz 397910 BLAKE2B 60b0ac75cf6358a3660c3e59f85e5c27a670095ad973edbf2b53350726b48f1036aa90dd999cf149c10956a43692389ab2e87c63bce3b711ae2c7cb894157753 SHA512 dcaf1c8f71f69037f9341ff29befb2507d7bfa11a25e6e864000b802fe1221d6b47f2f78faa6c490711e65d0dda4b289e5ed1ffc261e4d2142054f48d1aac140
diff --git a/app-admin/kubectx/kubectx-0.4.1.ebuild b/app-admin/kubectx/kubectx-0.4.1.ebuild
new file mode 100644
index 000000000000..bcdb869a0ef6
--- /dev/null
+++ b/app-admin/kubectx/kubectx-0.4.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vcs-snapshot bash-completion-r1
+
+DESCRIPTION="Fast way to switch between clusters and namespaces in kubectl"
+HOMEPAGE="https://github.com/ahmetb/kubectx"
+SRC_URI="https://github.com/ahmetb/kubectx/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="sys-cluster/kubectl"
+
+src_install() {
+ dobin kubectx kubens
+
+ insinto /usr/share/zsh/site-functions
+ newins completion/kubectx.zsh _kubectx
+ newins completion/kubens.zsh _kubens
+
+ newbashcomp completion/kubectx.bash kubectx
+ newbashcomp completion/kubens.bash kubens
+}