summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/killproc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/killproc')
-rw-r--r--app-admin/killproc/Manifest1
-rw-r--r--app-admin/killproc/files/killproc-2.13-makefile.patch42
-rw-r--r--app-admin/killproc/killproc-2.13-r1.ebuild28
-rw-r--r--app-admin/killproc/metadata.xml7
4 files changed, 78 insertions, 0 deletions
diff --git a/app-admin/killproc/Manifest b/app-admin/killproc/Manifest
new file mode 100644
index 000000000000..24cf342918f7
--- /dev/null
+++ b/app-admin/killproc/Manifest
@@ -0,0 +1 @@
+DIST killproc-2.13.tar.gz 37953 SHA256 090590f5ab24559889bd134f38258d5ea567590098580c2345ca8183fb9c3e78 SHA512 2ba8daa10d78c7e6df80f6fc5bff24807571bd8bcecf4674c1dac180da5c462b326c1fd45e31b4974937d47871b48c9e5b215a7b323e65d98fe0a66b171e9d2d WHIRLPOOL 06bcba6d88ec598c5ae31f18a24cc14ae710d4e94f0185c29017b75a475c9e84be6fb01470af24d945f22a169a0c77060741f8228cd8066d5be53dc5d6395b49
diff --git a/app-admin/killproc/files/killproc-2.13-makefile.patch b/app-admin/killproc/files/killproc-2.13-makefile.patch
new file mode 100644
index 000000000000..4eb8131448ee
--- /dev/null
+++ b/app-admin/killproc/files/killproc-2.13-makefile.patch
@@ -0,0 +1,42 @@
+--- a/Makefile
++++ b/Makefile
+@@ -27,9 +27,7 @@
+ #
+ # egcs used with -O2 includes -fno-force-mem which is/was buggy (1998/10/08)
+ #
+- CFLAGS = $(RPM_OPT_FLAGS) $(COPTS) $(DEBUG) $(INC) -D_GNU_SOURCE -Wall -pipe
+- CLOOP = -funroll-loops
+- CC = gcc
++ CFLAGS = $(RPM_OPT_FLAGS) $(COPTS) $(DEBUG) $(INC) -D_GNU_SOURCE -Wall
+ RM = rm -f
+ MKDIR = mkdir -p
+ RMDIR = rm -rf
+@@ -59,22 +57,22 @@
+ all: $(SBINPRG) $(UBINPRG)
+
+ libinit.o: libinit.c libinit.h
+- $(CC) $(CFLAGS) $(CLOOP) -DINITDIR=\"$(INITDIR)\" -c $<
++ $(CC) $(CFLAGS) -DINITDIR=\"$(INITDIR)\" -c $<
+
+ killproc: killproc.c libinit.o
+- $(CC) $(CFLAGS) $(CLOOP) -o $@ $^ $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ startproc: startproc.c libinit.o
+- $(CC) $(CFLAGS) $(CLOOP) -o $@ $^ $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ checkproc: checkproc.c libinit.o
+- $(CC) $(CFLAGS) $(CLOOP) -o $@ $^ $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ usleep: usleep.c
+- $(CC) $(CFLAGS) -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
+
+ fsync: fsync.c
+- $(CC) $(CFLAGS) -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
+
+ clean:
+ $(RM) *.o *~ killproc startproc checkproc pidofproc start_daemon usleep fsync
diff --git a/app-admin/killproc/killproc-2.13-r1.ebuild b/app-admin/killproc/killproc-2.13-r1.ebuild
new file mode 100644
index 000000000000..92094e47d750
--- /dev/null
+++ b/app-admin/killproc/killproc-2.13-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="killproc and assorted tools for boot scripts"
+HOMEPAGE="http://ftp.suse.com/pub/projects/init/"
+SRC_URI="ftp://ftp.suse.com/pub/projects/init/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-makefile.patch"
+ tc-export CC
+ export COPTS=${CFLAGS}
+}
+
+src_install() {
+ into /
+ dosbin checkproc fsync killproc startproc usleep
+ into /usr
+ doman *.8 *.1
+ dodoc README *.lsm
+}
diff --git a/app-admin/killproc/metadata.xml b/app-admin/killproc/metadata.xml
new file mode 100644
index 000000000000..347ef1097116
--- /dev/null
+++ b/app-admin/killproc/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>jer@gentoo.org</email>
+</maintainer>
+</pkgmetadata>