summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/hwreport
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/hwreport')
-rw-r--r--app-admin/hwreport/Manifest2
-rw-r--r--app-admin/hwreport/hwreport-0.10.0.ebuild30
-rw-r--r--app-admin/hwreport/hwreport-0.11.0.ebuild30
-rw-r--r--app-admin/hwreport/metadata.xml8
4 files changed, 70 insertions, 0 deletions
diff --git a/app-admin/hwreport/Manifest b/app-admin/hwreport/Manifest
new file mode 100644
index 000000000000..73406cbf6e65
--- /dev/null
+++ b/app-admin/hwreport/Manifest
@@ -0,0 +1,2 @@
+DIST hwreport-0.10.0.tar.bz2 11171 SHA256 34269554e3888a4a3486ab6290ce417ac3c4e38a2f12e5327900323e5c875567 SHA512 6c3793040258455cdab6aecca7f540c118dd7fb9b1441ea4daf46288d2c285db7ee13a0b9e455a4018f288fa7977583c4a626956ac4628e54606c66a684a891a WHIRLPOOL 12f04391e1fef9ad0e634000311dd0b0e8ed7ce8efe84862aea5e7f062688715ac754e238255d40fa24423d8d4c88664b2ca1f00991e08507759f51d4a0ab4d2
+DIST hwreport-0.11.0.tar.bz2 14337 SHA256 b4337f91b2e9d6d500bfc9af7e32f1966db4346ff9b2ad869d09500189555160 SHA512 591e76a9bd739da0b53eb39796f026b4bde75243cdbd5cbfc0774b4dfd067656108478f4a24ea7d5693ecd2acf3a11a11f617c9b187480bd963596d5fc5db3d9 WHIRLPOOL 4c22d1d45d44f0c6e9b9b629f3db7dbdaf971343fbe1f68a010cd34359b35c1141a1679e5a08cd7ef7304aeb66bab66f7de07efde18c359d476038d18fb78098
diff --git a/app-admin/hwreport/hwreport-0.10.0.ebuild b/app-admin/hwreport/hwreport-0.10.0.ebuild
new file mode 100644
index 000000000000..13b65a49d01f
--- /dev/null
+++ b/app-admin/hwreport/hwreport-0.10.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="Collect system informations for the hardware4linux.info site"
+HOMEPAGE="http://hardware4linux.info/"
+SRC_URI="http://hardware4linux.info/res/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc sparc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=sys-apps/dmidecode-2.8 >=sys-apps/pciutils-2.2.0"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o scan-printers scan-printers.c
+}
+
+src_install() {
+ dobin hwreport scan-printers
+ dodoc README
+}
+
+pkg_postinst() {
+ elog "You can now generate your reports and post them on ${HOMEPAGE}"
+}
diff --git a/app-admin/hwreport/hwreport-0.11.0.ebuild b/app-admin/hwreport/hwreport-0.11.0.ebuild
new file mode 100644
index 000000000000..ec5c7bab7da7
--- /dev/null
+++ b/app-admin/hwreport/hwreport-0.11.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Collect system informations for the hardware4linux.info site"
+HOMEPAGE="http://hardware4linux.info/"
+SRC_URI="http://hardware4linux.info/res/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/libusb:1"
+RDEPEND="${DEPEND}
+ >=sys-apps/dmidecode-2.8
+ >=sys-apps/pciutils-2.2.0"
+
+src_prepare() {
+ # fix syntax error
+ sed -e 's:perl -p -i -e "s@/var/lib/hwreport@$(vardir)@" -e "s@/usr/sbin@$(bindir)@" $(DESTDIR)$(crondir)/$(PKG):perl -p -i -e "s@/var/lib/hwreport@$(vardir)@;" -e "s@/usr/sbin@$(bindir)@" $(DESTDIR)$(crondir)/$(PKG):' -i "${S}"/Makefile
+ # respect LDFLAGS
+ sed -e 's:$(CFLAGS):$(CFLAGS) $(LDFLAGS):' -i Makefile
+}
+
+pkg_postinst() {
+ elog "You can now generate your reports and post them on ${HOMEPAGE}"
+}
diff --git a/app-admin/hwreport/metadata.xml b/app-admin/hwreport/metadata.xml
new file mode 100644
index 000000000000..2811adea6ed8
--- /dev/null
+++ b/app-admin/hwreport/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>fauli@gentoo.org</email>
+ <name>Christian Faulhammer</name>
+</maintainer>
+</pkgmetadata>