summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-17 09:38:21 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-17 09:57:11 +0100
commit5f1275f8634e5ff592af0cd3c2059064c2ffef26 (patch)
tree41efa9b43c950832f325c737b0c25f30ef82dc2c /app-admin/hddtemp
parentdev-python/batinfo: New package, ebuild written by me (diff)
downloadgentoo-5f1275f8634e5ff592af0cd3c2059064c2ffef26.tar.gz
gentoo-5f1275f8634e5ff592af0cd3c2059064c2ffef26.tar.bz2
gentoo-5f1275f8634e5ff592af0cd3c2059064c2ffef26.zip
app-admin/hddtemp: Move to nextgen readme.gentoo eclass
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'app-admin/hddtemp')
-rw-r--r--app-admin/hddtemp/hddtemp-0.3_beta15-r25.ebuild25
-rw-r--r--app-admin/hddtemp/metadata.xml12
2 files changed, 23 insertions, 14 deletions
diff --git a/app-admin/hddtemp/hddtemp-0.3_beta15-r25.ebuild b/app-admin/hddtemp/hddtemp-0.3_beta15-r25.ebuild
index 7daa559ac305..96f779734d5c 100644
--- a/app-admin/hddtemp/hddtemp-0.3_beta15-r25.ebuild
+++ b/app-admin/hddtemp/hddtemp-0.3_beta15-r25.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit eutils autotools readme.gentoo systemd
+
+inherit eutils autotools readme.gentoo-r1 systemd
MY_P=${P/_beta/-beta}
DBV=20080531
@@ -37,13 +38,17 @@ If hddtemp complains but finds your HDD temperature sensor, use the
--quiet option to suppress the warning.
"
+PATCHES=(
+ "${FILESDIR}"/${P}-satacmds.patch
+ "${FILESDIR}"/${P}-byteswap.patch
+ "${FILESDIR}"/${P}-execinfo.patch
+ "${FILESDIR}"/${P}-nls.patch
+ "${FILESDIR}"/${P}-iconv.patch
+ "${FILESDIR}"/${P}-dontwake.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-satacmds.patch
- epatch "${FILESDIR}"/${P}-byteswap.patch
- epatch "${FILESDIR}"/${P}-execinfo.patch
- epatch "${FILESDIR}"/${P}-nls.patch
- epatch "${FILESDIR}"/${P}-iconv.patch
- epatch "${FILESDIR}"/${P}-dontwake.patch
+ epatch "${PATCHES[@]}"
AT_M4DIR="m4" eautoreconf
}
@@ -79,6 +84,10 @@ src_install() {
fi
}
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
+
update_db() {
local src=$1
local dst=$2
diff --git a/app-admin/hddtemp/metadata.xml b/app-admin/hddtemp/metadata.xml
index c518306cdc08..4339a37c3540 100644
--- a/app-admin/hddtemp/metadata.xml
+++ b/app-admin/hddtemp/metadata.xml
@@ -1,12 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="person">
- <email>aidecoe@gentoo.org</email>
-</maintainer>
-<use>
- <flag name="network-cron">
+ <maintainer type="person">
+ <email>aidecoe@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="network-cron">
Monthly cronjob to update hddtemp.db.
</flag>
-</use>
+ </use>
</pkgmetadata>