summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/hardening-check
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/hardening-check')
-rw-r--r--app-admin/hardening-check/Manifest3
-rw-r--r--app-admin/hardening-check/hardening-check-2.5.ebuild27
-rw-r--r--app-admin/hardening-check/hardening-check-2.6.ebuild28
-rw-r--r--app-admin/hardening-check/hardening-check-2.7.ebuild28
-rw-r--r--app-admin/hardening-check/metadata.xml14
5 files changed, 100 insertions, 0 deletions
diff --git a/app-admin/hardening-check/Manifest b/app-admin/hardening-check/Manifest
new file mode 100644
index 000000000000..a99be1ee8ce3
--- /dev/null
+++ b/app-admin/hardening-check/Manifest
@@ -0,0 +1,3 @@
+DIST hardening-wrapper_2.5.tar.gz 21157 SHA256 9ae2cc44d9543476b5b8655b4699af5421218dce44ce0d4a89cf5d81ba12b9bf SHA512 e2c183736e9f1dd1b39ecde7d2bf2c22d4c87c69cb158d98bb527b8325d88ea86bceb6087633cc761e973a22d0cf97c6266464d117e408ed2aee2e67c8ab5565 WHIRLPOOL 652327876a29ad8a69529bcb85b1331a227348a1ca87c1e5cf69fbcea0ad7c57afdcb14536eebfc8668834a701ee80f8579b8851f596e41ee782e4c6dbf47cb9
+DIST hardening-wrapper_2.6.tar.xz 19436 SHA256 c5fc46439646d0929a0605e4f3db67e57eefbbf5ceec5a2888440dbdf4450224 SHA512 924d9d816148bc5f2d25d66fd24c7b2a77fef8d62eb7656d4c9b0ee50c767789f25aaa3b776138103682366ff7c2266be4a207d4b11361655b5097131033283e WHIRLPOOL b74177a5f12984d381f3f9143a03605b157f571edc9ed09cdea2c72920c41aea3b1e5687409539cc087d66dd6a496e6204a1d5f165ce7070849d34b3ee851134
+DIST hardening-wrapper_2.7.tar.xz 19604 SHA256 20c601c6ccac7534d17d4be9442a4ad8f02b8461c2c50dee8b45d596cd6cf8e7 SHA512 834242b28e06f32d6e899f13fcfc66f560e4137267f8cb46fab21337240fec612ea2803345012308af50c0fc4af92f52a28a18803ba330998ad7cb1321023121 WHIRLPOOL ebcee88c6225187b685f0c4792642131a8b9cc3b28fc293348c0cb59a5dc1f484df526f27fb9761204cdefae3d8a99975353a2160ec4fe4ebdea79cd4a8e4dd7
diff --git a/app-admin/hardening-check/hardening-check-2.5.ebuild b/app-admin/hardening-check/hardening-check-2.5.ebuild
new file mode 100644
index 000000000000..ff78e06d91b4
--- /dev/null
+++ b/app-admin/hardening-check/hardening-check-2.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MY_PN="hardening-wrapper"
+
+DESCRIPTION="Report the hardening characterists of a set of binaries"
+HOMEPAGE="https://wiki.debian.org/Hardening https://packages.debian.org/source/jessie/hardening-wrapper"
+SRC_URI="mirror://debian/pool/main/h/${MY_PN}/${MY_PN}_${PV}.tar.gz"
+
+KEYWORDS="amd64 x86"
+IUSE=""
+LICENSE="GPL-2+"
+SLOT="0"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PN}"
+
+src_compile() { :; }
+
+src_install() {
+ newbin ${PN}.sh ${PN}
+}
diff --git a/app-admin/hardening-check/hardening-check-2.6.ebuild b/app-admin/hardening-check/hardening-check-2.6.ebuild
new file mode 100644
index 000000000000..9b7c96f3703d
--- /dev/null
+++ b/app-admin/hardening-check/hardening-check-2.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MY_PN="hardening-wrapper"
+
+DESCRIPTION="Report the hardening characterists of a set of binaries"
+HOMEPAGE="https://wiki.debian.org/Hardening https://packages.debian.org/source/jessie/hardening-wrapper"
+SRC_URI="mirror://debian/pool/main/h/${MY_PN}/${MY_PN}_${PV}.tar.xz"
+
+KEYWORDS="amd64 x86"
+IUSE=""
+LICENSE="GPL-2+"
+SLOT="0"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PN}"
+
+src_compile() { :; }
+
+src_install() {
+ newbin ${PN}.sh ${PN}
+ dodoc AUTHORS
+}
diff --git a/app-admin/hardening-check/hardening-check-2.7.ebuild b/app-admin/hardening-check/hardening-check-2.7.ebuild
new file mode 100644
index 000000000000..6ecf5ac6ca3d
--- /dev/null
+++ b/app-admin/hardening-check/hardening-check-2.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MY_PN="hardening-wrapper"
+
+DESCRIPTION="Report the hardening characterists of a set of binaries"
+HOMEPAGE="https://wiki.debian.org/Hardening https://packages.debian.org/source/jessie/hardening-wrapper"
+SRC_URI="mirror://debian/pool/main/h/${MY_PN}/${MY_PN}_${PV}.tar.xz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+LICENSE="GPL-2+"
+SLOT="0"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PN}"
+
+src_compile() { :; }
+
+src_install() {
+ newbin ${PN}.sh ${PN}
+ dodoc AUTHORS
+}
diff --git a/app-admin/hardening-check/metadata.xml b/app-admin/hardening-check/metadata.xml
new file mode 100644
index 000000000000..2c97c584ed1f
--- /dev/null
+++ b/app-admin/hardening-check/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ago@gentoo.org</email>
+ <name>Agostino Sarubbo</name>
+ </maintainer>
+ <maintainer>
+ <email>kees@outflux.net</email>
+ <name>Kees Cook</name>
+ <description>Upstream - please CC on bugs that concerns upstream</description>
+ </maintainer>
+</pkgmetadata>
+