summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-12-03 09:18:06 +0100
committerHans de Graaff <graaff@gentoo.org>2016-12-03 09:58:22 +0100
commit4f1977644c438e114ec6a17eda347f820fc6e3dc (patch)
tree57afa582b3be2b8a0d00afc09c60647cc2f8d146 /app-admin/ec2-ami-tools/ec2-ami-tools-1.5.6-r1.ebuild
parentx11-terms/guake: Old. (diff)
downloadgentoo-4f1977644c438e114ec6a17eda347f820fc6e3dc.tar.gz
gentoo-4f1977644c438e114ec6a17eda347f820fc6e3dc.tar.bz2
gentoo-4f1977644c438e114ec6a17eda347f820fc6e3dc.zip
app-admin/ec2-ami-tools: use ruby21 with ruby-single eclass
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-admin/ec2-ami-tools/ec2-ami-tools-1.5.6-r1.ebuild')
-rw-r--r--app-admin/ec2-ami-tools/ec2-ami-tools-1.5.6-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-admin/ec2-ami-tools/ec2-ami-tools-1.5.6-r1.ebuild b/app-admin/ec2-ami-tools/ec2-ami-tools-1.5.6-r1.ebuild
new file mode 100644
index 000000000000..183281837500
--- /dev/null
+++ b/app-admin/ec2-ami-tools/ec2-ami-tools-1.5.6-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+USE_RUBY="ruby21"
+
+inherit ruby-single versionator
+
+DESCRIPTION="Command-line tools that serve as client interface to the Amazon EC2 web service"
+HOMEPAGE="http://developer.amazonwebservices.com/connect/entry.jspa?externalID=368&categoryID=88"
+SRC_URI="http://s3.amazonaws.com/ec2-downloads/${P}.zip"
+
+LICENSE="Amazon
+ || ( Ruby GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND="
+ ${RUBY_DEPS}
+ virtual/ruby-ssl
+ net-misc/rsync
+ net-misc/curl"
+
+src_prepare() {
+ # Remove a left behind license file.
+ rm lib/ec2/oem/LICENSE.txt || die 'Removal of LICENSE failed.'
+}
+
+src_install() {
+ dobin bin/*
+
+ insinto /usr
+ doins -r lib
+
+ insinto /etc/ec2/amitools
+ doins etc/ec2/amitools/*
+
+ dodir /etc/env.d
+ echo "EC2_AMITOOL_HOME=/usr" >> "${T}"/99${PN} || die "Can't write environment variable."
+ doenvd "${T}"/99${PN}
+}
+
+pkg_postinst() {
+ ewarn "Remember to run \`env-update && source /etc/profile\` if you plan"
+ ewarn "to use these tools in a shell before logging out (or restarting"
+ ewarn "your login manager)."
+}