summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/conserver
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/conserver')
-rw-r--r--app-admin/conserver/Manifest1
-rw-r--r--app-admin/conserver/conserver-8.1.18-r1.ebuild87
-rw-r--r--app-admin/conserver/conserver-8.1.18.ebuild87
-rw-r--r--app-admin/conserver/files/conserver-8.1.18-dmalloc.patch100
-rw-r--r--app-admin/conserver/files/conserver-prestrip.patch24
-rw-r--r--app-admin/conserver/files/conserver.confd7
-rw-r--r--app-admin/conserver/files/conserver.initd38
-rw-r--r--app-admin/conserver/files/conserver.initd-r138
-rw-r--r--app-admin/conserver/files/conserver.pam-pambase6
-rw-r--r--app-admin/conserver/metadata.xml23
10 files changed, 411 insertions, 0 deletions
diff --git a/app-admin/conserver/Manifest b/app-admin/conserver/Manifest
new file mode 100644
index 000000000000..4fee7ef33d12
--- /dev/null
+++ b/app-admin/conserver/Manifest
@@ -0,0 +1 @@
+DIST conserver-8.1.18.tar.gz 323247 SHA256 3c73cebf732419c41c7c860032e41d83c1f152fe3115a30dc9851820b7864e14 SHA512 a8029aef5fd84f93eb3ae56ba7f751d79a6065c012bfd805e050f8c9edf09fd660c272d3f3ce0a47cfb17678574babbecad63f8bfd50ad4fdccdbabc2249435f WHIRLPOOL e12e54f2af25ef696ecf61818da0dd8cd09c23ca03e0fbb8445ee8eca5dc4ec2dbb25e88a68ac4a51c49b89838bf875ac65ac0e59d49337f36aa3929aa02dc81
diff --git a/app-admin/conserver/conserver-8.1.18-r1.ebuild b/app-admin/conserver/conserver-8.1.18-r1.ebuild
new file mode 100644
index 000000000000..5c918854667a
--- /dev/null
+++ b/app-admin/conserver/conserver-8.1.18-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit ssl-cert eutils pam autotools
+
+DESCRIPTION="Serial Console Manager"
+HOMEPAGE="http://www.conserver.com/"
+SRC_URI="http://www.conserver.com/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="kerberos pam ssl tcpd debug"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6g )
+ pam? ( virtual/pam )
+ tcpd? ( sys-apps/tcp-wrappers )
+ debug? ( dev-libs/dmalloc )
+ kerberos? (
+ virtual/krb5
+ net-libs/libgssglue
+ )"
+RDEPEND="${DEPEND}
+ pam? ( >=sys-auth/pambase-20080219.1 )"
+
+src_prepare() {
+ # Apply patch to prevent package from stripping binaries
+ epatch "${FILESDIR}"/${PN}-prestrip.patch
+
+ # Apply patch to use custom dmalloc macro
+ epatch "${FILESDIR}"/${P}-dmalloc.patch
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with ssl openssl) \
+ $(use_with pam) \
+ $(use_with tcpd libwrap) \
+ $(use_with debug dmalloc) \
+ $(use_with kerberos gssapi) \
+ --with-logfile=/var/log/conserver.log \
+ --with-pidfile=/var/run/conserver.pid \
+ --with-cffile=conserver/conserver.cf \
+ --with-pwdfile=conserver/conserver.passwd \
+ --with-master=localhost \
+ --with-port=7782
+}
+
+src_install() {
+ emake DESTDIR="${D}" exampledir="/usr/share/doc/${PF}/examples" install
+
+ ## create data directory
+ dodir /var/consoles
+ fowners daemon:daemon /var/consoles
+ fperms 700 /var/consoles
+
+ ## add startup and sample config
+ newinitd "${FILESDIR}"/conserver.initd-r1 conserver
+ newconfd "${FILESDIR}"/conserver.confd conserver
+
+ dodir /etc/conserver
+ fperms 700 /etc/conserver
+ insinto /etc/conserver
+ newins "${S}"/conserver.cf/conserver.cf conserver.cf.sample
+ newins "${S}"/conserver.cf/conserver.passwd conserver.passwd.sample
+
+ ## add docs
+ dohtml conserver.html
+ dodoc CHANGES FAQ PROTOCOL README TODO
+ dodoc conserver/Sun-serial contrib/maketestcerts
+ newdoc conserver.cf/conserver.cf conserver.cf.sample
+
+ # Add pam config
+ newpamd "${FILESDIR}"/conserver.pam-pambase conserver
+}
+
+pkg_postinst() {
+ # Add certs if SSL use flag is enabled
+ if use ssl && [ ! -f "${ROOT}"/etc/ssl/conserver/conserver.key ]; then
+ install_cert /etc/ssl/conserver/conserver
+ fi
+}
diff --git a/app-admin/conserver/conserver-8.1.18.ebuild b/app-admin/conserver/conserver-8.1.18.ebuild
new file mode 100644
index 000000000000..4d4b1e78842d
--- /dev/null
+++ b/app-admin/conserver/conserver-8.1.18.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit ssl-cert eutils pam autotools
+
+DESCRIPTION="Serial Console Manager"
+HOMEPAGE="http://www.conserver.com/"
+SRC_URI="http://www.conserver.com/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE="kerberos pam ssl tcpd debug"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6g )
+ pam? ( virtual/pam )
+ tcpd? ( sys-apps/tcp-wrappers )
+ debug? ( dev-libs/dmalloc )
+ kerberos? (
+ virtual/krb5
+ net-libs/libgssglue
+ )"
+RDEPEND="${DEPEND}
+ pam? ( >=sys-auth/pambase-20080219.1 )"
+
+src_prepare() {
+ # Apply patch to prevent package from stripping binaries
+ epatch "${FILESDIR}"/${PN}-prestrip.patch
+
+ # Apply patch to use custom dmalloc macro
+ epatch "${FILESDIR}"/${P}-dmalloc.patch
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with ssl openssl) \
+ $(use_with pam) \
+ $(use_with tcpd libwrap) \
+ $(use_with debug dmalloc) \
+ $(use_with kerberos gssapi) \
+ --with-logfile=/var/log/conserver.log \
+ --with-pidfile=/var/run/conserver.pid \
+ --with-cffile=conserver/conserver.cf \
+ --with-pwdfile=conserver/conserver.passwd \
+ --with-master=localhost \
+ --with-port=7782
+}
+
+src_install() {
+ emake DESTDIR="${D}" exampledir="/usr/share/doc/${PF}/examples" install
+
+ ## create data directory
+ dodir /var/consoles
+ fowners daemon:daemon /var/consoles
+ fperms 700 /var/consoles
+
+ ## add startup and sample config
+ newinitd "${FILESDIR}"/conserver.initd conserver
+ newconfd "${FILESDIR}"/conserver.confd conserver
+
+ dodir /etc/conserver
+ fperms 700 /etc/conserver
+ insinto /etc/conserver
+ newins "${S}"/conserver.cf/conserver.cf conserver.cf.sample
+ newins "${S}"/conserver.cf/conserver.passwd conserver.passwd.sample
+
+ ## add docs
+ dohtml conserver.html
+ dodoc CHANGES FAQ PROTOCOL README TODO
+ dodoc conserver/Sun-serial contrib/maketestcerts
+ newdoc conserver.cf/conserver.cf conserver.cf.sample
+
+ # Add pam config
+ newpamd "${FILESDIR}"/conserver.pam-pambase conserver
+}
+
+pkg_postinst() {
+ # Add certs if SSL use flag is enabled
+ if use ssl && [ ! -f "${ROOT}"/etc/ssl/conserver/conserver.key ]; then
+ install_cert /etc/ssl/conserver/conserver
+ fi
+}
diff --git a/app-admin/conserver/files/conserver-8.1.18-dmalloc.patch b/app-admin/conserver/files/conserver-8.1.18-dmalloc.patch
new file mode 100644
index 000000000000..ff82f74b261c
--- /dev/null
+++ b/app-admin/conserver/files/conserver-8.1.18-dmalloc.patch
@@ -0,0 +1,100 @@
+--- configure.in 2011-08-19 01:11:06.000000000 -0400
++++ configure.in 2011-08-19 02:06:50.000000000 -0400
+@@ -320,6 +320,8 @@
+ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
+
++AM_WITH_DMALLOC([cons_with_dmalloc="YES"],[cons_with_dmalloc="NO"])
++
+ dnl ### Compiler characteristics. ##################################
+ AC_AIX
+ AC_C_CONST
+@@ -578,51 +580,6 @@
+ fi]
+ )
+
+-cons_with_dmalloc="NO"
+-AC_ARG_WITH(dmalloc,
+- AS_HELP_STRING([--with-dmalloc@<:@=PATH@:>@],
+- [Compile in dmalloc support]),
+- [if test "$withval" != "no"; then
+- if test "$withval" != "yes"; then
+- DMALLOCCPPFLAGS="-I$withval/include"
+- if test "$use_dash_r" != "yes"; then
+- DMALLOCLDFLAGS="-L$withval/lib"
+- else
+- DMALLOCLDFLAGS="-L$withval/lib -R$withval/lib"
+- fi
+- else
+- DMALLOCCPPFLAGS=""
+- DMALLOCLDFLAGS=""
+- fi
+-
+- oCPPFLAGS="$CPPFLAGS"
+- oLDFLAGS="$LDFLAGS"
+- oLIBS="$LIBS"
+- have_dmalloc=no
+-
+- CPPFLAGS="$CPPFLAGS $DMALLOCCPPFLAGS"
+- LDFLAGS="$LDFLAGS $DMALLOCLDFLAGS"
+-
+- AC_CHECK_HEADER([dmalloc.h],
+- [LIBS="$LIBS -ldmalloc"
+- AC_MSG_CHECKING(for dmalloc libraries -ldmalloc)
+- AC_TRY_LINK([#include <dmalloc.h>
+- ],[dmalloc_debug(0)],
+- [AC_MSG_RESULT(yes)
+- cons_with_dmalloc="YES"
+- AC_DEFINE(HAVE_DMALLOC)
+- have_dmalloc=yes],
+- [AC_MSG_RESULT(no)])],)
+-
+- if test $have_dmalloc = no; then
+- LIBS="$oLIBS"
+- CPPFLAGS="$oCPPFLAGS"
+- LDFLAGS="$oLDFLAGS"
+- fi
+- fi]
+-)
+-
+-
+ dnl ### Check for needed functions. ################################
+
+ dnl dnl The following basically stollen from the less-358 distribution, but
+--- /dev/null 2011-08-07 13:18:05.535976733 -0400
++++ m4/dmalloc.m4 2011-08-19 03:49:03.755073497 -0400
+@@ -0,0 +1,34 @@
++## ----------------------------------- ## -*- Autoconf -*-
++## Check if --with-dmalloc was given. ##
++## From Franc,ois Pinard ##
++## ----------------------------------- ##
++
++# Copyright (C) 1996, 1998, 1999, 2000, 2001, 2002, 2003, 2005, 2010,
++# 2011 Free Software Foundation, Inc.
++#
++# This file is free software; the Free Software Foundation
++# gives unlimited permission to copy and/or distribute it,
++# with or without modifications, as long as this notice is preserved.
++
++# serial 7
++
++dnl AM_WITH_DMALLOC([ACTION-IF-FOUND],[ACTION-IF-NOT])
++AC_DEFUN([AM_WITH_DMALLOC],
++[AC_MSG_CHECKING([if malloc debugging is wanted])
++AC_ARG_WITH([dmalloc],
++[AS_HELP_STRING([--with-dmalloc],
++ [use dmalloc, as in http://www.dmalloc.com])],
++[if test "$withval" = yes; then
++ AC_MSG_RESULT([yes])
++ AC_DEFINE([WITH_DMALLOC], [1],
++ [Define if using the dmalloc debugging malloc package])
++ LIBS="$LIBS -ldmalloc"
++ LDFLAGS="$LDFLAGS -g"
++ [$1]
++else
++ AC_MSG_RESULT([no])
++ [$2]
++fi], [AC_MSG_RESULT([no])])
++])
++
++AU_DEFUN([fp_WITH_DMALLOC], [AM_WITH_DMALLOC])
diff --git a/app-admin/conserver/files/conserver-prestrip.patch b/app-admin/conserver/files/conserver-prestrip.patch
new file mode 100644
index 000000000000..e67c49da1a66
--- /dev/null
+++ b/app-admin/conserver/files/conserver-prestrip.patch
@@ -0,0 +1,24 @@
+diff -Nuar conserver-8.1.14.orig/conserver/Makefile.in conserver-8.1.14/conserver/Makefile.in
+--- conserver-8.1.14.orig/conserver/Makefile.in 2006-10-25 17:41:00.398082243 -0600
++++ conserver-8.1.14/conserver/Makefile.in 2006-10-25 17:41:27.876759095 -0600
+@@ -13,7 +13,7 @@
+
+ ### Installation programs and flags
+ INSTALL = @INSTALL@
+-INSTALL_PROGRAM = @INSTALL_PROGRAM@ -s
++INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ LN_S = @LN_S@
+ MKDIR = @MKDIR@
+
+diff -Nuar conserver-8.1.14.orig/console/Makefile.in conserver-8.1.14/console/Makefile.in
+--- conserver-8.1.14.orig/console/Makefile.in 2006-10-25 17:41:00.401081662 -0600
++++ conserver-8.1.14/console/Makefile.in 2006-10-25 17:41:18.188635834 -0600
+@@ -9,7 +9,7 @@
+
+ ### Installation programs and flags
+ INSTALL = @INSTALL@
+-INSTALL_PROGRAM = @INSTALL_PROGRAM@ -s
++INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ LN_S = @LN_S@
+ MKDIR = @MKDIR@
+
diff --git a/app-admin/conserver/files/conserver.confd b/app-admin/conserver/files/conserver.confd
new file mode 100644
index 000000000000..abbee0b338e2
--- /dev/null
+++ b/app-admin/conserver/files/conserver.confd
@@ -0,0 +1,7 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+## Config file for /etc/init.d/conserver
+
+CONSERVER_OPTS="-d"
diff --git a/app-admin/conserver/files/conserver.initd b/app-admin/conserver/files/conserver.initd
new file mode 100644
index 000000000000..358a17ef744a
--- /dev/null
+++ b/app-admin/conserver/files/conserver.initd
@@ -0,0 +1,38 @@
+#!/sbin/runscript
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need clock
+}
+
+checkconfig() {
+ if [ ! -e /etc/conserver/conserver.cf ] ; then
+ eerror "You need to create /etc/conserver/conserver.cf first."
+ eerror "A sample is placed there to be renamed and ajusted."
+ eerror "Read the man page or see /usr/share/doc/conserver-<version>/."
+ return 1
+ fi
+
+ if [ ! -e /etc/conserver/conserver.passwd ] ; then
+ eerror "You need to create /etc/conserver/conserver.passwd first."
+ eerror "A sample is placed there to be renamed and ajusted."
+ eerror "Read the man page or see /usr/share/doc/conserver-<version>/."
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting conserver"
+ start-stop-daemon --start --quiet --exec \
+ /usr/sbin/conserver -- ${CONSERVER_OPTS} 1>/dev/null
+ eend $? "Failed to start conserver"
+}
+
+stop() {
+ ebegin "Stopping conserver"
+ start-stop-daemon --stop --quiet --pidfile /var/run/conserver.pid
+ eend $? "Failed to stop conserver"
+}
diff --git a/app-admin/conserver/files/conserver.initd-r1 b/app-admin/conserver/files/conserver.initd-r1
new file mode 100644
index 000000000000..7f4cf32b433c
--- /dev/null
+++ b/app-admin/conserver/files/conserver.initd-r1
@@ -0,0 +1,38 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need clock
+}
+
+checkconfig() {
+ if [ ! -e /etc/conserver/conserver.cf ] ; then
+ eerror "You need to create /etc/conserver/conserver.cf first."
+ eerror "A sample is placed there to be renamed and ajusted."
+ eerror "Read the man page or see /usr/share/doc/conserver-<version>/."
+ return 1
+ fi
+
+ if [ ! -e /etc/conserver/conserver.passwd ] ; then
+ eerror "You need to create /etc/conserver/conserver.passwd first."
+ eerror "A sample is placed there to be renamed and ajusted."
+ eerror "Read the man page or see /usr/share/doc/conserver-<version>/."
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting conserver"
+ start-stop-daemon --start --quiet --pidfile /var/run/conserver.pid --exec \
+ /usr/sbin/conserver -- ${CONSERVER_OPTS} 1>/dev/null
+ eend $? "Failed to start conserver"
+}
+
+stop() {
+ ebegin "Stopping conserver"
+ start-stop-daemon --stop --quiet --pidfile /var/run/conserver.pid
+ eend $? "Failed to stop conserver"
+}
diff --git a/app-admin/conserver/files/conserver.pam-pambase b/app-admin/conserver/files/conserver.pam-pambase
new file mode 100644
index 000000000000..30025fe1403e
--- /dev/null
+++ b/app-admin/conserver/files/conserver.pam-pambase
@@ -0,0 +1,6 @@
+auth required pam_securetty.so
+auth include system-remote-login
+
+account include system-remote-login
+password include system-remote-login
+session include system-remote-login
diff --git a/app-admin/conserver/metadata.xml b/app-admin/conserver/metadata.xml
new file mode 100644
index 000000000000..c3a63c8f01d2
--- /dev/null
+++ b/app-admin/conserver/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>dan@danweeks.net</email>
+ <name>Dan Weeks</name>
+ <description>Maintainer. Assign bugs to him</description>
+ </maintainer>
+ <longdescription>
+ Conserver is an application that allows multiple users to watch a serial
+ console at the same time. It can log the data, allows users to take
+ write-access of a console (one at a time), and has a variety of bells
+ and whistles to accentuate that basic functionality. The idea is that
+ conserver will log all your serial traffic so you can go back and review
+ why something crashed, look at changes (if done on the console), or tie
+ the console logs into a monitoring system (just watch the logfiles it
+ creates). With multi-user capabilities you can work on equipment with
+ others, mentor, train, etc. It also does all that client-server stuff so
+ that, assuming you have a network connection, you can interact with any
+ of the equipment from home or wherever.
+ </longdescription>
+</pkgmetadata>