summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2017-11-18 12:31:16 +0100
committerDaniel Pielmeier <billie@gentoo.org>2017-11-18 12:31:38 +0100
commit556e6f84b755f0ef2481d4f51f910ba3d81177b5 (patch)
tree01fadb23fefb0f0e622e05ad7b0fef76a05e0b7a /app-admin/conky
parentx11-misc/evolvotron: Version bump. (diff)
downloadgentoo-556e6f84b755f0ef2481d4f51f910ba3d81177b5.tar.gz
gentoo-556e6f84b755f0ef2481d4f51f910ba3d81177b5.tar.bz2
gentoo-556e6f84b755f0ef2481d4f51f910ba3d81177b5.zip
app-admin/conky: Fix bug 610444:
Thanks to Daniel Campbell for the report and patch. Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-admin/conky')
-rw-r--r--app-admin/conky/conky-1.10.6-r2.ebuild1
-rw-r--r--app-admin/conky/files/conky-1.10.6-fix-text-shades.patch12
2 files changed, 13 insertions, 0 deletions
diff --git a/app-admin/conky/conky-1.10.6-r2.ebuild b/app-admin/conky/conky-1.10.6-r2.ebuild
index 266ec099c3d4..2f866b427285 100644
--- a/app-admin/conky/conky-1.10.6-r2.ebuild
+++ b/app-admin/conky/conky-1.10.6-r2.ebuild
@@ -76,6 +76,7 @@ DOCS=( README.md TODO ChangeLog NEWS AUTHORS )
PATCHES=(
"${FILESDIR}"/${P}-new_graph-oor.patch
"${FILESDIR}"/${P}-gcc-7.patch
+ "${FILESDIR}"/${P}-fix-text-shades.patch
)
DISABLE_AUTOFORMATTING="yes"
diff --git a/app-admin/conky/files/conky-1.10.6-fix-text-shades.patch b/app-admin/conky/files/conky-1.10.6-fix-text-shades.patch
new file mode 100644
index 000000000000..70b0c52d2a14
--- /dev/null
+++ b/app-admin/conky/files/conky-1.10.6-fix-text-shades.patch
@@ -0,0 +1,12 @@
+--- a/src/conky.cc 2017-02-21 18:00:40.157275779 -0800
++++ b/src/conky.cc 2017-02-21 18:05:16.137077877 -0800
+@@ -1930,7 +1930,9 @@
+
+ static void draw_stuff(void)
+ {
++#ifndef BUILD_X11
+ static int text_offset_x, text_offset_y; /* offset for start position */
++#endif
+ text_offset_x = text_offset_y = 0;
+ #ifdef BUILD_IMLIB2
+ cimlib_render(text_start_x, text_start_y, window.width, window.height);