summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-09-30 08:42:56 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-30 21:11:55 +0300
commitdb4563ee526564b78e2b9a1c02ea5c84e93a06c5 (patch)
tree99629eab2171345a907c7913ca82c0f04c55e9e1 /app-admin/clustershell
parentdev-python/flask: Remove old (diff)
downloadgentoo-db4563ee526564b78e2b9a1c02ea5c84e93a06c5.tar.gz
gentoo-db4563ee526564b78e2b9a1c02ea5c84e93a06c5.tar.bz2
gentoo-db4563ee526564b78e2b9a1c02ea5c84e93a06c5.zip
app-admin/clustershell: add 1.9.2
- Switch to PyPI sources - Enable py3.12 - Move RDEPEND before BDEPEND, which is more common ordering. - Use unittest module instead of unittest_or_fail for py3.12, where unittest_or_fail does not exist. Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-admin/clustershell')
-rw-r--r--app-admin/clustershell/Manifest1
-rw-r--r--app-admin/clustershell/clustershell-1.9.2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/clustershell/Manifest b/app-admin/clustershell/Manifest
index 4f24250d57e5..fc0275cc9a2c 100644
--- a/app-admin/clustershell/Manifest
+++ b/app-admin/clustershell/Manifest
@@ -1 +1,2 @@
+DIST ClusterShell-1.9.2.tar.gz 400880 BLAKE2B d10c78696268cabd001e1da1c28f1850d6b2fd9d20e73f9aeab378c855a0b937f32d706869e2d3fcdf109b2e98175abbec8f06fe0c6d2c4139d2da14f1c5b610 SHA512 852c9dcbe333965fa853e4360da7305c448dc037348ede18c0417d763e68d4bafad0a60480fce421f1815a86dd0a20e07d32fd8828aa185e7e1b88ed292014fc
DIST clustershell-1.9.1.gh.tar.gz 383917 BLAKE2B 90d8c8390453a2c843bbb909a741d24d5f8e4b8eb03631bbe81b98973fce95d96dd3e68d0b951bc23d067057222c858e5041a3bafde200e0e2d14a0be995689f SHA512 32ee8b43d92e7ada8c81facc6a0609c39beee9189fa6fb9c2237387a58134f99fb2e6ab6e5de35c8e6fc8d3cef57f74f4c08b14968484546859071dff2594eb1
diff --git a/app-admin/clustershell/clustershell-1.9.2.ebuild b/app-admin/clustershell/clustershell-1.9.2.ebuild
new file mode 100644
index 000000000000..b232e41774fa
--- /dev/null
+++ b/app-admin/clustershell/clustershell-1.9.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=ClusterShell
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python framework for efficient cluster administration"
+HOMEPAGE="https://github.com/cea-hpc/clustershell/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ app-shells/pdsh
+ virtual/openssh
+ sys-devel/bc
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ default
+
+ # remove test sets that require working ssh connection
+ rm tests/{CLIClush,TaskDistant*}Test.py || die
+}
+
+python_test() {
+ cd tests || die
+ local runner=unittest_or_fail
+ if [[ ${EPYTHON} == python3.12 ]]; then
+ runner=unittest
+ fi
+ # Automatic discovery does not work
+ "${EPYTHON}" -m "${runner}" -v *.py || die "Tests failed with ${EPYTHON}"
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}
+
+pkg_postinst() {
+ einfo "Some default system-wide config files have been installed into"
+ einfo "/etc/${PN}"
+}