summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/bastille
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/bastille')
-rw-r--r--app-admin/bastille/Manifest2
-rw-r--r--app-admin/bastille/bastille-3.0.9-r1.ebuild70
-rw-r--r--app-admin/bastille/files/bastille-3.0.9-perl.patch25
-rw-r--r--app-admin/bastille/metadata.xml9
4 files changed, 106 insertions, 0 deletions
diff --git a/app-admin/bastille/Manifest b/app-admin/bastille/Manifest
new file mode 100644
index 000000000000..ae837f777488
--- /dev/null
+++ b/app-admin/bastille/Manifest
@@ -0,0 +1,2 @@
+DIST Bastille-3.0.9.tar.bz2 319045 SHA256 1fd66ef724441a36459d5f937ce76c3bb9f7ccc9584d318a916ff59f709fc02d SHA512 a97ab2c2bb64c655d43ddcfd4000cee8666787e5b5923390e3155b258c3a2cf7d131abd474f9b0dd415eb455b664ab26a875da6636268b2a715ea87dd4dae2f0 WHIRLPOOL 5e2044814844d6779dcdd9d8154696502936a73fd599f630c18ff218b32c75edb094a3c3b50ec496d6db05a0569f3df08f423f65f86ca4de98bca3888aac48b6
+DIST bastille-3.0.9-gentoo-0.2.patch.bz2 14117 SHA256 91773f8fda6aa67dd87c4451f04ed525965c7408590281b960a3e717ff57880c SHA512 a4ecfc064d6cf8c12b6f53c81dea841931df270293b03c39266861121f3def28fcbc4127b3bc9374028983e584736fb85361443badaadec7441cfb1570bdea8f WHIRLPOOL 624d539d140b540e29e453d178afd23f6ba8d8f1584309852eee2f73c179f1d8e5eb907ddaddc939c4b47a5581400956c7c5a17fb9c039ed54cda49d22144c00
diff --git a/app-admin/bastille/bastille-3.0.9-r1.ebuild b/app-admin/bastille/bastille-3.0.9-r1.ebuild
new file mode 100644
index 000000000000..9b8a129ad736
--- /dev/null
+++ b/app-admin/bastille/bastille-3.0.9-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PERL_EXPORT_PHASE_FUNCTIONS=no
+inherit eutils perl-module
+
+PATCHVER=0.2
+MY_PN=${PN/b/B}
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_PN}
+DESCRIPTION="Bastille-Linux is a security hardening tool"
+HOMEPAGE="http://bastille-linux.org/"
+SRC_URI="mirror://sourceforge/${PN}-linux/${MY_P}.tar.bz2
+ mirror://gentoo/${P}-gentoo-${PATCHVER}.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+IUSE="X"
+
+RDEPEND="
+ net-firewall/iptables
+ app-admin/logrotate
+ dev-perl/Curses
+ net-firewall/psad
+ X? ( dev-perl/perl-tk )
+ virtual/logger
+"
+
+src_prepare() {
+ epatch "${WORKDIR}"/${P}-gentoo-${PATCHVER}.patch
+
+ # make sure the Perl modules go into vendor dir
+ epatch "${FILESDIR}/${P}-perl.patch"
+ perl_set_version
+
+ cd "${S}"
+ chmod a+x Install.sh bastille-ipchains bastille-netfilter
+}
+
+src_install() {
+ perl_set_version
+ export VENDOR_LIB
+
+ cd "${S}"
+ DESTDIR="${D}" ./Install.sh
+
+ # Example configs
+ cd "${S}"
+ insinto /usr/share/Bastille
+ doins *.config
+
+ newinitd ${PN}-firewall.gentoo-init ${PN}-firewall
+
+ # Documentation
+ cd "${S}"
+ dodoc *.txt BUGS Change* README*
+ cd "${S}"/docs
+ doman *.1m
+}
+
+pkg_postinst() {
+ elog "Please be aware that when using the Server Lax, Server Moderate, or"
+ elog "Server Paranoia configurations, you may need to use InteractiveBastille"
+ elog "to set any advanced network information, such as masquerading and"
+ elog "internal interfaces, if you plan to use them."
+}
diff --git a/app-admin/bastille/files/bastille-3.0.9-perl.patch b/app-admin/bastille/files/bastille-3.0.9-perl.patch
new file mode 100644
index 000000000000..ab109093bc14
--- /dev/null
+++ b/app-admin/bastille/files/bastille-3.0.9-perl.patch
@@ -0,0 +1,25 @@
+diff -ruN Bastille-gentoo-2/Install.sh Bastille/Install.sh
+--- Bastille-gentoo-2/Install.sh 2014-12-09 23:05:55.674808824 +0100
++++ Bastille/Install.sh 2014-12-09 23:17:25.907847419 +0100
+@@ -3,7 +3,7 @@
+ umask 077
+
+ mkdir -p ${DESTDIR}/usr/sbin
+-mkdir -p ${DESTDIR}/usr/lib/perl5/site_perl/Curses
++mkdir -p ${DESTDIR}/${VENDOR_LIB}/Curses
+ mkdir -p ${DESTDIR}/usr/lib/Bastille
+ mkdir -p ${DESTDIR}/usr/share/Bastille
+ mkdir -p ${DESTDIR}/usr/share/Bastille/OSMap
+@@ -13,9 +13,9 @@
+
+ cp AutomatedBastille ${DESTDIR}/usr/sbin/
+ cp BastilleBackEnd ${DESTDIR}/usr/sbin
+-cp Bastille_Curses.pm ${DESTDIR}/usr/lib/perl5/site_perl
+-cp Bastille_Tk.pm ${DESTDIR}/usr/lib/perl5/site_perl
+-cp Curses/Widgets.pm ${DESTDIR}/usr/lib/perl5/site_perl/Curses
++cp Bastille_Curses.pm ${DESTDIR}/${VENDOR_LIB}
++cp Bastille_Tk.pm ${DESTDIR}/${VENDOR_LIB}
++cp Curses/Widgets.pm ${DESTDIR}/${VENDOR_LIB}/Curses
+ cp InteractiveBastille ${DESTDIR}/usr/sbin
+ # Questions.txt has been replaced by Modules.txt and Questions/
+ #cp Questions.txt ${DESTDIR}/usr/share/Bastille
diff --git a/app-admin/bastille/metadata.xml b/app-admin/bastille/metadata.xml
new file mode 100644
index 000000000000..c60ce0ba2450
--- /dev/null
+++ b/app-admin/bastille/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>hardened</herd>
+ <longdescription>The Bastille Hardening System attempts to "harden" or "tighten" Unix operating systems.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">bastille-linux</remote-id>
+ </upstream>
+</pkgmetadata>