summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-09 05:28:00 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-09 06:26:21 +0100
commitd2a60c8a358e36856a8f47fb68de6db1a265923a (patch)
tree28ba32e359980c9c81bd069c01380e3d26f1a926 /app-admin/awscli
parentdev-python/boto3: Bump to 1.35.95 (diff)
downloadgentoo-d2a60c8a358e36856a8f47fb68de6db1a265923a.tar.gz
gentoo-d2a60c8a358e36856a8f47fb68de6db1a265923a.tar.bz2
gentoo-d2a60c8a358e36856a8f47fb68de6db1a265923a.zip
app-admin/awscli: Bump to 1.36.36
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.36.36.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 35e7aec2dd3b..2944340dc2b3 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,3 +3,4 @@ DIST aws-cli-1.36.31.gh.tar.gz 2876521 BLAKE2B 6ba90d3852b25608bb908b3853bff3de7
DIST aws-cli-1.36.33.gh.tar.gz 2877337 BLAKE2B 0e3cdbac864370c0ef785191fc692e1a28c81467fac6e8bc5840b6fa79ef6b09583ce70f85b2220538c587ddf4c320aef9ba2cb9bfaaa30c68f0498556b256f0 SHA512 78a106f0fd30eef9f6e0d48800fd7f2144ffd7a01adf669d6d84ab5f064045a6c163bbd042a788c3d51a70060165f0d29a603734ac43680afcb4711dc8e31b53
DIST aws-cli-1.36.34.gh.tar.gz 2877281 BLAKE2B e6e5e7cba252891e22de98bdb7a3791486e8a1a729acedecb57a70471487f4b31fb7bd35cc91d15b7831b0f4963ff44371ce11c6d62ff9fc8fe737748b66f5ca SHA512 793c97eebe32b60125f13989fc49aa0dc12963b9a596b9d38ce58cacaeebeff128b4bdb0647ab38af54fbe5972e15b24ec3326c4c213e7647cd77fa286135781
DIST aws-cli-1.36.35.gh.tar.gz 2875492 BLAKE2B 7484dcc22a3a8e74f5c12f572f3cc32e013db052ed8c5792666fb3cc1a1ab4cc1d8fb744895f48d9ad62939d5d7915a288306b947e2a9ce73320346e42f1760d SHA512 b96fc97f4663bc2e7d9ee5dbca0fec323e3ecb5485648882c2e2288bd35a4f50b8ee3dd015f4e55cdfc95460cb9f380cd845d0c5ffc3ddd66f4fa392b77052b8
+DIST aws-cli-1.36.36.gh.tar.gz 2875582 BLAKE2B fa7d3fa63155e081a358dec7e1b82887d01f11a2936babb83a6f279f86db31aba6cc662b6ccadd505739aba9e9f63578f1f74e7e602b3b9199b57b23518a5de9 SHA512 dbe018b10815461f192d7310950657cd7011730ac7d0f1889a57b51eecb63d4302d2a24db7b98c3500095edcd0841a30734f46e4073976734f8206253bf54db6
diff --git a/app-admin/awscli/awscli-1.36.36.ebuild b/app-admin/awscli/awscli-1.36.36.ebuild
new file mode 100644
index 000000000000..cffe1be806db
--- /dev/null
+++ b/app-admin/awscli/awscli-1.36.36.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y-1).(z+59)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) - 1)).$(( $(ver_cut 3-) + 59 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=(
+ "${serial_tests[@]}"
+
+ # flaky (some ordering?)
+ tests/functional/s3/test_cp_command.py::TestCPCommand::test_multipart_upload_with_checksum_algorithm_crc32
+ )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}