summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-13 07:06:40 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-13 07:30:06 +0200
commit46f7e9fe25cb634f1696352cd55f057f4bc02949 (patch)
tree7978812738adfb8e586c93e8db0958b4a13f4e20 /app-admin/awscli
parentdev-python/boto3: Bump to 1.21.39 (diff)
downloadgentoo-46f7e9fe25cb634f1696352cd55f057f4bc02949.tar.gz
gentoo-46f7e9fe25cb634f1696352cd55f057f4bc02949.tar.bz2
gentoo-46f7e9fe25cb634f1696352cd55f057f4bc02949.zip
app-admin/awscli: Bump to 1.22.94
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.22.94.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 9271a27d5820..583ec6c7d2c3 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -5,3 +5,4 @@ DIST awscli-1.22.90.tar.gz 2186538 BLAKE2B 16b1942ee9fa65240a1b8b045b8e3e8659cc2
DIST awscli-1.22.91.tar.gz 2186925 BLAKE2B e7f6b4a5dce1b0f2752621628a28c7af75ce175b268c1b87a6516ad4bbc83738afdbef52d23e050febd3c351006aad2ecec9ce6d3052454b4f9352d3d5cde143 SHA512 b14e1d2da753ded2e90d72619ab205d9af6ec561cf01a8cbb09931a70338e50a8efe4555633f695ab4a486670e31e48ee1eba13e3943a728502e3aa0783f4c51
DIST awscli-1.22.92.tar.gz 2187466 BLAKE2B 570e2fbb3efa0cf1664acbe6cd995799b98142ccea4fb36a967e3b3a77da4947295b4c0c9376a6c8780c0c9109ebe2e1a5e24dfd6cfb758960a6df24b8296f0c SHA512 022b9c12a71eaf62a6bea30df33d9f30ee309c77690cb6b08b770e987adf3e5cf8581b0a097c0f4466c73e82d1daacc42cd73eff48390ef3c5ca3cc49bc37a23
DIST awscli-1.22.93.tar.gz 2187925 BLAKE2B c4b13aada04aea6b320c9b93c83cce11a4081e6b13cb7e3a83f2ee2ba651de4dbf636cfaefeee049a5ab91519bbfa6bbea37bd5a0a06a84979684bbf7c90c65c SHA512 c13d363ffff11fe30d3b78966caebb9026bcdbb4a6b9eb6e641de4955f9f360b6a4ecae25e1315d3e4943ea341f0f4c3be2aacf5849be3906d1fb0b0a9102490
+DIST awscli-1.22.94.tar.gz 2194607 BLAKE2B 985ce46ac8c3a12abc983fda4d424dbfa5c5da26c5552af9895079bc1aaa925e7f0c35f469f6b7f917007e162ce340adc68e4ae1c79f72c673bdf965ee550cfa SHA512 d34ad97d50de64591f0239de94b81d2ab77f8f4e284a356abe684bcd4c4d8f4a2d5e47d67e7b59322898d4f5b3503991eb550a424f894001aec547fe07e58923
diff --git a/app-admin/awscli/awscli-1.22.94.ebuild b/app-admin/awscli/awscli-1.22.94.ebuild
new file mode 100644
index 000000000000..2040c8cb81d2
--- /dev/null
+++ b/app-admin/awscli/awscli-1.22.94.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# awscli 1.22.55 → botocore 1.24.0
+# so botocore is x.(y+2).(z-55)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(( $(ver_cut 3-) - 55))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}