summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-01-18 00:11:34 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2019-01-18 00:11:34 -0600
commitc2a66c3e7c7b3c5d9bcaa73030b3d7f1b7a60e5d (patch)
tree4ce65543f4b7d889c223ea6adcd17d52863ca90f /app-admin/ansible/ansible-2.6.12.ebuild
parentsys-apps/portage: remove old version 2.3.55 (diff)
downloadgentoo-c2a66c3e7c7b3c5d9bcaa73030b3d7f1b7a60e5d.tar.gz
gentoo-c2a66c3e7c7b3c5d9bcaa73030b3d7f1b7a60e5d.tar.bz2
gentoo-c2a66c3e7c7b3c5d9bcaa73030b3d7f1b7a60e5d.zip
app-admin/ansible: 2.6.12 and 2.7.6 bump
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/ansible/ansible-2.6.12.ebuild')
-rw-r--r--app-admin/ansible/ansible-2.6.12.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/app-admin/ansible/ansible-2.6.12.ebuild b/app-admin/ansible/ansible-2.6.12.ebuild
new file mode 100644
index 000000000000..4bec3453ac7f
--- /dev/null
+++ b/app-admin/ansible/ansible-2.6.12.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+# not included in release tarball
+RESTRICT="test"
+
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
+ distutils-r1_python_install_all
+
+ doman docs/man/man1/*.1
+ dodoc -r examples
+}