summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-12-01 12:32:36 +0100
committerPacho Ramos <pacho@gentoo.org>2024-12-01 12:36:18 +0100
commit5aca6ea4a58429dafc2339e1a0c0884809cc6c82 (patch)
tree4ef033ab67e0540805311a7e9c9000c260a2d6ac /app-accessibility
parentmedia-fonts/noto: drop 20240731 (diff)
downloadgentoo-5aca6ea4a58429dafc2339e1a0c0884809cc6c82.tar.gz
gentoo-5aca6ea4a58429dafc2339e1a0c0884809cc6c82.tar.bz2
gentoo-5aca6ea4a58429dafc2339e1a0c0884809cc6c82.zip
app-accessibility/orca: Fix shebangs and update homepage
Thanks-to: Squeaktoy Closes: https://bugs.gentoo.org/939905 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/orca/orca-46.2-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/app-accessibility/orca/orca-46.2-r1.ebuild b/app-accessibility/orca/orca-46.2-r1.ebuild
new file mode 100644
index 000000000000..d7404591ef65
--- /dev/null
+++ b/app-accessibility/orca/orca-46.2-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit gnome2 meson python-single-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://orca.gnome.org/"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-core-2.50:2[introspection]
+ >=dev-libs/glib-2.28:2
+ media-libs/gstreamer:1.0[introspection]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.18:3[${PYTHON_USEDEP}]
+ ')
+ braille? (
+ $(python_gen_cond_dep '
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[${PYTHON_SINGLE_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.46[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ ')
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_configure() {
+ local emesonargs=(
+ -Dspiel=false # spiel not yet in gentoo
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${ED}"
+ python_optimize
+}