summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-09-02 18:08:21 -0300
committerMatt Turner <mattst88@gentoo.org>2023-09-04 11:42:40 -0400
commit35ed7ea3b226a540dbe5b1e37abe44adff692f1a (patch)
treedb2e00d78edc9d88cb1e2e7ce8e7ce5ed1febc27 /app-accessibility/at-spi2-core
parentapp-dicts/myspell-en: drop 20230801 (diff)
downloadgentoo-35ed7ea3b226a540dbe5b1e37abe44adff692f1a.tar.gz
gentoo-35ed7ea3b226a540dbe5b1e37abe44adff692f1a.tar.bz2
gentoo-35ed7ea3b226a540dbe5b1e37abe44adff692f1a.zip
app-accessibility/at-spi2-core: Version bump to 2.48.4
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32568 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-accessibility/at-spi2-core')
-rw-r--r--app-accessibility/at-spi2-core/Manifest1
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-2.48.4.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/app-accessibility/at-spi2-core/Manifest b/app-accessibility/at-spi2-core/Manifest
index f09fc7e1070e..00559aa222aa 100644
--- a/app-accessibility/at-spi2-core/Manifest
+++ b/app-accessibility/at-spi2-core/Manifest
@@ -1 +1,2 @@
DIST at-spi2-core-2.48.3.tar.xz 554388 BLAKE2B 9692df8cc0bc8de82f6e339b9358be7ab1bc598afdb39503f5f05ca772109b962a513fe2ef79d8f094ea732457225409f3c765784a54cbabf27b8fc72c893eb9 SHA512 e79ef0eb0f23241d61ba2a62f4024a5df5ff7125bc085590f9038b3397d255b88b8266deec14f3fe53bee4072ab85695a47d27d8be0529b18a103ad792fa0e54
+DIST at-spi2-core-2.48.4.tar.xz 554916 BLAKE2B 6329407e1e0d0a085189174ad31ac65d890e36a1b20179d68155fffa029b476a6b094765b6d3c300a8fa3cdeb01936a1b14cac34c530650287e711132c136ddc SHA512 fa85b680ad5254a8281197969f335c69b6c71d3ea4ec04efb8d70ba9feafd76330cd23a09169eef6f04abf0000e4823d2c2591999e8ed88bc035a26ed8bebdf0
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-2.48.4.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-2.48.4.ebuild
new file mode 100644
index 000000000000..5aabf7fa9bcd
--- /dev/null
+++ b/app-accessibility/at-spi2-core/at-spi2-core-2.48.4.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson-multilib systemd virtualx xdg
+
+DESCRIPTION="D-Bus accessibility specifications and registration daemon"
+HOMEPAGE="https://wiki.gnome.org/Accessibility https://gitlab.gnome.org/GNOME/at-spi2-core"
+
+LICENSE="LGPL-2.1+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="X dbus-broker gtk-doc +introspection systemd"
+REQUIRED_USE="
+ dbus-broker? ( systemd )
+ gtk-doc? ( X )
+"
+
+DEPEND="
+ >=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.67.4:2[${MULTILIB_USEDEP}]
+ >=dev-libs/libxml2-2.9.1:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.54.0:= )
+ systemd? ( sys-apps/systemd[${MULTILIB_USEDEP}] )
+ X? (
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ )
+
+ !<dev-libs/atk-2.46.0
+ !<app-accessibility/at-spi2-atk-2.46.0
+"
+RDEPEND="${DEPEND}
+ dbus-broker? ( sys-apps/dbus-broker )
+"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ dev-python/sphinx
+ dev-util/gdbus-codegen
+ >=dev-util/gi-docgen-2021.1
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_bus=$(usex dbus-broker dbus-broker dbus-daemon)
+ $(meson_use systemd use_systemd)
+ -Dsystemd_user_dir="$(systemd_get_userunitdir)"
+ $(meson_native_use_bool gtk-doc docs)
+ $(meson_native_use_feature introspection)
+ $(meson_feature X x11)
+ -Ddisable_p2p=false
+ -Datk_only=false
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ virtx dbus-run-session meson test -C "${BUILD_DIR}" || die
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/{libatspi,atk} || die
+ mv "${ED}"/usr/share/doc/libatspi "${ED}"/usr/share/gtk-doc/libatspi/html || die
+ mv "${ED}"/usr/share/doc/atk "${ED}"/usr/share/gtk-doc/atk/html || die
+ fi
+}