summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-07-11 13:50:38 +0200
committerConrad Kostecki <conikost@gentoo.org>2023-07-12 20:37:31 +0200
commitfe3f50c52954d72ff14636dd560a56cf9c4e2631 (patch)
tree20d6885587a38e66f35220ae5aabff4e378df217
parentx11-misc/xkblayout-state: remove live ebuild (diff)
downloadgentoo-fe3f50c52954d72ff14636dd560a56cf9c4e2631.tar.gz
gentoo-fe3f50c52954d72ff14636dd560a56cf9c4e2631.tar.bz2
gentoo-fe3f50c52954d72ff14636dd560a56cf9c4e2631.zip
x11-misc/xkblayout-state: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/31835 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--x11-misc/xkblayout-state/Manifest1
-rw-r--r--x11-misc/xkblayout-state/xkblayout-state-0_p20211106.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/x11-misc/xkblayout-state/Manifest b/x11-misc/xkblayout-state/Manifest
index a23c24b233aa..d9c77e8013ab 100644
--- a/x11-misc/xkblayout-state/Manifest
+++ b/x11-misc/xkblayout-state/Manifest
@@ -1 +1,2 @@
DIST xkblayout-state-0_p20180118.tar.gz 6853 BLAKE2B 1a8b3a9c89d9647bb8b9f6a2261f2e06f44f408823939268d60364fe532b9501e3c36d8f66cc1160f0b5432874d48046f848159842d09135a6cb4af658a8b248 SHA512 7618e920f8044324b7f4eb58d4e22ce076056d2d911cd950e6a862303c4b37f31f5919fec69c63173a7ff181d51849def4f6a78a407baf3012232f2f423bed00
+DIST xkblayout-state-0_p20211106.tar.gz 7617 BLAKE2B 523a861c7cf79e2fc77ced1c411d54771f3ed4ed236ac89d8c89996a26e6fe4bf0d12f75ade9d9bebb1de9e233dcd6ca838dbf297df6f411caff0a27e47df5b5 SHA512 85d785ed767d1c29cd1710bc07894ebc94a18018afa211202929c82ac10e7efb06e5ce29d8de507cbd4c931d650e3c04e1452f63dad17a99a379e55761dbc15b
diff --git a/x11-misc/xkblayout-state/xkblayout-state-0_p20211106.ebuild b/x11-misc/xkblayout-state/xkblayout-state-0_p20211106.ebuild
new file mode 100644
index 000000000000..765479fe3bb9
--- /dev/null
+++ b/x11-misc/xkblayout-state/xkblayout-state-0_p20211106.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+# Commit Date: 06 Nov 2021
+EGIT_COMMIT="f311779ed95f43f1fdebed0f710ad84057e6fe19"
+
+DESCRIPTION="Small program to get/set the current XKB layout"
+HOMEPAGE="https://github.com/nonpop/xkblayout-state"
+SRC_URI="https://github.com/nonpop/xkblayout-state/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}"/usr DESTDIR="${D}" install
+}