summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-08 15:09:39 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-08 15:17:47 +0100
commitf6c43c529f1e7805a416cb95ce4586afbec20077 (patch)
tree989b894bb6ea02356154fb98308132444383d6f6
parentsci-mathematics/acl2: install TAGS if USE=emacs (diff)
downloadgentoo-f6c43c529f1e7805a416cb95ce4586afbec20077.tar.gz
gentoo-f6c43c529f1e7805a416cb95ce4586afbec20077.tar.bz2
gentoo-f6c43c529f1e7805a416cb95ce4586afbec20077.zip
dev-python/google-api-python-client: Remove Python < 3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.71.0-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.71.0-r1.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.71.0-r1.ebuild
new file mode 100644
index 000000000000..73c0eee57b5d
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.71.0-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_10 )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+SRC_URI="
+ https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}