summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2024-06-16 10:49:25 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2024-06-16 10:49:25 +0000
commitf3d21d934733f83dc93a8c22a166bb1a3aa34d6e (patch)
tree47d0ce274f0f1d2d6fa96640bebf6847867dd19e
parent2024-06-16 10:34:40 UTC (diff)
parentapp-dicts/gwaei: Migrate to yelp (diff)
downloadgentoo-f3d21d934733f83dc93a8c22a166bb1a3aa34d6e.tar.gz
gentoo-f3d21d934733f83dc93a8c22a166bb1a3aa34d6e.tar.bz2
gentoo-f3d21d934733f83dc93a8c22a166bb1a3aa34d6e.zip
Merge updates from master
-rw-r--r--app-dicts/gwaei/files/gwaei-3.6.2-yelp.patch53
-rw-r--r--app-dicts/gwaei/gwaei-3.6.2-r1.ebuild86
-rw-r--r--app-text/lcdf-typetools/lcdf-typetools-2.110.ebuild4
-rw-r--r--app-text/texlive/texlive-2023.ebuild2
-rw-r--r--dev-texlive/texlive-binextra/texlive-binextra-2023_p69527-r3.ebuild2
-rw-r--r--dev-texlive/texlive-langjapanese/texlive-langjapanese-2023_p64603-r1.ebuild2
-rw-r--r--dev-texlive/texlive-xetex/texlive-xetex-2023_p69452-r1.ebuild2
7 files changed, 145 insertions, 6 deletions
diff --git a/app-dicts/gwaei/files/gwaei-3.6.2-yelp.patch b/app-dicts/gwaei/files/gwaei-3.6.2-yelp.patch
new file mode 100644
index 000000000000..a5515561fd59
--- /dev/null
+++ b/app-dicts/gwaei/files/gwaei-3.6.2-yelp.patch
@@ -0,0 +1,53 @@
+---
+ autogen.sh | 1 -
+ configure.ac | 4 +---
+ src/gwaei/help/Makefile.am | 5 +++--
+ 3 files changed, 4 insertions(+), 6 deletions(-)
+
+--- gwaei.git.orig/configure.ac
++++ gwaei.git/configure.ac
+@@ -73,8 +73,6 @@ AM_CONDITIONAL([WITH_MECAB], [test x$mec
+
+ AC_CHECK_LIB(m, sqrt)
+
+-GNOME_DOC_INIT(,,[:])
+-
+ PKG_CHECK_MODULES(LIBWAEI, glib-2.0 >= $GLIB_REQUIRED_VERSION
+ gobject-2.0 >= $GLIB_REQUIRED_VERSION
+ gio-2.0 >= $GIO_REQUIRED_VERSION
+@@ -103,7 +101,7 @@ if test x$gnome = xtrue; then
+ libcurl >= $LIBCURL_REQUIRED_VERSION )
+ AC_SUBST(GWAEI_CFLAGS)
+ AC_SUBST(GWAEI_LIBS)
+- GNOME_DOC_INIT
++ YELP_HELP_INIT
+ fi
+
+ if test x$hunspell = xtrue; then
+--- gwaei.git.orig/src/gwaei/help/Makefile.am
++++ gwaei.git/src/gwaei/help/Makefile.am
+@@ -2,10 +2,12 @@ PACKAGE = @PACKAGE@
+ VERSION = @VERSION@
+ datadir = @datadir@
+
+-include $(top_srcdir)/gnome-doc-utils.make
++@YELP_HELP_RULES@
+ dist-hook: doc-dist-hook
+-DOC_MODULE = gwaei
++HELP_MODULE = gwaei
++HELP_ID = gwaei
+
++HELP_FILES=glossary.xml gwaei.xml
+ cglossarydir = $(datadir)/gnome/help/$(PACKAGE)/C
+ cglossary_DATA = C/glossary.xml
+ EXTRA_DIST = C/glossary.xml
+--- gwaei.git.orig/autogen.sh
++++ gwaei.git/autogen.sh
+@@ -6,7 +6,6 @@ touch ChangeLog
+ libtoolize --force
+ glib-gettextize --copy --force
+ intltoolize --copy --force --automake
+-gnome-doc-prepare --copy --force
+ aclocal -I m4 --force
+ autoheader -f
+ automake --copy --force --add-missing
diff --git a/app-dicts/gwaei/gwaei-3.6.2-r1.ebuild b/app-dicts/gwaei/gwaei-3.6.2-r1.ebuild
new file mode 100644
index 000000000000..0939ac61c424
--- /dev/null
+++ b/app-dicts/gwaei/gwaei-3.6.2-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools gnome2-utils xdg
+
+DESCRIPTION="Japanese-English Dictionary for GNOME"
+HOMEPAGE="https://github.com/zakkudo/gwaei"
+SRC_URI="https://downloads.sourceforge.net/gwaei/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="gtk hunspell nls mecab test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=net-misc/curl-7.20.0
+ >=dev-libs/glib-2.31
+ gtk? (
+ x11-libs/gtk+:3
+ app-text/yelp-tools
+ )
+ hunspell? ( app-text/hunspell )
+ nls? ( virtual/libintl )
+ mecab? ( app-text/mecab )"
+DEPEND="${RDEPEND}
+ gtk? (
+ x11-themes/gnome-icon-theme-symbolic
+ app-text/yelp-tools
+ )"
+BDEPEND="
+ app-text/rarian
+ dev-util/intltool
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.17 )
+ test? (
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/scrollkeeper-dtd
+ )"
+
+PATCHES=(
+ # Migrate away from gnome-doc-utils (from Debian)
+ "${FILESDIR}/${P}-yelp.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_with gtk gnome) \
+ $(use_enable nls) \
+ $(use_with hunspell) \
+ $(use_with mecab)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_preinst() {
+ if use gtk; then
+ gnome2_schemas_savelist
+ xdg_pkg_preinst
+ fi
+}
+
+pkg_postinst() {
+ if use gtk; then
+ gnome2_schemas_update
+ xdg_pkg_postinst
+ fi
+}
+
+pkg_postrm() {
+ if use gtk; then
+ gnome2_schemas_update
+ xdg_pkg_postrm
+ fi
+}
diff --git a/app-text/lcdf-typetools/lcdf-typetools-2.110.ebuild b/app-text/lcdf-typetools/lcdf-typetools-2.110.ebuild
index 18ff420fc49b..9037fe3921ca 100644
--- a/app-text/lcdf-typetools/lcdf-typetools-2.110.ebuild
+++ b/app-text/lcdf-typetools/lcdf-typetools-2.110.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -14,7 +14,7 @@ SRC_URI="https://lcdf.org/type/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+KEYWORDS="~alpha ~amd64 ~arm arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="+kpathsea"
RDEPEND="kpathsea? ( virtual/tex-base dev-libs/kpathsea:= )"
diff --git a/app-text/texlive/texlive-2023.ebuild b/app-text/texlive/texlive-2023.ebuild
index d2f55d5383fe..0784f5241a10 100644
--- a/app-text/texlive/texlive-2023.ebuild
+++ b/app-text/texlive/texlive-2023.ebuild
@@ -8,7 +8,7 @@ HOMEPAGE="http://tug.org/texlive/"
LICENSE="metapackage"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
IUSE="cjk context extra games graphics humanities luatex metapost music pdfannotextractor png pstricks publishers science tex4ht texi2html truetype xetex xml X"
LANGS="af ar as bg bn br ca cs cy da de el en eo es et eu fa fi fr ga gl gu he
diff --git a/dev-texlive/texlive-binextra/texlive-binextra-2023_p69527-r3.ebuild b/dev-texlive/texlive-binextra/texlive-binextra-2023_p69527-r3.ebuild
index 65dea38637c3..1f525639526a 100644
--- a/dev-texlive/texlive-binextra/texlive-binextra-2023_p69527-r3.ebuild
+++ b/dev-texlive/texlive-binextra/texlive-binextra-2023_p69527-r3.ebuild
@@ -204,7 +204,7 @@ DESCRIPTION="TeXLive TeX auxiliary programs"
LICENSE="Apache-2.0 Artistic BSD BSD-2 FDL-1.1+ GPL-1+ GPL-2 GPL-2+ GPL-3 GPL-3+ LGPL-3 LPPL-1.0 LPPL-1.2 LPPL-1.3 LPPL-1.3c MIT TeX TeX-other-free public-domain"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
COMMON_DEPEND="
>=dev-texlive/texlive-basic-2023
"
diff --git a/dev-texlive/texlive-langjapanese/texlive-langjapanese-2023_p64603-r1.ebuild b/dev-texlive/texlive-langjapanese/texlive-langjapanese-2023_p64603-r1.ebuild
index 1c1ff9c04005..5ac24445548a 100644
--- a/dev-texlive/texlive-langjapanese/texlive-langjapanese-2023_p64603-r1.ebuild
+++ b/dev-texlive/texlive-langjapanese/texlive-langjapanese-2023_p64603-r1.ebuild
@@ -151,7 +151,7 @@ DESCRIPTION="TeXLive Japanese"
LICENSE="BSD BSD-2 GPL-1+ GPL-2 GPL-3 LPPL-1.3 LPPL-1.3c MIT OFL-1.1 TeX TeX-other-free public-domain"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
COMMON_DEPEND="
>=dev-texlive/texlive-langcjk-2023
"
diff --git a/dev-texlive/texlive-xetex/texlive-xetex-2023_p69452-r1.ebuild b/dev-texlive/texlive-xetex/texlive-xetex-2023_p69452-r1.ebuild
index 038708ce8aac..21c7621436dc 100644
--- a/dev-texlive/texlive-xetex/texlive-xetex-2023_p69452-r1.ebuild
+++ b/dev-texlive/texlive-xetex/texlive-xetex-2023_p69452-r1.ebuild
@@ -103,7 +103,7 @@ DESCRIPTION="TeXLive XeTeX and packages"
LICENSE="Apache-2.0 CC-BY-4.0 CC-BY-SA-4.0 GPL-1+ GPL-3 LGPL-2+ LPPL-1.2 LPPL-1.3 LPPL-1.3c MIT TeX-other-free public-domain"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
COMMON_DEPEND="
>=app-text/texlive-core-2023[xetex]
>=dev-texlive/texlive-basic-2023