summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2019-07-15 16:18:45 -0500
committerWilliam Hubbs <williamh@gentoo.org>2019-07-15 16:30:20 -0500
commitf04ac4dfe14c5cab939614ca9d07897c824d06e8 (patch)
tree1e98fd59d11a7539057c112f2827c0aa79e7bccb
parentapp-admin/vault: Bump to version 1.1.3 (diff)
downloadgentoo-f04ac4dfe14c5cab939614ca9d07897c824d06e8.tar.gz
gentoo-f04ac4dfe14c5cab939614ca9d07897c824d06e8.tar.bz2
gentoo-f04ac4dfe14c5cab939614ca9d07897c824d06e8.zip
dev-python/psycopg: 2.8.3 bump
Closes: https://bugs.gentoo.org/683412 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--dev-python/psycopg/Manifest1
-rw-r--r--dev-python/psycopg/files/psycopg-2.8.3-avoid-mxdatetime.patch24
-rw-r--r--dev-python/psycopg/psycopg-2.8.3.ebuild70
3 files changed, 95 insertions, 0 deletions
diff --git a/dev-python/psycopg/Manifest b/dev-python/psycopg/Manifest
index 1a34ee61b5ef..e145a42249fd 100644
--- a/dev-python/psycopg/Manifest
+++ b/dev-python/psycopg/Manifest
@@ -1,3 +1,4 @@
DIST psycopg2-2.7.4.tar.gz 425331 BLAKE2B 9d256ea340e4bace53981596d9d42863ddc9c8c079579b0621d8043af34daade05b9cec5465c6b3990f537a4350d9cf60a43062a0aa34db1f39b336296b32d3f SHA512 e78db528a4d3b897e0d8d38755179082dacddfb2d10bda963fc3836548991eaa0d4c1b8f81b329b15f4e685046c39e6f2a352b6c47b1da42af3a262094233034
DIST psycopg2-2.7.5.tar.gz 426358 BLAKE2B 301bd4c6ecbc29b1b02e477ffd3576c4bbb00142998a85f5a79678a96b521098a8d0bf75779ab7ecb082c6d374cbf41cc845dcba0e1413b98621f67f9b139135 SHA512 5bf85b6760871f904b6b570ea454f99b72cf97acf9cce10b63dc7b6b0b18913b50ad4f24c469d101c54de6ad6100f1cac3c58225076b5e584a677f5ab4170a93
DIST psycopg2-2.7.7.tar.gz 427474 BLAKE2B bc721b721693bc5f560a4829e84715d15e8c14523ada00109c7d7ba916c91928082fff286bd3c2ff5987c0436443128d1408ac9de073ad538b1e356fc73aaf8f SHA512 032344957c00bf659ca5e46f54f827a6d79809e370d661cd349e2ce935873359bcc4f440b74c6f14658bf1cd9598b6d884abae507fd33db9e07b01fc87967fb0
+DIST psycopg2-2.8.3.tar.gz 377333 BLAKE2B a4f22fb4dfc5492147bee198c587c5c5e43e197e5abb60cc7d5d7a006d91ffd22e35fbfeba35b8d36322f3802073fc105cb8270d436a3ad4d52b1c3c41ba39b1 SHA512 74268f6d05922c968d46ad62a49b4af54dc30463daa67cc0f32d5930c366596f9a1b2f368f2b38c8a9d45bfdcffb13be469a5cbf3911c62d163bea5c7a3ad928
diff --git a/dev-python/psycopg/files/psycopg-2.8.3-avoid-mxdatetime.patch b/dev-python/psycopg/files/psycopg-2.8.3-avoid-mxdatetime.patch
new file mode 100644
index 000000000000..3475bf31795e
--- /dev/null
+++ b/dev-python/psycopg/files/psycopg-2.8.3-avoid-mxdatetime.patch
@@ -0,0 +1,24 @@
+diff --git a/setup.py b/setup.py
+index c1f319a..c44fc69 100644
+--- a/setup.py
++++ b/setup.py
+@@ -525,19 +525,6 @@ parser.read('setup.cfg')
+
+ # check for mx package
+ have_mxdatetime = False
+-mxincludedir = ''
+-if parser.has_option('build_ext', 'mx_include_dir'):
+- mxincludedir = parser.get('build_ext', 'mx_include_dir')
+-if not mxincludedir:
+- mxincludedir = os.path.join(get_python_inc(plat_specific=1), "mx")
+-if mxincludedir.strip() and os.path.exists(mxincludedir):
+- # Build the support for mx: we will check at runtime if it can be imported
+- include_dirs.append(mxincludedir)
+- define_macros.append(('HAVE_MXDATETIME', '1'))
+- sources.append('adapter_mxdatetime.c')
+- depends.extend(['adapter_mxdatetime.h', 'typecast_mxdatetime.c'])
+- have_mxdatetime = True
+- version_flags.append('mx')
+
+ # generate a nice version string to avoid confusion when users report bugs
+ version_flags.append('pq3') # no more a choice
diff --git a/dev-python/psycopg/psycopg-2.8.3.ebuild b/dev-python/psycopg/psycopg-2.8.3.ebuild
new file mode 100644
index 000000000000..685d96de02ed
--- /dev/null
+++ b/dev-python/psycopg/psycopg-2.8.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN="${PN}2"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="PostgreSQL database adapter for Python"
+HOMEPAGE="http://initd.org/psycopg/ https://pypi.org/project/psycopg2/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="debug doc examples"
+
+RDEPEND=">=dev-db/postgresql-8.1:*"
+DEPEND="${RDEPEND}
+ doc? (
+ >=dev-python/pygments-2.2[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6[${PYTHON_USEDEP}]
+ )"
+
+RESTRICT="test"
+
+# Avoid using mxdatetime: https://bugs.gentoo.org/452028
+PATCHES=(
+ "${FILESDIR}"/psycopg-2.8.3-avoid-mxdatetime.patch
+)
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile() {
+ local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}
+
+ ! python_is_python3 && append-flags -fno-strict-aliasing
+
+ distutils-r1_python_compile
+}
+
+python_prepare_all() {
+ if use debug; then
+ sed -i 's/^\(define=\)/\1PSYCOPG_DEBUG,/' setup.cfg || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc/src -j1 html text
+}
+
+python_install_all() {
+ if use doc; then
+ dodoc -r doc/src/_build/html
+ dodoc doc/src/_build/text/*
+ fi
+
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}