summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-04-24 12:12:50 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-04-24 12:12:50 +0200
commitee1ae3a1f668aa970b099294b8643c315b934ca9 (patch)
treeeb512843edd33cfa88a0b5d47100015e6e931957
parentsys-kernel/installkernel: add 37 (diff)
downloadgentoo-ee1ae3a1f668aa970b099294b8643c315b934ca9.tar.gz
gentoo-ee1ae3a1f668aa970b099294b8643c315b934ca9.tar.bz2
gentoo-ee1ae3a1f668aa970b099294b8643c315b934ca9.zip
sys-kernel/installkernel: drop 36
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sys-kernel/installkernel/Manifest1
-rw-r--r--sys-kernel/installkernel/installkernel-36.ebuild190
2 files changed, 0 insertions, 191 deletions
diff --git a/sys-kernel/installkernel/Manifest b/sys-kernel/installkernel/Manifest
index 5cb7aa0df3ad..097709aa69ba 100644
--- a/sys-kernel/installkernel/Manifest
+++ b/sys-kernel/installkernel/Manifest
@@ -1,3 +1,2 @@
DIST installkernel-28.tar.gz 18922 BLAKE2B 26e7b073cd44896f830a8977efb9730b92d01074084a3cfc934719de87bbf6ec25ea865f8b1cd88613279dbb83bb9ad72eb2c90bc0f6152aa0cc11ca71a9963a SHA512 5a0ed452e131d85628c1cf6ecc2a6bb9fe3c9f20c999c9919b3e238d1aa09a114c6086cf5de8d3ecf63cfa80fd2804092ebb8ad6505b51df2786eb3037bdf3f0
-DIST installkernel-36.tar.gz 21122 BLAKE2B 1db6aaa8c46c6e374cfd0895f692562f3a4417e667bff61ded42c6ac01355867a932e87e71c354c555e121cc892200c4306fcc231b92f34d68476d24a99dbd23 SHA512 7a05513372d7441df5e97c275254dd3cf445001e791533993902290d2698a53b05a30540f637c851e774f0cf215c10f93e5ec3c5e55b36dd1415ed36eb7b5290
DIST installkernel-37.tar.gz 21040 BLAKE2B a6a94dd07c345d0606a557ad11d25f0089331afaced1a7c3c877c3fafbbb091e98d6655a2fb4460495feff064297d296aceb94e202a942f20eafe5e572c9bd81 SHA512 f689eb23791cc2aadcd4202b85af0e4b36a747b1c9f75d7e4a1d4fe0f64b92ae39a1d3f3b409fd8efeb52966c63010d7f6e827f5a9c45e2b39f57101e3c281f7
diff --git a/sys-kernel/installkernel/installkernel-36.ebuild b/sys-kernel/installkernel/installkernel-36.ebuild
deleted file mode 100644
index bae0d8720c6e..000000000000
--- a/sys-kernel/installkernel/installkernel-36.ebuild
+++ /dev/null
@@ -1,190 +0,0 @@
-# Copyright 2019-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit linux-info
-
-DESCRIPTION="Gentoo fork of installkernel script from debianutils"
-HOMEPAGE="
- https://github.com/projg2/installkernel-gentoo
- https://wiki.gentoo.org/wiki/Installkernel
-"
-SRC_URI="https://github.com/projg2/installkernel-gentoo/archive/v${PV}.tar.gz
- -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-gentoo-${PV}"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux"
-IUSE="dracut efistub grub refind systemd systemd-boot uki ukify"
-REQUIRED_USE="
- systemd-boot? ( systemd )
- ukify? ( uki )
- ?? ( efistub grub refind systemd-boot )
-"
-# efistub requires systemd's kernel-install because:
-# - We need support for removal to clean-up the created entry
-# - We need to know the location of the ESP
-# - kernel-bootcfg at some point calls bootctl (to find ESP)
-
-RDEPEND="
- !<=sys-kernel/installkernel-systemd-3
- dracut? (
- >=sys-kernel/dracut-060_pre20240104-r4
- uki? (
- || (
- sys-apps/systemd[boot(-)]
- sys-apps/systemd-utils[boot(-)]
- )
- )
- )
- efistub? (
- systemd? ( >=app-emulation/virt-firmware-24.2_p20240315-r2 )
- !systemd? ( sys-boot/uefi-mkconfig )
- )
- grub? ( sys-boot/grub )
- refind? ( sys-boot/refind )
- systemd? (
- || (
- sys-apps/systemd[kernel-install(-)]
- sys-apps/systemd-utils[kernel-install(-)]
- )
- )
- systemd-boot? (
- || (
- sys-apps/systemd[boot(-)]
- sys-apps/systemd-utils[boot(-)]
- )
- )
- ukify? (
- || (
- sys-apps/systemd[boot(-),ukify(-)]
- sys-apps/systemd-utils[boot(-),ukify(-)]
- )
- )
- !=sys-apps/systemd-255.2-r1
- !=sys-apps/systemd-255.2-r0
- !~sys-apps/systemd-255.1
- !~sys-apps/systemd-255.0
- !=sys-apps/systemd-254.8-r0
- !=sys-apps/systemd-254.7-r0
- !~sys-apps/systemd-254.6
- !<=sys-apps/systemd-254.5-r1
-" # Block against systemd that still installs dummy install.conf
-
-pkg_setup() {
- use efistub && CONFIG_CHECK="EFI_STUB" linux-info_pkg_setup
-}
-
-src_install() {
- keepdir /etc/kernel/postinst.d
- keepdir /etc/kernel/preinst.d
-
- exeinto /usr/lib/kernel/preinst.d
- use dracut && doexe hooks/50-dracut.install
- use ukify && doexe hooks/60-ukify.install
-
- exeinto /usr/lib/kernel/postinst.d
- use grub && doexe hooks/91-grub-mkconfig.install
- use efistub && doexe hooks/95-efistub-uefi-mkconfig.install
- use refind && doexe hooks/95-refind-copy-icon.install
-
- exeinto /usr/lib/kernel/install.d
- doexe hooks/systemd/00-00machineid-directory.install
- doexe hooks/systemd/10-copy-prebuilt.install
- doexe hooks/systemd/90-compat.install
- use grub && doexe hooks/systemd/91-grub-mkconfig.install
- use efistub && doexe hooks/systemd/95-efistub-kernel-bootcfg.install
- use refind && doexe hooks/systemd/95-refind-copy-icon.install
-
- if use systemd; then
- sed -e 's/${SYSTEMD_KERNEL_INSTALL:=0}/${SYSTEMD_KERNEL_INSTALL:=1}/g' -i installkernel ||
- die "enabling systemd's kernel-install failed"
- fi
-
- # set some default config using the flags we have anyway
- touch "${T}/install.conf" || die
- echo "# This file is managed by ${CATEGORY}/${PN}" >> "${T}/install.conf" || die
- if use uki; then
- echo "layout=uki" >> "${T}/install.conf" || die
- elif use efistub; then
- echo "layout=efistub" >> "${T}/install.conf" || die
- elif use grub; then
- echo "layout=grub" >> "${T}/install.conf" || die
- elif use systemd-boot; then
- echo "layout=bls" >> "${T}/install.conf" || die
- else
- echo "layout=compat" >> "${T}/install.conf" || die
- fi
-
- if use dracut; then
- echo "initrd_generator=dracut" >> "${T}/install.conf" || die
- if ! use ukify; then
- if use uki; then
- echo "uki_generator=dracut" >> "${T}/install.conf" || die
- else
- echo "uki_generator=none" >> "${T}/install.conf" || die
- fi
- fi
- else
- echo "initrd_generator=none" >> "${T}/install.conf" || die
- fi
-
- if use ukify; then
- echo "uki_generator=ukify" >> "${T}/install.conf" || die
- else
- if ! use dracut; then
- echo "uki_generator=none" >> "${T}/install.conf" || die
- fi
- fi
-
- insinto /usr/lib/kernel
- doins "${T}/install.conf"
-
- into /
- dosbin installkernel
- doman installkernel.8
-
- einstalldocs
-}
-
-pkg_postinst() {
- # show only when upgrading to 14+
- if [[ -n "${REPLACING_VERSIONS}" ]] && ver_test "${REPLACING_VERSIONS}" -lt 14; then
- elog "Version 14 and up of ${PN} effectively merges"
- elog "${PN}-gentoo and ${PN}-systemd."
- elog "Switching between the traditional installkernel and systemd's"
- elog "kernel-install is controlled with the systemd USE flag or the"
- elog "SYSTEMD_KERNEL_INSTALL environment variable."
- elog
- elog "See the installkernel wiki page[1] for more details."
- elog
- elog "[1]: https://wiki.gentoo.org/wiki/Installkernel"
- elog
- fi
-
- # show only on first install of version 20+
- if [[ -z "${REPLACING_VERSIONS}" ]] || ver_test "${REPLACING_VERSIONS}" -lt 20; then
- if has_version "sys-boot/grub" && ! use grub; then
- elog "sys-boot/grub is installed but the grub USE flag is not enabled."
- elog "Users may want to enable this flag to automatically update the"
- elog "bootloader configuration on each kernel install."
- fi
- if ( has_version "sys-apps/systemd[boot]" ||
- has_version "sys-apps/systemd-utils[boot]" ) &&
- ! use systemd-boot; then
- elog "systemd-boot is installed but the systemd-boot USE flag"
- elog "is not enabled. Users should enable this flag to install kernels"
- elog "in a layout that systemd-boot understands and to automatically"
- elog "update systemd-boot's configuration on each kernel install."
- fi
- fi
-
- if use efistub; then
- ewarn "Automated EFI Stub booting is highly experimental. UEFI implementations"
- ewarn "often differ between vendors and as a result EFI stub booting is not"
- ewarn "guaranteed to work for all UEFI systems. Ensure an alternative method"
- ewarn "of booting the system is available before rebooting."
- fi
-}