summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2022-12-06 21:31:43 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2022-12-06 21:31:43 +0000
commite9bd8817823aa3d57f9de6c80944cef977e50945 (patch)
treed882a2c5c9df2c8e279488acf69ce53bc3eb9994
parent2022-12-06 21:16:48 UTC (diff)
parentdev-ml/lablgtk: fix typo in restriction (diff)
downloadgentoo-e9bd8817823aa3d57f9de6c80944cef977e50945.tar.gz
gentoo-e9bd8817823aa3d57f9de6c80944cef977e50945.tar.bz2
gentoo-e9bd8817823aa3d57f9de6c80944cef977e50945.zip
Merge updates from master
-rw-r--r--dev-libs/boost/files/boost-1.79.0-CVE-2012-2677.patch121
-rw-r--r--dev-libs/boost/files/boost-1.79.0-disable_icu_rpath.patch29
-rw-r--r--dev-libs/boost/files/boost-1.79.0-fix-mips1-transition.patch39
-rw-r--r--dev-ml/lablgtk/metadata.xml4
-rw-r--r--net-analyzer/dhcp_probe/Manifest1
-rw-r--r--net-analyzer/dhcp_probe/dhcp_probe-1.3.0-r4.ebuild50
-rw-r--r--net-analyzer/dhcp_probe/dhcp_probe-1.3.1.ebuild18
-rw-r--r--net-analyzer/dhcp_probe/files/1.3.0/01_dhcp_probe.5.patch47
-rw-r--r--net-analyzer/dhcp_probe/files/1.3.0/02_dhcp_probe.8.patch35
-rw-r--r--net-analyzer/dhcp_probe/files/1.3.0/03_implicit_point_conv_bootp.c.patch21
-rw-r--r--net-analyzer/dhcp_probe/files/1.3.0/04_linux_32_or_64bits.patch33
-rw-r--r--net-analyzer/dhcp_probe/files/1.3.0/05-cleanup.patch29
-rw-r--r--net-analyzer/dhcp_probe/files/1.3.0/06-return.patch11
-rw-r--r--net-analyzer/dhcp_probe/files/1.3.0/07-comment.patch11
-rw-r--r--net-analyzer/dhcp_probe/files/1.3.0/08-man8.patch20
-rw-r--r--net-analyzer/hexinject/files/hexinject-1.6-fix-build-system.patch22
-rw-r--r--net-analyzer/hexinject/hexinject-1.6-r2.ebuild (renamed from net-analyzer/hexinject/hexinject-1.6-r1.ebuild)9
-rw-r--r--net-analyzer/ifmetric/ifmetric-0.3-r3.ebuild (renamed from net-analyzer/ifmetric/ifmetric-0.3-r2.ebuild)10
-rw-r--r--net-analyzer/ndoutils/ndoutils-2.1.3-r3.ebuild (renamed from net-analyzer/ndoutils/ndoutils-2.1.3-r2.ebuild)59
-rw-r--r--net-analyzer/netpipe/files/netpipe-3.7.2-fix-makefile.patch35
-rw-r--r--net-analyzer/netpipe/netpipe-3.7.2-r1.ebuild (renamed from net-analyzer/netpipe/netpipe-3.7.2.ebuild)25
21 files changed, 99 insertions, 530 deletions
diff --git a/dev-libs/boost/files/boost-1.79.0-CVE-2012-2677.patch b/dev-libs/boost/files/boost-1.79.0-CVE-2012-2677.patch
deleted file mode 100644
index 5dfbf85bc63f..000000000000
--- a/dev-libs/boost/files/boost-1.79.0-CVE-2012-2677.patch
+++ /dev/null
@@ -1,121 +0,0 @@
-https://src.fedoraproject.org/rpms/boost/raw/master/f/boost-1.58.0-pool.patch
-https://bugzilla.redhat.com/show_bug.cgi?id=828856
-https://bugs.gentoo.org/620468
-https://svn.boost.org/trac10/ticket/6701
-
---- a/boost/pool/pool.hpp
-+++ b/boost/pool/pool.hpp
-@@ -27,4 +27,6 @@
- #include <boost/pool/poolfwd.hpp>
-
-+// std::numeric_limits
-+#include <boost/limits.hpp>
- // boost::integer::static_lcm
- #include <boost/integer/common_factor_ct.hpp>
-@@ -356,4 +358,11 @@
- }
-
-+ size_type max_chunks() const
-+ { //! Calculated maximum number of memory chunks that can be allocated in a single call by this Pool.
-+ size_type partition_size = alloc_size();
-+ size_type POD_size = integer::static_lcm<sizeof(size_type), sizeof(void *)>::value + sizeof(size_type);
-+ return (std::numeric_limits<size_type>::max() - POD_size) / alloc_size();
-+ }
-+
- static void * & nextof(void * const ptr)
- { //! \returns Pointer dereferenced.
-@@ -375,5 +384,7 @@
- //! the first time that object needs to allocate system memory.
- //! The default is 32. This parameter may not be 0.
-- //! \param nmax_size is the maximum number of chunks to allocate in one block.
-+ //! \param nmax_size is the maximum number of chunks to allocate in one block.
-+ set_next_size(nnext_size);
-+ set_max_size(nmax_size);
- }
-
-@@ -398,7 +409,7 @@
- }
- void set_next_size(const size_type nnext_size)
-- { //! Set number of chunks to request from the system the next time that object needs to allocate system memory. This value should never be set to 0.
-- //! \returns nnext_size.
-- next_size = start_size = nnext_size;
-+ { //! Set number of chunks to request from the system the next time that object needs to allocate system memory. This value should never be set to 0.
-+ BOOST_USING_STD_MIN();
-+ next_size = start_size = min BOOST_PREVENT_MACRO_SUBSTITUTION(nnext_size, max_chunks());
- }
- size_type get_max_size() const
-@@ -408,5 +419,6 @@
- void set_max_size(const size_type nmax_size)
- { //! Set max_size.
-- max_size = nmax_size;
-+ BOOST_USING_STD_MIN();
-+ max_size = min BOOST_PREVENT_MACRO_SUBSTITUTION(nmax_size, max_chunks());
- }
- size_type get_requested_size() const
-@@ -709,7 +721,7 @@
- BOOST_USING_STD_MIN();
- if(!max_size)
-- next_size <<= 1;
-+ set_next_size(next_size << 1);
- else if( next_size*partition_size/requested_size < max_size)
-- next_size = min BOOST_PREVENT_MACRO_SUBSTITUTION(next_size << 1, max_size*requested_size/ partition_size);
-+ set_next_size(min BOOST_PREVENT_MACRO_SUBSTITUTION(next_size << 1, max_size * requested_size / partition_size));
-
- // initialize it,
-@@ -749,7 +761,7 @@
- BOOST_USING_STD_MIN();
- if(!max_size)
-- next_size <<= 1;
-+ set_next_size(next_size << 1);
- else if( next_size*partition_size/requested_size < max_size)
-- next_size = min BOOST_PREVENT_MACRO_SUBSTITUTION(next_size << 1, max_size*requested_size/ partition_size);
-+ set_next_size(min BOOST_PREVENT_MACRO_SUBSTITUTION(next_size << 1, max_size * requested_size / partition_size));
-
- // initialize it,
-@@ -793,4 +805,6 @@
- //! \returns Address of chunk n if allocated ok.
- //! \returns 0 if not enough memory for n chunks.
-+ if (n > max_chunks())
-+ return 0;
-
- const size_type partition_size = alloc_size();
-@@ -841,7 +855,7 @@
- BOOST_USING_STD_MIN();
- if(!max_size)
-- next_size <<= 1;
-+ set_next_size(next_size << 1);
- else if( next_size*partition_size/requested_size < max_size)
-- next_size = min BOOST_PREVENT_MACRO_SUBSTITUTION(next_size << 1, max_size*requested_size/ partition_size);
-+ set_next_size(min BOOST_PREVENT_MACRO_SUBSTITUTION(next_size << 1, max_size * requested_size / partition_size));
-
- // insert it into the list,
---- a/libs/pool/test/test_bug_6701.cpp
-+++ b/libs/pool/test/test_bug_6701.cpp
-@@ -0,0 +1,27 @@
-+/* Copyright (C) 2012 Étienne Dupuis
-+*
-+* Use, modification and distribution is subject to the
-+* Boost Software License, Version 1.0. (See accompanying
-+* file LICENSE_1_0.txt or http://www.boost.org/LICENSE_1_0.txt)
-+*/
-+
-+// Test of bug #6701 (https://svn.boost.org/trac/boost/ticket/6701)
-+
-+#include <boost/pool/object_pool.hpp>
-+#include <boost/limits.hpp>
-+
-+int main()
-+{
-+ boost::pool<> p(1024, std::numeric_limits<size_t>::max() / 768);
-+
-+ void *x = p.malloc();
-+ BOOST_ASSERT(!x);
-+
-+ BOOST_ASSERT(std::numeric_limits<size_t>::max() / 1024 >= p.get_next_size());
-+ BOOST_ASSERT(std::numeric_limits<size_t>::max() / 1024 >= p.get_max_size());
-+
-+ void *y = p.ordered_malloc(std::numeric_limits<size_t>::max() / 768);
-+ BOOST_ASSERT(!y);
-+
-+ return 0;
-+}
diff --git a/dev-libs/boost/files/boost-1.79.0-disable_icu_rpath.patch b/dev-libs/boost/files/boost-1.79.0-disable_icu_rpath.patch
deleted file mode 100644
index 32faf8d0eb31..000000000000
--- a/dev-libs/boost/files/boost-1.79.0-disable_icu_rpath.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/libs/locale/build/Jamfile.v2
-+++ b/libs/locale/build/Jamfile.v2
-@@ -65,8 +65,8 @@
-
- if $(ICU_LINK)
- {
-- ICU_OPTS = <include>$(ICU_PATH)/include <linkflags>$(ICU_LINK) <dll-path>$(ICU_PATH)/bin <runtime-link>shared ;
-- ICU64_OPTS = <include>$(ICU_PATH)/include <linkflags>$(ICU_LINK) <dll-path>$(ICU_PATH)/bin64 <runtime-link>shared ;
-+ ICU_OPTS = <include>$(ICU_PATH)/include <linkflags>$(ICU_LINK) <runtime-link>shared ;
-+ ICU64_OPTS = <include>$(ICU_PATH)/include <linkflags>$(ICU_LINK) <runtime-link>shared ;
- }
- else
- {
-@@ -124,7 +124,6 @@
- <library>icuuc/<link>shared/<runtime-link>shared
- <library>icudt/<link>shared/<runtime-link>shared
- <library>icuin/<link>shared/<runtime-link>shared
-- <dll-path>$(ICU_PATH)/bin
- <runtime-link>shared ;
-
-
-@@ -183,7 +182,6 @@
- <library>icuuc_64/<link>shared/<runtime-link>shared
- <library>icudt_64/<link>shared/<runtime-link>shared
- <library>icuin_64/<link>shared/<runtime-link>shared
-- <dll-path>$(ICU_PATH)/bin64
- <runtime-link>shared ;
-
-
diff --git a/dev-libs/boost/files/boost-1.79.0-fix-mips1-transition.patch b/dev-libs/boost/files/boost-1.79.0-fix-mips1-transition.patch
deleted file mode 100644
index 81b29ac6cac1..000000000000
--- a/dev-libs/boost/files/boost-1.79.0-fix-mips1-transition.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-https://github.com/boostorg/boost/commit/791442bf1ed7a3b14893ed9e73ef2ab32b2a6026, and
-https://github.com/boostorg/config/commit/1a55d1d9c6d1cf7739645080bdd92fe903b4211e without the file renaming.
-
---- a/boostcpp.jam
-+++ b/boostcpp.jam
-@@ -634,7 +634,7 @@ rule address-model ( )
- return <conditional>@boostcpp.deduce-address-model ;
- }
-
--local deducable-architectures = arm mips1 power riscv s390x sparc x86 combined ;
-+local deducable-architectures = arm mips power riscv s390x sparc x86 combined ;
- feature.feature deduced-architecture : $(deducable-architectures) : propagated optional composite hidden ;
- for a in $(deducable-architectures)
- {
-@@ -645,10 +645,10 @@ rule deduce-architecture ( properties * )
- {
- local result ;
- local filtered = [ toolset-properties $(properties) ] ;
-- local names = arm mips1 power riscv s390x sparc x86 combined ;
-+ local names = arm mips power riscv s390x sparc x86 combined ;
- local idx = [ configure.find-builds "default architecture" : $(filtered)
- : /boost/architecture//arm
-- : /boost/architecture//mips1
-+ : /boost/architecture//mips
- : /boost/architecture//power
- : /boost/architecture//riscv
- : /boost/architecture//s390x
---- a/libs/config/checks/architecture/Jamfile.jam
-+++ b/libs/config/checks/architecture/Jamfile.jam
-@@ -18,7 +18,8 @@ obj 64 : 64.cpp ;
-
- obj arm : arm.cpp ;
- obj combined : combined.cpp ;
--obj mips1 : mips1.cpp ;
-+obj mips : mips1.cpp ;
-+alias mips1 : mips ; # Backwards compatibility
- obj power : power.cpp ;
- obj riscv : riscv.cpp ;
- obj sparc : sparc.cpp ;
diff --git a/dev-ml/lablgtk/metadata.xml b/dev-ml/lablgtk/metadata.xml
index 4d3ab587ee41..437ccb8ea1e5 100644
--- a/dev-ml/lablgtk/metadata.xml
+++ b/dev-ml/lablgtk/metadata.xml
@@ -10,10 +10,10 @@
<name>Mark Wright</name>
</maintainer>
<use>
- <flag name="glade" restrict="&lt;dev-ml/lablgtki-3">
+ <flag name="glade" restrict="&lt;dev-ml/lablgtk-3">
Enable <pkg>gnome-base/libglade</pkg> bindings compilation
</flag>
- <flag name="gnomecanvas" restrict="&lt;dev-ml/lablgtki-3">
+ <flag name="gnomecanvas" restrict="&lt;dev-ml/lablgtk-3">
Enable <pkg>gnome-base/libgnomecanvas</pkg> bindings compilation
</flag>
<flag name="sourceview">
diff --git a/net-analyzer/dhcp_probe/Manifest b/net-analyzer/dhcp_probe/Manifest
index d14483774cf0..5ed1a3a8246e 100644
--- a/net-analyzer/dhcp_probe/Manifest
+++ b/net-analyzer/dhcp_probe/Manifest
@@ -1,2 +1 @@
-DIST dhcp_probe-1.3.0.tar.gz 211613 BLAKE2B cbcc43b292fe537216ef40de9e417c1f700be4ad5f34feacd9475eb31866b68957ce66c5abc47db3b7e5a0dc8751ca6e54200b79ab2f1f8c3f308f6c1c7aef4d SHA512 d643012529ee5149adbc0c1f19f8e579c55201e86de2aec9b3313be9412db4e973162f864d1baaf79fa340b7bd9a7385f0f1406d1b616e801ced3c7bb387c854
DIST dhcp_probe-1.3.1.tar.gz 246238 BLAKE2B 86c079c4c7951f3a70ced20dbea5d4f0d716335d2f9a18b1b9986965ca0446b5a7b673c7e652405deceeef336218016418a86be1a76d452c7802061403a66e82 SHA512 1002683e6ceb3806289fa9e4879be3d957a9ddc42656d7114942708560f8efba0db058137e04cad092e5a083900987aa1f76c5a7c20db4b57c104dd6a6fcabb6
diff --git a/net-analyzer/dhcp_probe/dhcp_probe-1.3.0-r4.ebuild b/net-analyzer/dhcp_probe/dhcp_probe-1.3.0-r4.ebuild
deleted file mode 100644
index 3819fc35ca70..000000000000
--- a/net-analyzer/dhcp_probe/dhcp_probe-1.3.0-r4.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit flag-o-matic
-
-DESCRIPTION="discover DHCP and BootP servers on a directly-attached Ethernet network"
-HOMEPAGE="https://www.net.princeton.edu/software/dhcp_probe/"
-SRC_URI="https://www.net.princeton.edu/software/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="
- net-libs/libpcap
- >=net-libs/libnet-1.1.2.1-r2
-"
-RDEPEND="${DEPEND}"
-DOCS=(
- "${FILESDIR}"/${PN}_mail
- AUTHORS
- ChangeLog
- NEWS
- README
- TODO
- extras/dhcp_probe.cf.sample
-)
-PATCHES=(
- "${FILESDIR}"/${PV}/01_dhcp_probe.5.patch
- "${FILESDIR}"/${PV}/02_dhcp_probe.8.patch
- "${FILESDIR}"/${PV}/03_implicit_point_conv_bootp.c.patch
- "${FILESDIR}"/${PV}/04_linux_32_or_64bits.patch
- "${FILESDIR}"/${PV}/05-cleanup.patch
- "${FILESDIR}"/${PV}/06-return.patch
- "${FILESDIR}"/${PV}/07-comment.patch
- "${FILESDIR}"/${PV}/08-man8.patch
-)
-
-src_configure() {
- use amd64 && append-flags -D__ARCH__=64
- STRIP=true econf
-}
-
-src_install() {
- default
-
- newinitd "${FILESDIR}/${PN}.initd" ${PN}
- newconfd "${FILESDIR}/${PN}.confd" ${PN}
-}
diff --git a/net-analyzer/dhcp_probe/dhcp_probe-1.3.1.ebuild b/net-analyzer/dhcp_probe/dhcp_probe-1.3.1.ebuild
index 4bcdb5ae2887..c7d6357a1e18 100644
--- a/net-analyzer/dhcp_probe/dhcp_probe-1.3.1.ebuild
+++ b/net-analyzer/dhcp_probe/dhcp_probe-1.3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,19 +13,11 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-DEPEND="net-libs/libpcap
- >=net-libs/libnet-1.1.2.1-r2"
+DEPEND="
+ net-libs/libnet
+ net-libs/libpcap"
RDEPEND="${DEPEND}"
-DOCS=(
- AUTHORS
- ChangeLog
- NEWS
- README
- TODO
- extras/dhcp_probe.cf.sample
-)
-
PATCHES=(
"${FILESDIR}"/${PN}-1.3.1-respect-AR.patch
"${FILESDIR}"/${PN}-1.3.1-fix-configure-CPP.patch
@@ -50,7 +42,7 @@ src_configure() {
src_install() {
default
- dodoc "${FILESDIR}"/${PN}_mail
+ dodoc extras/dhcp_probe.cf.sample "${FILESDIR}"/${PN}_mail
newinitd "${FILESDIR}"/${PN}.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
diff --git a/net-analyzer/dhcp_probe/files/1.3.0/01_dhcp_probe.5.patch b/net-analyzer/dhcp_probe/files/1.3.0/01_dhcp_probe.5.patch
deleted file mode 100644
index 2d5599c06224..000000000000
--- a/net-analyzer/dhcp_probe/files/1.3.0/01_dhcp_probe.5.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 01_dhcp_probe.5.dpatch by Laurent Guignard <lguignard.debian@gmail.com>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Change a syntax problem in groff file for hyphenation problem
-## Note:
-## Submitted to upstream programmer Irwin Tillman<irwin@princeton.edu>.
-## This patch will be applied in the next version of the upstream code.
-
-
-@DPATCH@
-diff -urNad trunk~/doc/dhcp_probe.cf.5 trunk/doc/dhcp_probe.cf.5
---- trunk~/doc/dhcp_probe.cf.5 2009-03-30 14:53:40.000000000 +0200
-+++ trunk/doc/dhcp_probe.cf.5 2009-03-30 14:57:05.000000000 +0200
-@@ -472,10 +472,10 @@
- .PP
- .RS
- .nf
---p the name of the calling program (e.g. dhcp_probe),
---I the name of the interface on which the unexpected response packet was received
---i the IP source address of the packet
---m Ethernet source address of the packet
-+\-p the name of the calling program (e.g. dhcp_probe),
-+\-I the name of the interface on which the unexpected response packet was received
-+\-i the IP source address of the packet
-+\-m Ethernet source address of the packet
- .fi
- .RE
- .PP
-@@ -483,7 +483,7 @@
- .PP
- .RS
- .nf
---y the non-zero yiaddr value from the packet, when it falls inside a "Lease Network of Concern"
-+\-y the non-zero yiaddr value from the packet, when it falls inside a "Lease Network of Concern"
- .fi
- .RE
- .PP
-@@ -723,7 +723,7 @@
- # alert_program_name2 /absolute/path/name
- #
- # The program specified via 'alert_program_name2' will be called as follows:
--# /absolute/path/name -p name_of_calling_program -I name_of_interface_on_which_the_response_was_received -i IP_source_of_the_response -m ether_src_of_the_response [-y yiaddr_when_in_lease_networks_of_concern]
-+# /absolute/path/name \-p name_of_calling_program \-I name_of_interface_on_which_the_response_was_received \-i IP_source_of_the_response \-m ether_src_of_the_response [\-y yiaddr_when_in_lease_networks_of_concern]
- # The options may appear in any order.
- # The program must silently ignore any options or arguments it does not recognize,
- # so as to be forward-compatible with future enhancements to dhcp_probe.
diff --git a/net-analyzer/dhcp_probe/files/1.3.0/02_dhcp_probe.8.patch b/net-analyzer/dhcp_probe/files/1.3.0/02_dhcp_probe.8.patch
deleted file mode 100644
index d9d3d5aa898a..000000000000
--- a/net-analyzer/dhcp_probe/files/1.3.0/02_dhcp_probe.8.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 02_dhcp_probe.8.dpatch by Laurent Guignard <lguignard.debian@gmail.com>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Change a syntax problem in groff file for hyphenation problem
-## Note:
-## Submitted to upstream programmer Irwin Tillman<irwin@princeton.edu>.
-## This patch will be applied in the next version of the upstream code.
-
-
-@DPATCH@
-diff -urNad trunk~/doc/dhcp_probe.8 trunk/doc/dhcp_probe.8
---- trunk~/doc/dhcp_probe.8 2009-03-30 14:53:40.000000000 +0200
-+++ trunk/doc/dhcp_probe.8 2009-03-30 15:18:09.000000000 +0200
-@@ -380,15 +380,15 @@
- file,
- that program is executed, with the following required options:
- .nf
-- -p the name of the calling program (e.g. dhcp_probe)
-- -I the name of the interface on which the unexpected response packet was received
-- -i the IP source address of the packet
-- -m and the Ethernet source address of the packet
-+ \-p the name of the calling program (e.g. dhcp_probe)
-+ \-I the name of the interface on which the unexpected response packet was received
-+ \-i the IP source address of the packet
-+ \-m and the Ethernet source address of the packet
- .fi
- If the response packet's yiaddr is non-zero and falls within a "Lease Networks of Concern",
- the following optional options are also passed:
- .nf
-- -y the non-zero yiaddr value
-+ \-y the non-zero yiaddr value
- .fi
- (We do not wait for the
- .I alert_program_name2
diff --git a/net-analyzer/dhcp_probe/files/1.3.0/03_implicit_point_conv_bootp.c.patch b/net-analyzer/dhcp_probe/files/1.3.0/03_implicit_point_conv_bootp.c.patch
deleted file mode 100644
index 41af750416bf..000000000000
--- a/net-analyzer/dhcp_probe/files/1.3.0/03_implicit_point_conv_bootp.c.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 03_implicit_point_conv_bootp.c.dpatch by Laurent Guignard <lguignard.debian@gmail.com>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Fix implicit Pointer Converstion in bootp.c file.
-## Fix bug #529635 discovered by Dann Frazier <dannf@debian.org>
-##
-
-@DPATCH@
-diff -urNad trunk~/src/bootp.c trunk/src/bootp.c
---- trunk~/src/bootp.c 2009-03-31 14:19:06.000000000 +0200
-+++ trunk/src/bootp.c 2009-05-21 09:51:26.000000000 +0200
-@@ -11,7 +11,7 @@
- #include "bootp.h"
- #include "configfile.h"
- #include "report.h"
--
-+#include "utils.h"
-
-
-
diff --git a/net-analyzer/dhcp_probe/files/1.3.0/04_linux_32_or_64bits.patch b/net-analyzer/dhcp_probe/files/1.3.0/04_linux_32_or_64bits.patch
deleted file mode 100644
index dcd79ffc58b2..000000000000
--- a/net-analyzer/dhcp_probe/files/1.3.0/04_linux_32_or_64bits.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 04_linux_32_or_64bits.dpatch by Laurent Guignard <lguignard.debian@gmail.com>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: A solution to solve the bug #535361
-## May be this will be a solution with the right method ???
-
-@DPATCH@
-diff -urNad trunk~/src/get_myipaddr.c trunk/src/get_myipaddr.c
---- trunk~/src/get_myipaddr.c 2009-09-03 13:10:32.000000000 +0200
-+++ trunk/src/get_myipaddr.c 2009-09-03 13:15:39.671451172 +0200
-@@ -118,7 +118,21 @@
- #endif /* not STRUCT_SOCKADDR_HAS_SA_LEN */
-
- /* increment ptr to next interface for next time through the loop */
-+#ifdef __ARCH__ /* Debian GNU/Linux behavior for packaging goal */
-+ switch(__ARCH__) {
-+ case 32: /* 32 bits architectures */
-+ ptr += sizeof(ifr->ifr_name) + len;
-+ break;
-+ case 64: /* 64 bits architectures */
-+ ptr += sizeof(struct ifreq);
-+ break;
-+ default: /* Default dhcp_probe behavior */
-+ ptr += sizeof(ifr->ifr_name) + len;
-+ break;
-+ }
-+#else /* Default dhcp_probe behavior */
- ptr += sizeof(ifr->ifr_name) + len;
-+#endif
-
- if (strcmp(ifname, ifr->ifr_name) != 0 ) /* is this the interface we're looking for? */
- continue;
diff --git a/net-analyzer/dhcp_probe/files/1.3.0/05-cleanup.patch b/net-analyzer/dhcp_probe/files/1.3.0/05-cleanup.patch
deleted file mode 100644
index 4151b461bbfd..000000000000
--- a/net-analyzer/dhcp_probe/files/1.3.0/05-cleanup.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- dhcp_probe-1.3.0/src/dhcp_probe.c.orig 2009-03-09 21:17:47.000000000 +0100
-+++ dhcp_probe-1.3.0/src/dhcp_probe.c 2009-11-19 18:09:26.000000000 +0100
-@@ -84,7 +84,6 @@
- struct sigaction sa;
- FILE *pid_fp;
- char *cwd = CWD;
-- int i;
-
- int write_packet_len;
- int bytes_written;
-@@ -98,9 +97,6 @@
- int linktype;
- char pcap_errbuf[PCAP_ERRBUF_SIZE], pcap_errbuf2[PCAP_ERRBUF_SIZE];
-
-- /* for libnet */
-- char libnet_errbuf[LIBNET_ERRBUF_SIZE];
--
- /* get progname = last component of argv[0] */
- prog = strrchr(argv[0], '/');
- if (prog)
-@@ -987,8 +983,6 @@
- Must not be called until after initial configuration is complete.
- */
-
-- int i;
--
- if (! read_configfile(config_file)) {
- my_exit(1, 1, 1);
- }
diff --git a/net-analyzer/dhcp_probe/files/1.3.0/06-return.patch b/net-analyzer/dhcp_probe/files/1.3.0/06-return.patch
deleted file mode 100644
index c27ad646e6c9..000000000000
--- a/net-analyzer/dhcp_probe/files/1.3.0/06-return.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- dhcp_probe-1.3.0/src/dhcp_probe.c.orig 2009-11-19 18:13:31.000000000 +0100
-+++ dhcp_probe-1.3.0/src/dhcp_probe.c 2009-11-19 18:13:59.000000000 +0100
-@@ -684,6 +684,8 @@
- pcap_close(pd_template);
-
- my_exit(0, 1, 1);
-+
-+ return 0; /* will not be reached */
- }
-
-
diff --git a/net-analyzer/dhcp_probe/files/1.3.0/07-comment.patch b/net-analyzer/dhcp_probe/files/1.3.0/07-comment.patch
deleted file mode 100644
index c8184144a597..000000000000
--- a/net-analyzer/dhcp_probe/files/1.3.0/07-comment.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- dhcp_probe-1.3.0/src/configfile.c.orig 2009-03-09 21:17:47.000000000 +0100
-+++ dhcp_probe-1.3.0/src/configfile.c 2009-11-19 18:17:03.000000000 +0100
-@@ -55,7 +55,7 @@
-
- /* parallel arrays of "lease networks of concern" (address & mask), and number of elems in arrays.
- We also precompute a parallel array of 'addr & mask' to save computing these repeatedly later.
--/* If a response already identified as being from a rogue DHCP server contains a yiaddr field field
-+ If a response already identified as being from a rogue DHCP server contains a yiaddr field field
- that falls into one of these networks, it is reported as a matter of special concern.
- */
- struct in_addr lease_networks_of_concern_addr[MAX_LEASE_NETWORKS_OF_CONCERN];
diff --git a/net-analyzer/dhcp_probe/files/1.3.0/08-man8.patch b/net-analyzer/dhcp_probe/files/1.3.0/08-man8.patch
deleted file mode 100644
index 56f8686eaebd..000000000000
--- a/net-analyzer/dhcp_probe/files/1.3.0/08-man8.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- dhcp_probe-1.3.0/doc/dhcp_probe.8.orig 2009-11-19 18:27:47.000000000 +0100
-+++ dhcp_probe-1.3.0/doc/dhcp_probe.8 2009-11-19 18:28:50.000000000 +0100
-@@ -141,7 +141,7 @@
- libraries.
- .SH OPTIONS
- .TP
--.IB \-c \ config_file
-+.BI \-c \ config_file
- Specifies the configuration file.
- If not specified, this defaults to
- .BR /etc/dhcp_probe.cf .
-@@ -253,7 +253,7 @@
- .B \-v
- Display the program's version number, then exit.
- .TP
--.IB \-w \ cwd
-+.BI \-w \ cwd
- Specifies the working directory; shortly after starting the
- program changes its current working directory to this.
- If not specified, this defaults to
diff --git a/net-analyzer/hexinject/files/hexinject-1.6-fix-build-system.patch b/net-analyzer/hexinject/files/hexinject-1.6-fix-build-system.patch
index fbe91199bbfa..9d22337afa93 100644
--- a/net-analyzer/hexinject/files/hexinject-1.6-fix-build-system.patch
+++ b/net-analyzer/hexinject/files/hexinject-1.6-fix-build-system.patch
@@ -1,18 +1,22 @@
Author: holgersson <holgersson@posteo.de>
Date: Fri Oct 20 18:30:00 2017 +0200
-Don’t call gcc directly, and respect CFLAGS. As this project
-is plain C I don’t care fore CXXFLAGS here.
+Respect CC, CFLAGS, CPPFLAGS and LDFLAGS.
---- a/Makefile 2017-10-20 18:15:11.743805540 +0200
-+++ b/Makefile 2017-10-20 18:24:55.120009439 +0200
-@@ -1,6 +1,6 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,11 +1,7 @@
-CC = gcc
-CFLAGS = -Wall
-LDFLAGS = -lpcap
-+CC ?= gcc
+CFLAGS += -Wall
-+LDFLAGS = -lpcap
++LDLIBS = -lpcap
- all:
- $(CC) $(CFLAGS) $(LDFLAGS) -o hexinject hexinject.c
+-all:
+- $(CC) $(CFLAGS) $(LDFLAGS) -o hexinject hexinject.c
+- $(CC) $(CFLAGS) $(LDFLAGS) -o prettypacket prettypacket.c
+- $(CC) $(CFLAGS) $(LDFLAGS) -o hex2raw hex2raw.c
++all: hexinject prettypacket hex2raw
+
+ clean:
+ rm -f hexinject prettypacket hex2raw *~
diff --git a/net-analyzer/hexinject/hexinject-1.6-r1.ebuild b/net-analyzer/hexinject/hexinject-1.6-r2.ebuild
index e36c1803461e..bfef01f88b8f 100644
--- a/net-analyzer/hexinject/hexinject-1.6-r1.ebuild
+++ b/net-analyzer/hexinject/hexinject-1.6-r2.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="Network packet sniffer and injector"
HOMEPAGE="http://hexinject.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
LICENSE="BSD"
SLOT="0"
@@ -18,13 +19,9 @@ DEPEND="net-libs/libpcap"
RDEPEND="${DEPEND}
experimental? ( dev-lang/tcl )"
-S="${WORKDIR}/${PN}"
-
PATCHES=( "${FILESDIR}"/${PN}-1.6-fix-build-system.patch )
src_configure() {
- default
-
tc-export CC
}
diff --git a/net-analyzer/ifmetric/ifmetric-0.3-r2.ebuild b/net-analyzer/ifmetric/ifmetric-0.3-r3.ebuild
index f5e962992ffb..df13f75e5942 100644
--- a/net-analyzer/ifmetric/ifmetric-0.3-r2.ebuild
+++ b/net-analyzer/ifmetric/ifmetric-0.3-r3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
DESCRIPTION="Set metrics of all IPv4 routes attached to a given network interface at once"
HOMEPAGE="http://0pointer.de/lennart/projects/ifmetric/"
@@ -13,15 +13,11 @@ KEYWORDS="~amd64 ~ppc x86"
DEPEND="sys-kernel/linux-headers"
-DOCS=(
- README
- doc/README.html
-)
-
PATCHES=(
"${FILESDIR}"/${P}-ul.patch
"${FILESDIR}"/${P}-replybuf.patch
)
+HTML_DOCS=( doc/README.html )
src_configure() {
# man page and HTML are already generated
diff --git a/net-analyzer/ndoutils/ndoutils-2.1.3-r2.ebuild b/net-analyzer/ndoutils/ndoutils-2.1.3-r3.ebuild
index 784309fee43a..044cb36975f4 100644
--- a/net-analyzer/ndoutils/ndoutils-2.1.3-r2.ebuild
+++ b/net-analyzer/ndoutils/ndoutils-2.1.3-r3.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit systemd
DESCRIPTION="Nagios addon to store Nagios data in a MySQL database"
HOMEPAGE="https://www.nagios.org/"
SRC_URI="https://github.com/NagiosEnterprises/${PN}/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
LICENSE="GPL-2"
SLOT="0"
@@ -14,30 +16,19 @@ KEYWORDS="~amd64 ~ppc ~x86"
# We require the "nagios" user from net-analyzer/nagios-core at build
# time.
-DEPEND="dev-db/mysql-connector-c
+DEPEND="
+ dev-db/mysql-connector-c
dev-perl/DBD-mysql
dev-perl/DBI
>=net-analyzer/nagios-core-4.4.5"
RDEPEND="${DEPEND}
virtual/mysql"
-S="${WORKDIR}/${PN}-${P}"
-
-DOCS=(
- Changelog
- README
- THANKS
- TODO
- UPGRADING
- "docs/NDOUTILS DB Model.pdf"
- "docs/NDOUtils Documentation.pdf"
-)
-
PATCHES=(
- "${FILESDIR}/format-security.patch"
- "${FILESDIR}/ndoutils-2.0.0-asprintf.patch"
- "${FILESDIR}/sample-config-piddir.patch"
- "${FILESDIR}/openrc-init.patch"
+ "${FILESDIR}"/format-security.patch
+ "${FILESDIR}"/ndoutils-2.0.0-asprintf.patch
+ "${FILESDIR}"/sample-config-piddir.patch
+ "${FILESDIR}"/openrc-init.patch
)
src_configure() {
@@ -58,34 +49,38 @@ src_compile() {
# Avoid "emake all" so that we don't build the stuff for nagios-2.x
# and nagios-3.x, some of which throws QA warnings. We don't use it
# anyway.
- pushd src
- emake file2sock log2ndo ndo2db-4x ndomod-4x.o sockdebug
- popd
+ emake -C src file2sock log2ndo ndo2db-4x ndomod-4x.o sockdebug
}
src_install() {
+ # The documentation isn't installed by the build system
+ HTML_DOCS=( docs/html/. )
default
+
+ dodoc Changelog UPGRADING \
+ "docs/NDOUTILS DB Model.pdf" "docs/NDOUtils Documentation.pdf"
+
+ systemd_newunit startup/default-service ndoutils.service
+
insinto /etc/nagios
newins config/ndo2db.cfg-sample ndo2db.cfg
newins config/ndomod.cfg-sample ndomod.cfg
- newinitd "startup/openrc-init" ndo2db
- newconfd "startup/openrc-conf" ndo2db
- systemd_newunit "startup/default-service" "${PN}.service"
+ newinitd startup/openrc-init ndo2db
+ newconfd startup/openrc-conf ndo2db
- # The documentation isn't installed by the build system
- dodoc -r docs/html
-
- insinto "/usr/share/${PN}"
+ insinto /usr/share/ndoutils
doins -r db
# These need to be executable...
- exeinto "/usr/share/${PN}/db"
+ exeinto /usr/share/ndoutils/db
doexe db/{installdb,prepsql,upgradedb}
# Use symlinks because the installdb/upgradedb scripts use relative
# paths to the SQL queries.
- dosym "../share/${PN}/db/installdb" /usr/bin/ndoutils-installdb
- dosym "../share/${PN}/db/upgradedb" /usr/bin/ndoutils-upgradedb
+ dosym ../share/ndoutils/db/installdb /usr/bin/ndoutils-installdb
+ dosym ../share/ndoutils/db/upgradedb /usr/bin/ndoutils-upgradedb
+
+ keepdir /var/lib/nagios
}
pkg_postinst() {
diff --git a/net-analyzer/netpipe/files/netpipe-3.7.2-fix-makefile.patch b/net-analyzer/netpipe/files/netpipe-3.7.2-fix-makefile.patch
index f5c61737f7ae..d1f04a33a2dc 100644
--- a/net-analyzer/netpipe/files/netpipe-3.7.2-fix-makefile.patch
+++ b/net-analyzer/netpipe/files/netpipe-3.7.2-fix-makefile.patch
@@ -1,5 +1,3 @@
-diff --git a/makefile b/makefile
-index 16f9052..3ada81f 100644
--- a/makefile
+++ b/makefile
@@ -21,8 +21,6 @@
@@ -11,3 +9,36 @@ index 16f9052..3ada81f 100644
SRC = ./src
# For MPI, mpicc will set up the proper include and library paths
+@@ -91,26 +89,26 @@
+
+
+ tcp: $(SRC)/tcp.c $(SRC)/netpipe.c $(SRC)/netpipe.h
+- $(CC) $(CFLAGS) $(SRC)/netpipe.c $(SRC)/tcp.c -DTCP -o NPtcp -I$(SRC)
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $(SRC)/netpipe.c $(SRC)/tcp.c -DTCP -o NPtcp -I$(SRC)
+
+ tcp6: $(SRC)/tcp.c $(SRC)/netpipe.c $(SRC)/netpipe.h
+- $(CC) $(CFLAGS) $(SRC)/netpipe.c $(SRC)/tcp6.c -DTCP6 \
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $(SRC)/netpipe.c $(SRC)/tcp6.c -DTCP6 \
+ -o NPtcp6 -I$(SRC)
+
+ sctp: $(SRC)/sctp.c $(SRC)/netpipe.c $(SRC)/netpipe.h
+- $(CC) $(CFLAGS) $(SRC)/netpipe.c $(SRC)/sctp.c -DSCTP \
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $(SRC)/netpipe.c $(SRC)/sctp.c -DSCTP \
+ -o NPsctp -I$(SRC)
+
+ sctp6: $(SRC)/sctp6.c $(SRC)/netpipe.c $(SRC)/netpipe.h
+- $(CC) $(CFLAGS) $(SRC)/netpipe.c $(SRC)/sctp6.c -DSCTP6 \
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $(SRC)/netpipe.c $(SRC)/sctp6.c -DSCTP6 \
+ -o NPsctp6 -I$(SRC)
+
+ ipx: $(SRC)/ipx.c $(SRC)/netpipe.c $(SRC)/netpipe.h
+- $(CC) $(CFLAGS) $(SRC)/netpipe.c $(SRC)/ipx.c -DIPX \
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $(SRC)/netpipe.c $(SRC)/ipx.c -DIPX \
+ -o NPipx -I$(SRC) -lipx
+
+ memcpy: $(SRC)/memcpy.c $(SRC)/netpipe.c $(SRC)/netpipe.h
+- $(CC) $(CFLAGS) $(SRC)/netpipe.c $(SRC)/memcpy.c \
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $(SRC)/netpipe.c $(SRC)/memcpy.c \
+ -DMEMCPY -o NPmemcpy -I$(SRC)
+
+ MP_memcpy: $(SRC)/memcpy.c $(SRC)/netpipe.c $(SRC)/netpipe.h $(SRC)/MP_memcpy.c
diff --git a/net-analyzer/netpipe/netpipe-3.7.2.ebuild b/net-analyzer/netpipe/netpipe-3.7.2-r1.ebuild
index 894cf55c72a7..1cda1d25fa4a 100644
--- a/net-analyzer/netpipe/netpipe-3.7.2.ebuild
+++ b/net-analyzer/netpipe/netpipe-3.7.2-r1.ebuild
@@ -1,16 +1,18 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
-MY_PN=NetPIPE
-MY_P=${MY_PN}-${PV}
+MY_PN="NetPIPE"
+MY_P="${MY_PN}-${PV}"
DESCRIPTION="network protocol independent performance evaluator"
HOMEPAGE="http://bitspjoule.org/netpipe/"
SRC_URI="http://bitspjoule.org/netpipe/code/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
LICENSE="GPL-1+"
SLOT="0"
KEYWORDS="~amd64"
@@ -24,21 +26,20 @@ DOCS=(
dox/netpipe_paper.ps
dox/np_cluster2002.pdf
dox/np_euro.pdf
- )
+)
-PATCHES=(
- "${FILESDIR}"/${P}-fix-makefile.patch
- )
+PATCHES=( "${FILESDIR}"/${P}-fix-makefile.patch )
-S="${WORKDIR}"/${MY_P}
+src_configure() {
+ tc-export CC
+}
src_compile() {
- emake CC="$(tc-getCC)" LD="$(tc-getLD)" memcpy tcp $(usex ipv6 tcp6 '')
+ emake memcpy tcp $(usev ipv6 tcp6)
}
src_install() {
- dobin NPmemcpy NPtcp
- use ipv6 && dobin NPtcp6
+ dobin NPmemcpy NPtcp $(usev ipv6 NPtcp6)
doman dox/netpipe.1
einstalldocs
}