summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2024-07-15 04:48:54 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2024-07-15 04:48:54 +0000
commite6ec333b9d2522d650df48428a5b05c9fbe211ad (patch)
tree27956ad5a701645d29c89052b481bb657d76383b
parent2024-07-15 04:34:05 UTC (diff)
parentsci-geosciences/gpsd: Stabilize 3.25-r1 ppc64, #936081 (diff)
downloadgentoo-e6ec333b9d2522d650df48428a5b05c9fbe211ad.tar.gz
gentoo-e6ec333b9d2522d650df48428a5b05c9fbe211ad.tar.bz2
gentoo-e6ec333b9d2522d650df48428a5b05c9fbe211ad.zip
Merge updates from master
-rw-r--r--app-emulation/cloud-init/Manifest2
-rw-r--r--app-emulation/cloud-init/cloud-init-22.2.2.ebuild95
-rw-r--r--app-emulation/cloud-init/cloud-init-22.4.ebuild95
-rw-r--r--app-pda/libimobiledevice-glue/libimobiledevice-glue-1.1.0.ebuild2
-rw-r--r--app-pda/libimobiledevice/libimobiledevice-1.3.0_p20240201.ebuild2
-rw-r--r--dev-python/pychromecast/pychromecast-14.0.1.ebuild2
-rw-r--r--dev-util/cppcheck/Manifest1
-rw-r--r--dev-util/cppcheck/cppcheck-2.13.0.ebuild6
-rw-r--r--dev-util/cppcheck/cppcheck-2.14.2.ebuild152
-rw-r--r--dev-util/cppcheck/files/cppcheck-2.13.0-32-bit-tests.patch28
-rw-r--r--sci-geosciences/gpsd/gpsd-3.25-r1.ebuild2
11 files changed, 190 insertions, 197 deletions
diff --git a/app-emulation/cloud-init/Manifest b/app-emulation/cloud-init/Manifest
index e09f96458f80..cabaa649916e 100644
--- a/app-emulation/cloud-init/Manifest
+++ b/app-emulation/cloud-init/Manifest
@@ -1,4 +1,2 @@
-DIST cloud-init-22.2.2.tar.gz 1349451 BLAKE2B fdb6669e9762984614fefe787834f20f056345d304327679fa8bc7b4d6566509a23ecc4a7ac4e6368b9b9078a72fe6fe35533a67e7aeb0c0accbf5ad014f8aae SHA512 18b75ebbb5e808e19df5ceddb6402cc881c33443fb169f736f54837254ba43836994f2392a26febbd8df3342b3467ee72759b6942cfeb96d07c0e452c11dd0bf
-DIST cloud-init-22.4.tar.gz 1494295 BLAKE2B 5f961c895c0d6c78a7cee47d2b52acd57d959baeb5172cea89d75ffe23424e3a8a3170a0ecdcad729c6cb0c898477ea94c43a5f8bdf200fc3f122c32fdb2e96d SHA512 6151d1d5e4be241219cb5804ca2bad2dd790f366bc847d286a8840faad1fb4adf5d780c9418ce574c2cfcefc16851a49961f33c5da1fbc84bb8299cf138bfcfc
DIST cloud-init-23.4.tar.gz 1648908 BLAKE2B 0acec9c437c7a5a86ed9cd8718830a7311c257ae9f223a68959b8d1eccc693b35f6a716de5c04112d848c1e2e54f6461a3919fd733debba18989145f6669d359 SHA512 34966b173571764bf83779bef0e89a86971310ff0fa62feceef4fbe17c9fa6d1b69f11f57caaa32cc4ae4a74f598f157dfb3ce356221044666401230cfb1ad13
DIST cloud-init-24.2.tar.gz 1786275 BLAKE2B 21f5209a77ef401d12271f6ea695d84065b22f40b7273dd8709dee5fadc7038a0f59a9a3dd53b73812a44a603b5cdc7fb36b71fcdb1f2d4295d87d2cc6069fcd SHA512 72de351b3e978e01a4695b58987d942cc1b2faee749ac0df2024a839e0e1539c9b1f0a9e5cf1930e33c36344d152b7580cfe2dd55f95ad4f669df9b4dda4648d
diff --git a/app-emulation/cloud-init/cloud-init-22.2.2.ebuild b/app-emulation/cloud-init/cloud-init-22.2.2.ebuild
deleted file mode 100644
index a1d0ec08c413..000000000000
--- a/app-emulation/cloud-init/cloud-init-22.2.2.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# Disabled for now: bug #850628
-# https://bugs.launchpad.net/cloud-init/+bug/1978328
-#DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_10 )
-
-inherit distutils-r1 udev
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://git.launchpad.net/cloud-init"
-else
- SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
- KEYWORDS="amd64 arm64 ppc64 x86"
-fi
-
-DESCRIPTION="Cloud instance initialisation magic"
-HOMEPAGE="https://launchpad.net/cloud-init"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="selinux test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/oauthlib[${PYTHON_USEDEP}]
- dev-python/pyserial[${PYTHON_USEDEP}]
- >=dev-python/configobj-5.0.2[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/jsonpatch[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/netifaces[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${CDEPEND}
- test? (
- >=dev-python/httpretty-0.7.1[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- ${CDEPEND}
- net-analyzer/macchanger
- sys-apps/iproute2
- sys-fs/growpart
- virtual/logger
- selinux? ( sec-policy/selinux-cloudinit )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Fix location of documentation installation
- sed -i "s:USR + '/share/doc/cloud-init:USR + '/share/doc/${PF}:" setup.py || die
-
- if [[ ${PV} == *9999 ]] ; then
- sed -i 's/version=get_version(),/version=9999,/g' setup.py || die
- fi
- distutils-r1_python_prepare_all
-}
-
-python_install() {
- distutils-r1_python_install --init-system=sysvinit_openrc,systemd --distro gentoo
-}
-
-python_install_all() {
- keepdir /etc/cloud
-
- distutils-r1_python_install_all
-
- # installs as non-executable
- chmod +x "${D}"/etc/init.d/* || die
-}
-
-pkg_prerm() {
- udev_reload
-}
-
-pkg_postinst() {
- udev_reload
-
- elog "cloud-init-local needs to be run in the boot runlevel because it"
- elog "modifies services in the default runlevel. When a runlevel is started"
- elog "it is cached, so modifications that happen to the current runlevel"
- elog "while you are in it are not acted upon."
-}
diff --git a/app-emulation/cloud-init/cloud-init-22.4.ebuild b/app-emulation/cloud-init/cloud-init-22.4.ebuild
deleted file mode 100644
index 839d6105a832..000000000000
--- a/app-emulation/cloud-init/cloud-init-22.4.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# Disabled for now: bug #850628
-# https://bugs.launchpad.net/cloud-init/+bug/1978328
-#DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_10 python3_11 )
-
-inherit distutils-r1 udev
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://git.launchpad.net/cloud-init"
-else
- SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
- KEYWORDS="amd64 arm64 ppc64 x86"
-fi
-
-DESCRIPTION="Cloud instance initialisation magic"
-HOMEPAGE="https://launchpad.net/cloud-init"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="selinux test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/oauthlib[${PYTHON_USEDEP}]
- dev-python/pyserial[${PYTHON_USEDEP}]
- >=dev-python/configobj-5.0.2[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/jsonpatch[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/netifaces[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${CDEPEND}
- test? (
- >=dev-python/httpretty-0.7.1[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- ${CDEPEND}
- net-analyzer/macchanger
- sys-apps/iproute2
- sys-fs/growpart
- virtual/logger
- selinux? ( sec-policy/selinux-cloudinit )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Fix location of documentation installation
- sed -i "s:USR + '/share/doc/cloud-init:USR + '/share/doc/${PF}:" setup.py || die
-
- if [[ ${PV} == *9999 ]] ; then
- sed -i 's/version=get_version(),/version=9999,/g' setup.py || die
- fi
- distutils-r1_python_prepare_all
-}
-
-python_install() {
- distutils-r1_python_install --init-system=sysvinit_openrc,systemd --distro gentoo
-}
-
-python_install_all() {
- keepdir /etc/cloud
-
- distutils-r1_python_install_all
-
- # installs as non-executable
- chmod +x "${D}"/etc/init.d/* || die
-}
-
-pkg_prerm() {
- udev_reload
-}
-
-pkg_postinst() {
- udev_reload
-
- elog "cloud-init-local needs to be run in the boot runlevel because it"
- elog "modifies services in the default runlevel. When a runlevel is started"
- elog "it is cached, so modifications that happen to the current runlevel"
- elog "while you are in it are not acted upon."
-}
diff --git a/app-pda/libimobiledevice-glue/libimobiledevice-glue-1.1.0.ebuild b/app-pda/libimobiledevice-glue/libimobiledevice-glue-1.1.0.ebuild
index 5c7e2d348566..003d3959025d 100644
--- a/app-pda/libimobiledevice-glue/libimobiledevice-glue-1.1.0.ebuild
+++ b/app-pda/libimobiledevice-glue/libimobiledevice-glue-1.1.0.ebuild
@@ -9,7 +9,7 @@ SRC_URI="https://github.com/libimobiledevice/libimobiledevice-glue/releases/down
LICENSE="LGPL-2.1+"
SLOT="0/0.1.0"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 x86"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~loong ppc ~ppc64 ~riscv ~s390 x86"
RDEPEND=">=app-pda/libplist-2.3:="
DEPEND="${RDEPEND}"
diff --git a/app-pda/libimobiledevice/libimobiledevice-1.3.0_p20240201.ebuild b/app-pda/libimobiledevice/libimobiledevice-1.3.0_p20240201.ebuild
index 7d45aec2a2d6..407e3ee47d02 100644
--- a/app-pda/libimobiledevice/libimobiledevice-1.3.0_p20240201.ebuild
+++ b/app-pda/libimobiledevice/libimobiledevice-1.3.0_p20240201.ebuild
@@ -15,7 +15,7 @@ S="${WORKDIR}"/${PN}-${MY_COMMIT}
# While COPYING* doesn't mention 'or any later version', all the headers do, hence use +
LICENSE="GPL-2+ LGPL-2.1+"
SLOT="0/1.0-6" # based on SONAME of libimobiledevice-1.0.so
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~x86"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~loong ppc ~ppc64 ~riscv ~s390 x86"
IUSE="doc gnutls readline static-libs"
RDEPEND="
diff --git a/dev-python/pychromecast/pychromecast-14.0.1.ebuild b/dev-python/pychromecast/pychromecast-14.0.1.ebuild
index 923d1d60979d..594ec1fad4db 100644
--- a/dev-python/pychromecast/pychromecast-14.0.1.ebuild
+++ b/dev-python/pychromecast/pychromecast-14.0.1.ebuild
@@ -18,7 +18,7 @@ HOMEPAGE="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
RDEPEND="
>=dev-python/casttube-0.2.0[${PYTHON_USEDEP}]
diff --git a/dev-util/cppcheck/Manifest b/dev-util/cppcheck/Manifest
index dcf062251619..d98c5f9a5b71 100644
--- a/dev-util/cppcheck/Manifest
+++ b/dev-util/cppcheck/Manifest
@@ -1,2 +1,3 @@
DIST cppcheck-2.13.0.tar.gz 3643744 BLAKE2B 942391bdc2ad009e1bf9f691835c268b33ae0a7c84ff68a1ea7985abbc65fc7ea6e319111ed6a968f4f93f3b682ce46447ba1e3b1fccd96535497f3fd190b913 SHA512 35f266cd247860aa0a0d84862faf4561f4efea096e641a01ebc3b1e4cea14c91c75773344da5bd3d48101c11ee7841b46f24419a9583e65bd242d0219a1ca418
+DIST cppcheck-2.14.2.tar.gz 3723248 BLAKE2B 551c783e13202f496b705602566799848b611bcc706f7a803c9ff530b3405db9e0b5294d2ce51ef5a4889e08c5b9d54c15d40a7ec6f4dc59333a7b6ed24b1f02 SHA512 8e90fa87845a083a4de66ec86edf707184a2293eb346fd79bfcafb73f93db049216472fcb2ab802ce529680f9708261ba3c26675c6fd9637e1dc83903bc44c4b
DIST cppcheck-2.9.tar.gz 3916529 BLAKE2B 5d75328e1fcd389376630502ad7427d3473392a9467e8731e6cd7c2c6349efccc05eddd7eca4cb361930661d2383a8d316e33bd3609b9333a710153d199e326d SHA512 69204a7ceac087470201482894e6422b99d0849f08641e80b2e341c9d164a1d2095e3a08a1fba2e9fa681783d07fe7277b30ea0cc0bf582431b5d13ab2f58c1f
diff --git a/dev-util/cppcheck/cppcheck-2.13.0.ebuild b/dev-util/cppcheck/cppcheck-2.13.0.ebuild
index 71c678e92cc5..56fb9ec37a41 100644
--- a/dev-util/cppcheck/cppcheck-2.13.0.ebuild
+++ b/dev-util/cppcheck/cppcheck-2.13.0.ebuild
@@ -75,10 +75,14 @@ BDEPEND="
)
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.13.0-32-bit-tests.patch
+)
+
src_prepare() {
cmake_src_prepare
- # Modify to an existing dockbook location
+ # Modify to an existing docbook location
sed -i \
-e "s|set(DB2MAN .*|set(DB2MAN \"${EPREFIX}/usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl\")|" \
man/CMakeLists.txt || die
diff --git a/dev-util/cppcheck/cppcheck-2.14.2.ebuild b/dev-util/cppcheck/cppcheck-2.14.2.ebuild
new file mode 100644
index 000000000000..088bb97b6b42
--- /dev/null
+++ b/dev-util/cppcheck/cppcheck-2.14.2.ebuild
@@ -0,0 +1,152 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit cmake python-single-r1 xdg
+
+DESCRIPTION="Static analyzer of C/C++ code"
+HOMEPAGE="https://github.com/danmar/cppcheck"
+SRC_URI="https://github.com/danmar/cppcheck/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="charts gui qt6 htmlreport pcre test"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ charts? ( gui )
+ qt6? ( gui )
+"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/tinyxml2:=
+ pcre? ( dev-libs/libpcre )
+ gui? (
+ qt6? (
+ dev-qt/qtbase:6[gui,widgets,network]
+ dev-qt/qttools:6[assistant,linguist]
+ charts? ( dev-qt/qtcharts:6 )
+ )
+ !qt6? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qthelp:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ charts? ( dev-qt/qtcharts:5 )
+ )
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ ${PYTHON_DEPS}
+ htmlreport? (
+ $(python_gen_cond_dep '
+ dev-python/pygments[${PYTHON_USEDEP}]
+ ')
+ )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ virtual/pkgconfig
+ gui? (
+ !qt6? (
+ dev-qt/linguist-tools:5
+ )
+ )
+ test? (
+ gui? (
+ !qt6? (
+ dev-qt/qttest:5
+ )
+ )
+ htmlreport? (
+ $(python_gen_cond_dep '
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ ')
+ )
+ )
+"
+
+src_prepare() {
+ cmake_src_prepare
+
+ # Modify to an existing docbook location
+ sed -i \
+ -e "s|set(DB2MAN .*|set(DB2MAN \"${EPREFIX}/usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl\")|" \
+ man/CMakeLists.txt || die
+
+ # Make tests use cppcheck built in build dir.
+ sed -i -e "s|CPPCHECK_BIN = .*|CPPCHECK_BIN = '${BUILD_DIR}/bin/cppcheck'|" htmlreport/test_htmlreport.py || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DFILESDIR="${EPREFIX}"/usr/share/${PF}/
+ -DBUILD_MANPAGE=ON
+
+ -DHAVE_RULES=$(usex pcre)
+
+ -DBUILD_GUI=$(usex gui)
+ -DUSE_QT6=$(usex qt6)
+ -DWITH_QCHART=$(usex charts)
+
+ -DBUILD_TESTS=$(usex test)
+ -DREGISTER_TESTS=$(usex test)
+ -DREGISTER_GUI_TESTS=$(usex test)
+
+ -DUSE_MATCHCOMPILER=ON
+ -DUSE_LIBCXX=OFF
+
+ -DDISABLE_DMAKE=ON
+ -DUSE_BOOST=OFF
+ -DUSE_BUNDLED_TINYXML2=OFF
+
+ # Yes, this is necessary to use the correct python version.
+ # bug #826602
+ -DPython_EXECUTABLE=${PYTHON}
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ cmake_build man
+}
+
+src_test() {
+ local CMAKE_SKIP_TESTS=(
+ # Out of source builds breaks test TestFileLister
+ # https://github.com/danmar/cppcheck/pull/5462
+ TestFileLister
+ )
+ cmake_src_test
+ use htmlreport && epytest htmlreport
+}
+
+src_install() {
+ cmake_src_install
+
+ insinto /usr/share/${PF}/cfg
+ doins cfg/*.cfg
+
+ if use gui ; then
+ dobin "${WORKDIR}/${P}_build/bin/${PN}-gui"
+ dodoc gui/{projectfile.txt,gui.${PN}}
+ fi
+
+ use htmlreport && python_doscript htmlreport/cppcheck-htmlreport
+ python_fix_shebang "${ED}"/usr/share/${PF}
+ python_optimize "${ED}"/usr/share/${PF}
+
+ dodoc -r tools/triage
+ doman "${BUILD_DIR}"/man/cppcheck.1
+}
diff --git a/dev-util/cppcheck/files/cppcheck-2.13.0-32-bit-tests.patch b/dev-util/cppcheck/files/cppcheck-2.13.0-32-bit-tests.patch
new file mode 100644
index 000000000000..a31a014f5968
--- /dev/null
+++ b/dev-util/cppcheck/files/cppcheck-2.13.0-32-bit-tests.patch
@@ -0,0 +1,28 @@
+https://bugs.gentoo.org/935368
+https://github.com/danmar/cppcheck/commit/9118d330d387e73a20e1bc46c65387306afa0895
+
+From 9118d330d387e73a20e1bc46c65387306afa0895 Mon Sep 17 00:00:00 2001
+From: chrchr-github <78114321+chrchr-github@users.noreply.github.com>
+Date: Sat, 23 Dec 2023 20:59:59 +0100
+Subject: [PATCH] Fix test failure on 32bit platform (#5803)
+
+--- a/test/testother.cpp
++++ b/test/testother.cpp
+@@ -2173,6 +2173,7 @@ class TestOther : public TestFixture {
+ "}\n");
+ ASSERT_EQUALS("[test.cpp:1]: (performance) Function parameter 't' should be passed by const reference.\n", errout.str());
+
++ Settings settings0 = settingsBuilder(_settings).platform(Platform::Type::Unix64).build();
+ check("struct S {\n" // #12138
+ " union {\n"
+ " int a = 0;\n"
+@@ -2189,7 +2190,7 @@ class TestOther : public TestFixture {
+ "};\n"
+ "void f(S s) {\n"
+ " if (s.x > s.y) {}\n"
+- "}\n");
++ "}\n", /*filename*/ nullptr, /*inconclusive*/ true, /*runSimpleChecks*/ true, /*verbose*/ false, &settings0);
+ ASSERT_EQUALS("", errout.str());
+
+ check("struct S { std::list<int> l; };\n" // #12147
+
diff --git a/sci-geosciences/gpsd/gpsd-3.25-r1.ebuild b/sci-geosciences/gpsd/gpsd-3.25-r1.ebuild
index bbc8c829c5bd..f7f785b3ea35 100644
--- a/sci-geosciences/gpsd/gpsd-3.25-r1.ebuild
+++ b/sci-geosciences/gpsd/gpsd-3.25-r1.ebuild
@@ -15,7 +15,7 @@ if [[ ${PV} == 9999 ]] ; then
inherit git-r3
else
SRC_URI="mirror://nongnu/${PN}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+ KEYWORDS="amd64 arm ~arm64 ~loong ~ppc ppc64 ~riscv ~sparc ~x86"
fi
DESCRIPTION="GPS daemon and library for USB/serial GPS devices and GPS/mapping clients"