summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-07 07:57:49 +0000
committerSam James <sam@gentoo.org>2022-11-07 07:57:49 +0000
commite5cb1ccc95873d55f9f643b043f3f7493fd31eee (patch)
treeab5e37db023e5628ae874e92281ee0788a993547
parentsci-libs/scikit-learn: Stabilize 1.1.2 x86, #879985 (diff)
downloadgentoo-e5cb1ccc95873d55f9f643b043f3f7493fd31eee.tar.gz
gentoo-e5cb1ccc95873d55f9f643b043f3f7493fd31eee.tar.bz2
gentoo-e5cb1ccc95873d55f9f643b043f3f7493fd31eee.zip
dev-lang/python: append ncurses include path after CBUILD Python is built
We don't want to contaminate the mini CBUILD Python cross build with paths in SYSROOT. Bug: https://bugs.gentoo.org/880059 Bug: https://bugs.gentoo.org/880137 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-lang/python/python-3.10.8_p2.ebuild10
-rw-r--r--dev-lang/python/python-3.11.0_p1.ebuild10
-rw-r--r--dev-lang/python/python-3.12.0_alpha1_p1.ebuild10
-rw-r--r--dev-lang/python/python-3.8.15_p2.ebuild10
-rw-r--r--dev-lang/python/python-3.9.15_p2.ebuild10
5 files changed, 25 insertions, 25 deletions
diff --git a/dev-lang/python/python-3.10.8_p2.ebuild b/dev-lang/python/python-3.10.8_p2.ebuild
index b1ce528e225d..9430e1042550 100644
--- a/dev-lang/python/python-3.10.8_p2.ebuild
+++ b/dev-lang/python/python-3.10.8_p2.ebuild
@@ -166,11 +166,6 @@ src_configure() {
# PKG_CONFIG needed for cross.
tc-export CXX PKG_CONFIG
- # Fix implicit declarations on cross and prefix builds. Bug #674070.
- if use ncurses; then
- append-cppflags -I"${ESYSROOT}"/usr/include/ncursesw
- fi
-
local dbmliborder=
if use gdbm; then
dbmliborder+="${dbmliborder:+:}gdbm"
@@ -289,6 +284,11 @@ src_configure() {
local -x LDFLAGS_NODIST=${LDFLAGS}
local -x CFLAGS= LDFLAGS=
+ # Fix implicit declarations on cross and prefix builds. Bug #674070.
+ if use ncurses; then
+ append-cppflags -I"${ESYSROOT}"/usr/include/ncursesw
+ fi
+
econf "${myeconfargs[@]}"
if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
diff --git a/dev-lang/python/python-3.11.0_p1.ebuild b/dev-lang/python/python-3.11.0_p1.ebuild
index b13b791e8dff..261ca987064c 100644
--- a/dev-lang/python/python-3.11.0_p1.ebuild
+++ b/dev-lang/python/python-3.11.0_p1.ebuild
@@ -153,11 +153,6 @@ src_configure() {
# PKG_CONFIG needed for cross.
tc-export CXX PKG_CONFIG
- # Fix implicit declarations on cross and prefix builds. Bug #674070.
- if use ncurses; then
- append-cppflags -I"${ESYSROOT}"/usr/include/ncursesw
- fi
-
local dbmliborder=
if use gdbm; then
dbmliborder+="${dbmliborder:+:}gdbm"
@@ -281,6 +276,11 @@ src_configure() {
local -x LDFLAGS_NODIST=${LDFLAGS}
local -x CFLAGS= LDFLAGS=
+ # Fix implicit declarations on cross and prefix builds. Bug #674070.
+ if use ncurses; then
+ append-cppflags -I"${ESYSROOT}"/usr/include/ncursesw
+ fi
+
econf "${myeconfargs[@]}"
if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
diff --git a/dev-lang/python/python-3.12.0_alpha1_p1.ebuild b/dev-lang/python/python-3.12.0_alpha1_p1.ebuild
index 8d748fa37b67..15f03994af05 100644
--- a/dev-lang/python/python-3.12.0_alpha1_p1.ebuild
+++ b/dev-lang/python/python-3.12.0_alpha1_p1.ebuild
@@ -149,11 +149,6 @@ src_configure() {
# PKG_CONFIG needed for cross.
tc-export CXX PKG_CONFIG
- # Fix implicit declarations on cross and prefix builds. Bug #674070.
- if use ncurses; then
- append-cppflags -I"${ESYSROOT}"/usr/include/ncursesw
- fi
-
local dbmliborder=
if use gdbm; then
dbmliborder+="${dbmliborder:+:}gdbm"
@@ -270,6 +265,11 @@ src_configure() {
popd &> /dev/null || die
fi
+ # Fix implicit declarations on cross and prefix builds. Bug #674070.
+ if use ncurses; then
+ append-cppflags -I"${ESYSROOT}"/usr/include/ncursesw
+ fi
+
econf "${myeconfargs[@]}"
if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
diff --git a/dev-lang/python/python-3.8.15_p2.ebuild b/dev-lang/python/python-3.8.15_p2.ebuild
index f03d22173cd6..649ae9032e52 100644
--- a/dev-lang/python/python-3.8.15_p2.ebuild
+++ b/dev-lang/python/python-3.8.15_p2.ebuild
@@ -152,11 +152,6 @@ src_configure() {
# PKG_CONFIG needed for cross.
tc-export CXX PKG_CONFIG
- # Fix implicit declarations on cross and prefix builds. Bug #674070.
- if use ncurses; then
- append-cppflags -I"${ESYSROOT}"/usr/include/ncursesw
- fi
-
local dbmliborder=
if use gdbm; then
dbmliborder+="${dbmliborder:+:}gdbm"
@@ -242,6 +237,11 @@ src_configure() {
local -x LDFLAGS_NODIST=${LDFLAGS}
local -x CFLAGS= LDFLAGS=
+ # Fix implicit declarations on cross and prefix builds. Bug #674070.
+ if use ncurses; then
+ append-cppflags -I"${ESYSROOT}"/usr/include/ncursesw
+ fi
+
econf "${myeconfargs[@]}"
if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
diff --git a/dev-lang/python/python-3.9.15_p2.ebuild b/dev-lang/python/python-3.9.15_p2.ebuild
index d5d9a2e273eb..b55a6f73b915 100644
--- a/dev-lang/python/python-3.9.15_p2.ebuild
+++ b/dev-lang/python/python-3.9.15_p2.ebuild
@@ -162,11 +162,6 @@ src_configure() {
# PKG_CONFIG needed for cross.
tc-export CXX PKG_CONFIG
- # Fix implicit declarations on cross and prefix builds. Bug #674070.
- if use ncurses; then
- append-cppflags -I"${ESYSROOT}"/usr/include/ncursesw
- fi
-
local dbmliborder=
if use gdbm; then
dbmliborder+="${dbmliborder:+:}gdbm"
@@ -283,6 +278,11 @@ src_configure() {
local -x LDFLAGS_NODIST=${LDFLAGS}
local -x CFLAGS= LDFLAGS=
+ # Fix implicit declarations on cross and prefix builds. Bug #674070.
+ if use ncurses; then
+ append-cppflags -I"${ESYSROOT}"/usr/include/ncursesw
+ fi
+
econf "${myeconfargs[@]}"
if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then