summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-09-09 01:40:01 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-09-09 02:16:09 +0200
commitdd208d76029e639b4a48c6c2ce90f08d92c854bc (patch)
treeac4c582fac81591bb6b65d442e73c37a6a703243
parentx11-libs/gtk+: Update 2.24.32 patchset from upstream branch (diff)
downloadgentoo-dd208d76029e639b4a48c6c2ce90f08d92c854bc.tar.gz
gentoo-dd208d76029e639b4a48c6c2ce90f08d92c854bc.tar.bz2
gentoo-dd208d76029e639b4a48c6c2ce90f08d92c854bc.zip
media-libs/libheif: initial version
Package-Manager: Portage-2.3.49, Repoman-2.3.10
-rw-r--r--media-libs/libheif/Manifest1
-rw-r--r--media-libs/libheif/libheif-1.3.2.ebuild57
-rw-r--r--media-libs/libheif/libheif-9999.ebuild57
-rw-r--r--media-libs/libheif/metadata.xml11
4 files changed, 126 insertions, 0 deletions
diff --git a/media-libs/libheif/Manifest b/media-libs/libheif/Manifest
new file mode 100644
index 000000000000..477b5f924659
--- /dev/null
+++ b/media-libs/libheif/Manifest
@@ -0,0 +1 @@
+DIST libheif-1.3.2.tar.gz 1328174 BLAKE2B 4c0f82bb90d48f89a4ce9aed525c5823bb5d008e54e580e761f6fa4f5493f265929a0607e7b81046ba7c249bd2ca21a0c5ab91da83b7e7f3a2a63e8f24df88ed SHA512 bcc8b4b2522ef6fe68f5a9ffd5312c2c8f6bc3718394eef1860e199c30fb735bb214f665ed6480b5f5fe5d578b3ed77a4301af93775ae2349ba5038b3f3ef63a
diff --git a/media-libs/libheif/libheif-1.3.2.ebuild b/media-libs/libheif/libheif-1.3.2.ebuild
new file mode 100644
index 000000000000..c5acd4efc7d6
--- /dev/null
+++ b/media-libs/libheif/libheif-1.3.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools multilib-minimal
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/strukturag/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/strukturag/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="ISO/IEC 23008-12:2017 HEIF file format decoder and encoder"
+HOMEPAGE="https://github.com/strukturag/libheif"
+
+LICENSE="GPL-3"
+SLOT="0/1.3"
+KEYWORDS=""
+IUSE="static-libs +threads"
+
+# Doesn't yet support libjpeg-turbo-2, https://github.com/strukturag/libheif/issues/70
+DEPEND="
+ media-libs/libde265:=[${MULTILIB_USEDEP}]
+ media-libs/libpng:0=[${MULTILIB_USEDEP}]
+ media-libs/x265:=[${MULTILIB_USEDEP}]
+ sys-libs/zlib:=[${MULTILIB_USEDEP}]
+ virtual/jpeg:0=[${MULTILIB_USEDEP}]
+ !>=media-libs/libjpeg-turbo-2
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i -e 's:-Werror::' \
+ configure.ac || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable threads multithreading)
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+ if ! use static-libs ; then
+ find "${ED}" -name "*.a" -delete || die
+ fi
+}
diff --git a/media-libs/libheif/libheif-9999.ebuild b/media-libs/libheif/libheif-9999.ebuild
new file mode 100644
index 000000000000..aaf71823adef
--- /dev/null
+++ b/media-libs/libheif/libheif-9999.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools multilib-minimal
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/strukturag/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/strukturag/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="ISO/IEC 23008-12:2017 HEIF file format decoder and encoder"
+HOMEPAGE="https://github.com/strukturag/libheif"
+
+LICENSE="GPL-3"
+SLOT="0/1.3.9999"
+KEYWORDS=""
+IUSE="static-libs +threads"
+
+# Doesn't yet support libjpeg-turbo-2, https://github.com/strukturag/libheif/issues/70
+DEPEND="
+ media-libs/libde265:=[${MULTILIB_USEDEP}]
+ media-libs/libpng:0=[${MULTILIB_USEDEP}]
+ media-libs/x265:=[${MULTILIB_USEDEP}]
+ sys-libs/zlib:=[${MULTILIB_USEDEP}]
+ virtual/jpeg:0=[${MULTILIB_USEDEP}]
+ !>=media-libs/libjpeg-turbo-2
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i -e 's:-Werror::' \
+ configure.ac || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable threads multithreading)
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+ if ! use static-libs ; then
+ find "${ED}" -name "*.a" -delete || die
+ fi
+}
diff --git a/media-libs/libheif/metadata.xml b/media-libs/libheif/metadata.xml
new file mode 100644
index 000000000000..22000d0b0b55
--- /dev/null
+++ b/media-libs/libheif/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>graphics@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/strukturag/libheif/issues</bugs-to>
+ <remote-id type="github">strukturag/libheif</remote-id>
+ </upstream>
+</pkgmetadata>