summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-08-28 17:02:21 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-08-28 17:04:14 -0400
commitdce2e1a26622ec605dcec77c478e12611b96f35d (patch)
tree266a5c722a7bc123394bb6963c65575a4b17674f
parentapp-vim/cctree: EAPI 6 bump. (diff)
downloadgentoo-dce2e1a26622ec605dcec77c478e12611b96f35d.tar.gz
gentoo-dce2e1a26622ec605dcec77c478e12611b96f35d.tar.bz2
gentoo-dce2e1a26622ec605dcec77c478e12611b96f35d.zip
net-irc/bnc: new EAPI=6 revision respecting LDFLAGS.
Update the ebuild to EAPI=6, and update an existing patch. We already had a patch that made the build system support CFLAGS, so rather than add another patch, binki's patch from Bugzilla was incorporated into the existing one. The result respects CFLAGS, CPPFLAGS, and LDFLAGS. Gentoo-Bug: 338181 Package-Manager: portage-2.2.28
-rw-r--r--net-irc/bnc/bnc-2.9.4-r1.ebuild47
-rw-r--r--net-irc/bnc/files/respect-cflags-ldflags.patch90
2 files changed, 137 insertions, 0 deletions
diff --git a/net-irc/bnc/bnc-2.9.4-r1.ebuild b/net-irc/bnc/bnc-2.9.4-r1.ebuild
new file mode 100644
index 000000000000..c9616cab0c5b
--- /dev/null
+++ b/net-irc/bnc/bnc-2.9.4-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_P="${P/-/}"
+DESCRIPTION="BNC (BouNCe) is used as a gateway to an IRC Server"
+HOMEPAGE="http://gotbnc.com/"
+SRC_URI="http://gotbnc.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~s390 ~sparc ~x86"
+IUSE="ssl"
+
+DEPEND="ssl? ( dev-libs/openssl:0 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/respect-cflags-ldflags.patch"
+ "${FILESDIR}/${PN}-2.9.3-64bit.patch"
+)
+
+src_prepare() {
+ default
+ sed -i -e 's:./mkpasswd:/usr/bin/bncmkpasswd:' bncsetup \
+ || die 'failed to rename mkpasswd in bncsetup'
+}
+
+src_configure() {
+ econf $(use_with ssl)
+}
+
+src_install() {
+ default
+ mv "${D}"/usr/bin/{,bnc}mkpasswd \
+ || die 'failed to rename the mkpasswd executable'
+ dodoc example.conf motd
+}
+
+pkg_postinst() {
+ einfo 'You can find an example motd/conf file here:'
+ einfo " /usr/share/doc/${PF}"
+}
diff --git a/net-irc/bnc/files/respect-cflags-ldflags.patch b/net-irc/bnc/files/respect-cflags-ldflags.patch
new file mode 100644
index 000000000000..ce3c30ecf63d
--- /dev/null
+++ b/net-irc/bnc/files/respect-cflags-ldflags.patch
@@ -0,0 +1,90 @@
+From e5663f7b7bd506b7af2ee7ab2e68722ade1f2a03 Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Sun, 28 Aug 2016 16:06:09 -0400
+Subject: [PATCH 1/1] autotools: fix --with-ssl option and respect
+ {C,CPP,LD}FLAGS.
+
+Patch the build system to support LDFLAGS. This is a new revision of
+an existing Gentoo patch that made the build system support CFLAGS,
+and incorporates binki's patch from our bugzilla to add CPPFLAGS
+support.
+
+The --with-ssl option is also fixed in configure.in (it was
+missing a dash).
+
+Gentoo-Bug: 338181
+---
+ Makefile.in | 32 +++++++++++++++++++++-----------
+ configure.in | 2 +-
+ 2 files changed, 22 insertions(+), 12 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index b7c9733..f28a355 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -1,28 +1,38 @@
+ LIBS=@LIBS@
+-CFLAGS=-O3 -Wall -include config.h
++CFLAGS=@CFLAGS@ -Wall
++CPPFLAGS = -include config.h @CPPFLAGS@
+ CC=@CC@
+
+-ALL: bnc mkpasswd
++DESTDIR =
++prefix = @prefix@
++exec_prefix = @exec_prefix@
++bindir = @bindir@
++
++all ALL: bnc mkpasswd
++
++install: bnc mkpasswd
++ install -m 755 -d $(DESTDIR)$(bindir)
++ install -m 755 bnc mkpasswd bncchk bncsetup $(DESTDIR)$(bindir)
+
+ mkpasswd:mkpasswd.c
+- ${CC} ${CFLAGS} -o mkpasswd mkpasswd.c ${LIBS}
++ ${CC} ${CFLAGS} -o mkpasswd mkpasswd.c ${LIBS} ${LDFLAGS}
+ bnc: bnc.o conf.o server.o cmds.o ctcp.o send.o sbuf.o Makefile
+- ${CC} -o bnc bnc.o conf.o server.o cmds.o ctcp.o sbuf.o send.o ${LIBS}
++ ${CC} -o bnc bnc.o conf.o server.o cmds.o ctcp.o sbuf.o send.o ${LIBS} ${LDFLAGS}
+
+ bnc.o: config.h struct.h bnc.c Makefile
+- ${CC} ${CFLAGS} -c bnc.c
++ ${CC} ${CPPFLAGS} ${CFLAGS} -c bnc.c
+ conf.o: config.h struct.h conf.c Makefile
+- ${CC} ${CFLAGS} -c conf.c
++ ${CC} ${CPPFLAGS} ${CFLAGS} -c conf.c
+ cmds.o: config.h struct.h cmds.c Makefile
+- ${CC} ${CFLAGS} -c cmds.c
++ ${CC} ${CPPFLAGS} ${CFLAGS} -c cmds.c
+ ctcp.o: config.h ctcp.c Makefile
+- ${CC} ${CFLAGS} -c ctcp.c
++ ${CC} ${CPPFLAGS} ${CFLAGS} -c ctcp.c
+ server.o: config.h struct.h server.c Makefile
+- ${CC} ${CFLAGS} -c server.c
++ ${CC} ${CPPFLAGS} ${CFLAGS} -c server.c
+ send.o: send.c send.h Makefile
+- ${CC} ${CFLAGS} -c send.c
++ ${CC} ${CPPFLAGS} ${CFLAGS} -c send.c
+ sbuf.o: sbuf.c
+- ${CC} ${CFLAGS} -c sbuf.c
++ ${CC} ${CPPFLAGS} ${CFLAGS} -c sbuf.c
+
+ clean:
+ rm -rf *.o *~ core bnc mkpasswd
+diff --git a/configure.in b/configure.in
+index be17af3..3552eb1 100644
+--- a/configure.in
++++ b/configure.in
+@@ -35,7 +35,7 @@ AC_CHECK_LIB(crypt, crypt, LIBS="$LIBS -lcrypt",)
+ dnl Check for SSL support.
+ AC_MSG_CHECKING(whether to enable SSL support)
+ AC_ARG_WITH(ssl,
+-[ -with-ssl Enable SSL support],
++[ --with-ssl Enable SSL support],
+ [ case "$withval" in
+ yes)
+ AC_MSG_RESULT(yes)
+--
+2.7.3
+