summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-02-13 20:36:19 +0000
committerMatthew Smith <matthew@gentoo.org>2022-02-13 20:36:35 +0000
commitd334406dd8d20eee8386128f886599d56bc7002c (patch)
tree6f9f1f088809c9ba1bc42d81f1081d6596106ba3
parentapp-shells/liquidprompt: add 2.0.4 (diff)
downloadgentoo-d334406dd8d20eee8386128f886599d56bc7002c.tar.gz
gentoo-d334406dd8d20eee8386128f886599d56bc7002c.tar.bz2
gentoo-d334406dd8d20eee8386128f886599d56bc7002c.zip
app-crypt/mkp224o: initial import at 1.5.0
Signed-off-by: Matthew Smith <matthew@gentoo.org>
-rw-r--r--app-crypt/mkp224o/Manifest1
-rw-r--r--app-crypt/mkp224o/metadata.xml14
-rw-r--r--app-crypt/mkp224o/mkp224o-1.5.0.ebuild36
3 files changed, 51 insertions, 0 deletions
diff --git a/app-crypt/mkp224o/Manifest b/app-crypt/mkp224o/Manifest
new file mode 100644
index 000000000000..7048da480d16
--- /dev/null
+++ b/app-crypt/mkp224o/Manifest
@@ -0,0 +1 @@
+DIST mkp224o-1.5.0-src.tar.gz 1378324 BLAKE2B 19d38fbf23328607fa428ec9329cdc909b210b4235d85e14ff372347c9b408ecf22d41dac7122bdae06725d7bca0c3d53c81cc27272c47517e714e9b8e0625dd SHA512 aa5adc91e695dbfd8ece5fdfe3ca370056d4390a5186326b35ee37402040fa24675ede5389c48b79a1e57b624b86024ff72957741fef175602f7721f20c5cc14
diff --git a/app-crypt/mkp224o/metadata.xml b/app-crypt/mkp224o/metadata.xml
new file mode 100644
index 000000000000..6bbe7e963edf
--- /dev/null
+++ b/app-crypt/mkp224o/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>matthew@gentoo.org</email>
+ <name>Matthew Smith</name>
+ </maintainer>
+ <use>
+ <flag name="pcre2">Search with a regex instead of prefix/suffix matching</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">cathugger/mkp224o</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/mkp224o/mkp224o-1.5.0.ebuild b/app-crypt/mkp224o/mkp224o-1.5.0.ebuild
new file mode 100644
index 000000000000..0c0578e589f5
--- /dev/null
+++ b/app-crypt/mkp224o/mkp224o-1.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Vanity address generator for v3 Tor hidden service addresses"
+HOMEPAGE="https://github.com/cathugger/mkp224o"
+SRC_URI="https://github.com/cathugger/${PN}/releases/download/v${PV}/${PN}-${PV}-src.tar.gz"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="cpu_flags_x86_sse2 pcre2"
+
+DEPEND="
+ dev-libs/libsodium:=
+ pcre2? ( dev-libs/libpcre2:= )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( OPTIMISATION.txt README.txt )
+
+src_configure() {
+ local myeconfargs=(
+ --enable-regex=$(usex pcre2)
+ --enable-statistics
+ )
+ use cpu_flags_x86_sse2 && myeconfargs+=( --enable-donna-sse2 )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ einstalldocs
+ dobin ${PN}
+}