summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-22 05:01:55 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-22 05:01:55 +0200
commitb6d68747c3cd7c33eb4c7f8a9bc06585b0f518fa (patch)
treeafeed781a4577f5c1effd5439b1a4bf381255940
parentdev-python/tokenize-rt: Bump to 6.1.0 (diff)
downloadgentoo-b6d68747c3cd7c33eb4c7f8a9bc06585b0f518fa.tar.gz
gentoo-b6d68747c3cd7c33eb4c7f8a9bc06585b0f518fa.tar.bz2
gentoo-b6d68747c3cd7c33eb4c7f8a9bc06585b0f518fa.zip
dev-python/pyupgrade: Bump to 3.19.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyupgrade/Manifest1
-rw-r--r--dev-python/pyupgrade/pyupgrade-3.19.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pyupgrade/Manifest b/dev-python/pyupgrade/Manifest
index 15595e0eeba9..7cc31bb52b11 100644
--- a/dev-python/pyupgrade/Manifest
+++ b/dev-python/pyupgrade/Manifest
@@ -1 +1,2 @@
DIST pyupgrade-3.18.0.gh.tar.gz 66227 BLAKE2B e788e3ce2b7f67fb8af62e430c6702b60729e6d7310085f785db8262e54429b11f25c95f922a3e51b2bcbc5120221ba00ef27a96f03ec4bd76d98c876a45fa43 SHA512 16a13f38ab422cb36eb3ac7546064b7c524bb746a7828c871ed67548dab57f97f22c80e9f89b520a763ae6b87dec78c7b7454dff74db7425157bf30d8e950ba4
+DIST pyupgrade-3.19.0.gh.tar.gz 66259 BLAKE2B 4bc4f519ae6a7d7473f66393383e0b26fab753e0e2dec347e46a69e06ff388fc2ead8c22db64711c39b46ada3822eefb53d6530ae61dfe81b14f745dec0f461c SHA512 6679887a458d03932538a617ea23e16324a2e40de1680bb56139a76e59f9d3adb226fdc20f56b1022d9ca7221beb6a92186e5027cf598682fbbb40b6dee80532
diff --git a/dev-python/pyupgrade/pyupgrade-3.19.0.ebuild b/dev-python/pyupgrade/pyupgrade-3.19.0.ebuild
new file mode 100644
index 000000000000..52e6f1cbf950
--- /dev/null
+++ b/dev-python/pyupgrade/pyupgrade-3.19.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool + pre-commit hook to automatically upgrade syntax for newer Pythons"
+HOMEPAGE="
+ https://github.com/asottile/pyupgrade/
+ https://pypi.org/project/pyupgrade/
+"
+# no tests in sdist, as of 3.3.2
+SRC_URI="
+ https://github.com/asottile/pyupgrade/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ >=dev-python/tokenize-rt-6.1.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest