summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2017-02-18 14:42:49 +0100
committerRobin H. Johnson <robbat2@gentoo.org>2017-06-05 14:14:38 -0700
commitb14df26895f8a4c582b325870c6ace190e85330b (patch)
treef4c9abb251cc7fc6d368c9280b9f4219297557e0
parentsys-apps/watchdog: add two musl patches and bump eapi (diff)
downloadgentoo-b14df26895f8a4c582b325870c6ace190e85330b.tar.gz
gentoo-b14df26895f8a4c582b325870c6ace190e85330b.tar.bz2
gentoo-b14df26895f8a4c582b325870c6ace190e85330b.zip
dev-util/strace: Fix ebuilds to support musl libc
This change resolves a compilation error: typedef redefinition with different types. (cherry picked from commit 274bc28b9e69b3571994f29ebcb69bbeb1e0a34f) Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> Fixes: https://github.com/gentoo/gentoo/pull/4008
-rw-r--r--dev-util/strace/strace-4.13.ebuild1
-rw-r--r--dev-util/strace/strace-4.16.ebuild1
-rw-r--r--dev-util/strace/strace-4.17.ebuild1
-rw-r--r--dev-util/strace/strace-9999.ebuild1
4 files changed, 4 insertions, 0 deletions
diff --git a/dev-util/strace/strace-4.13.ebuild b/dev-util/strace/strace-4.13.ebuild
index d4d722c581c4..8cc44de60594 100644
--- a/dev-util/strace/strace-4.13.ebuild
+++ b/dev-util/strace/strace-4.13.ebuild
@@ -42,6 +42,7 @@ src_prepare() {
use static && append-ldflags -static
export ac_cv_header_libaio_h=$(usex aio)
+ use elibc_musl && export ac_cv_header_stdc=no
# Stub out the -k test since it's known to be flaky. #545812
sed -i '1iexit 77' tests*/strace-k.test || die
diff --git a/dev-util/strace/strace-4.16.ebuild b/dev-util/strace/strace-4.16.ebuild
index 74b709da3f14..ce19fe29c67d 100644
--- a/dev-util/strace/strace-4.16.ebuild
+++ b/dev-util/strace/strace-4.16.ebuild
@@ -42,6 +42,7 @@ src_prepare() {
use static && append-ldflags -static
export ac_cv_header_libaio_h=$(usex aio)
+ use elibc_musl && export ac_cv_header_stdc=no
# Stub out the -k test since it's known to be flaky. #545812
sed -i '1iexit 77' tests*/strace-k.test || die
diff --git a/dev-util/strace/strace-4.17.ebuild b/dev-util/strace/strace-4.17.ebuild
index 11d04e224bee..9ec77eb9b806 100644
--- a/dev-util/strace/strace-4.17.ebuild
+++ b/dev-util/strace/strace-4.17.ebuild
@@ -42,6 +42,7 @@ src_prepare() {
use static && append-ldflags -static
export ac_cv_header_libaio_h=$(usex aio)
+ use elibc_musl && export ac_cv_header_stdc=no
# Stub out the -k test since it's known to be flaky. #545812
sed -i '1iexit 77' tests*/strace-k.test || die
diff --git a/dev-util/strace/strace-9999.ebuild b/dev-util/strace/strace-9999.ebuild
index 11d04e224bee..9ec77eb9b806 100644
--- a/dev-util/strace/strace-9999.ebuild
+++ b/dev-util/strace/strace-9999.ebuild
@@ -42,6 +42,7 @@ src_prepare() {
use static && append-ldflags -static
export ac_cv_header_libaio_h=$(usex aio)
+ use elibc_musl && export ac_cv_header_stdc=no
# Stub out the -k test since it's known to be flaky. #545812
sed -i '1iexit 77' tests*/strace-k.test || die