summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-11-18 08:21:27 +0000
committerMatthew Smith <matthew@gentoo.org>2022-11-18 08:26:02 +0000
commitaccecc76c8180b1066e4a0ec9028d2bbf55f3614 (patch)
treeb53bddc8569ab8760608d7e9f96e854945bad244
parentsci-geosciences/grass: remove unused compilation configuration --with-wxwidge... (diff)
downloadgentoo-accecc76c8180b1066e4a0ec9028d2bbf55f3614.tar.gz
gentoo-accecc76c8180b1066e4a0ec9028d2bbf55f3614.tar.bz2
gentoo-accecc76c8180b1066e4a0ec9028d2bbf55f3614.zip
dev-util/rebar: re-add meck dependency
Closes: https://bugs.gentoo.org/877313 Signed-off-by: Matthew Smith <matthew@gentoo.org>
-rw-r--r--dev-util/rebar/rebar-3.20.0.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/dev-util/rebar/rebar-3.20.0.ebuild b/dev-util/rebar/rebar-3.20.0.ebuild
index d3b407311ef5..64591ebffb41 100644
--- a/dev-util/rebar/rebar-3.20.0.ebuild
+++ b/dev-util/rebar/rebar-3.20.0.ebuild
@@ -4,12 +4,16 @@
EAPI=8
MY_PN=${PN}3
+MECK_PV=0.8.13 # see rebar.config
inherit bash-completion-r1
DESCRIPTION="A sophisticated build-tool for Erlang projects that follows OTP principles"
HOMEPAGE="https://www.rebar3.org https://github.com/erlang/rebar3"
-SRC_URI="https://github.com/erlang/${MY_PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="
+ https://github.com/erlang/${MY_PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://repo.hex.pm/tarballs/meck-${MECK_PV}.tar )
+"
S="${WORKDIR}"/${MY_PN}-${PV}
LICENSE="Apache-2.0 MIT BSD"
@@ -25,6 +29,14 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+src_unpack() {
+ unpack ${P}.tar.gz
+ mkdir "${S}"/vendor/meck || die
+ tar -O -xf "${DISTDIR}"/meck-${MECK_PV}.tar contents.tar.gz |
+ tar -xzf - -C "${S}"/vendor/meck
+ assert
+}
+
src_compile() {
./bootstrap || die
}