summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-05 18:20:01 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-06 00:18:49 +0100
commita2b4ea135aa40336bfc55c246730f896cc065970 (patch)
treee73cd0b274fb446c837ef25f5b9bf246ee4058f6
parentdev-python/pexpect: Clean old up (diff)
downloadgentoo-a2b4ea135aa40336bfc55c246730f896cc065970.tar.gz
gentoo-a2b4ea135aa40336bfc55c246730f896cc065970.tar.bz2
gentoo-a2b4ea135aa40336bfc55c246730f896cc065970.zip
dev-python/pillow: Clean old up
-rw-r--r--dev-python/pillow/Manifest1
-rw-r--r--dev-python/pillow/pillow-4.2.1-r2.ebuild82
2 files changed, 0 insertions, 83 deletions
diff --git a/dev-python/pillow/Manifest b/dev-python/pillow/Manifest
index c02c259eca28..827ac450d969 100644
--- a/dev-python/pillow/Manifest
+++ b/dev-python/pillow/Manifest
@@ -1,3 +1,2 @@
DIST Pillow-3.4.2.zip 11042238 BLAKE2B 334af6eeadb3203b51572eca6ad9c196f3eeac14da0f1aedc351db692b33d413fdf5bc5c8564d2f53c324d9485dbdbda664b75a570b779e24f238c21829b4a39 SHA512 5e05206db5bc1b4177384f7e91ee79015c6e1bbdc7c31c997da054391b9b5ec7c1ebdec258a33f598986533894f3324b03d0b4b385b94e72a0517a3437553b39
-DIST Pillow-4.2.1.tar.gz 12673417 BLAKE2B b37aaf76b1e40e8914843333330bbcbba5d9eff02c47b43d1aef44fe71ce3627057ddd51c55c50afb12a3ef0fae8bdec73b9de37a2bac9c33eba4fa027c4f157 SHA512 8a1c691f067c1127b941a94ae991c728c94eab876fe2a511ed0ad8af9702d4969325bd565b11e656ffefe867bf385725a5c14e3c28f8945730fa21986f934f69
DIST Pillow-4.3.0.tar.gz 13874155 BLAKE2B c2258efe2727adeb7ba370fe30ef9bbabe952a1f6690e7904352884951e648d2c0e2037143b7c71a802ea1a04a2f7827a001621480036e43f6c01a96de3edcf7 SHA512 5811252802bd01ac86157235d42138685e746723df48b67ec7c7ebd3f172532b40cf86ca9d3d792e82f03986303a084bf3491c0d511dc068dea1bc631afdeabb
diff --git a/dev-python/pillow/pillow-4.2.1-r2.ebuild b/dev-python/pillow/pillow-4.2.1-r2.ebuild
deleted file mode 100644
index 785dfedc3b93..000000000000
--- a/dev-python/pillow/pillow-4.2.1-r2.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-PYTHON_REQ_USE='tk?,threads(+)'
-
-inherit distutils-r1 eutils virtualx
-
-MY_PN=Pillow
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python Imaging Library (fork)"
-HOMEPAGE="https://python-pillow.org/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="HPND"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples imagequant jpeg2k lcms test tiff tk truetype webp zlib"
-
-REQUIRED_USE="test? ( tiff )"
-
-RDEPEND="
- dev-python/olefile[${PYTHON_USEDEP}]
- imagequant? ( media-gfx/libimagequant:0 )
- virtual/jpeg:0
- jpeg2k? ( media-libs/openjpeg:2= )
- lcms? ( media-libs/lcms:2= )
- tiff? ( media-libs/tiff:0=[jpeg] )
- truetype? ( media-libs/freetype:2= )
- webp? ( media-libs/libwebp:0= )
- zlib? ( sys-libs/zlib:0= )"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-S="${WORKDIR}/${MY_P}"
-
-src_compile() {
- # raqm not in portage yet
- distutils-r1_src_compile \
- --disable-raqm \
- $(use_enable truetype freetype) \
- $(use_enable jpeg2k jpeg2000) \
- $(use_enable lcms) \
- $(use_enable tiff) \
- $(use_enable imagequant) \
- $(use_enable webp) \
- $(use_enable webp webpmux) \
- $(use_enable zlib)
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- "${PYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
- virtx nosetests -vx Tests/test_*.py
-}
-
-python_install() {
- python_doheader libImaging/*.h
- distutils-r1_python_install
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- if use examples ; then
- docinto examples
- dodoc Scripts/*
- docompress -x /usr/share/doc/${PF}/examples
- fi
- distutils-r1_python_install_all
-}