summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-21 05:52:12 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-21 05:52:12 +0100
commita2b287a366bee40ab45f0993bb70aae3ff51ae17 (patch)
treee3528b9bd69611a2abb8ab32a053cfc7483e1ec1
parentapp-admin/awscli: Bump to 1.36.7 (diff)
downloadgentoo-a2b287a366bee40ab45f0993bb70aae3ff51ae17.tar.gz
gentoo-a2b287a366bee40ab45f0993bb70aae3ff51ae17.tar.bz2
gentoo-a2b287a366bee40ab45f0993bb70aae3ff51ae17.zip
dev-python/qiskit: Bump to 1.3.0_rc2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/qiskit/Manifest1
-rw-r--r--dev-python/qiskit/qiskit-1.3.0_rc2.ebuild309
2 files changed, 310 insertions, 0 deletions
diff --git a/dev-python/qiskit/Manifest b/dev-python/qiskit/Manifest
index df1e26592cc0..02f71391308e 100644
--- a/dev-python/qiskit/Manifest
+++ b/dev-python/qiskit/Manifest
@@ -153,6 +153,7 @@ DIST pyo3-macros-backend-0.21.2.crate 58088 BLAKE2B 05dd49983c8aeddc47cd94f6cd58
DIST pyo3-macros-backend-0.22.6.crate 66312 BLAKE2B ec0b11bee1ad2192e8d95cebab0075d6ec5bf628e3344b86fb8e20a6d0bc1f891b56ccfa4622840a609480581f32bd211b9a3d1dd989716cf255efe3fdc89331 SHA512 87463939b5a5674e30e8ca05ae747f652f8679f0c5c85d20967e9910ad853768a769a914580e82e409188fe4add80a3117ccb9da24c250406bc6f76fe4453799
DIST qiskit-1.2.4.gh.tar.gz 10825861 BLAKE2B 5a916fc3b726d3f623c5c822a475248c5e5ebe6c5d4ff9485d0177714c335cf87d29b7b911535df7a5f9076ee24e7d2c8116d9062ae4e1d689c83e3805607665 SHA512 46e7c83f9a4b3c0e99a6328fc50ebc30bc57aabf0773c229575734bac606649fb6e2d82f1b3de01983a8fb29a2416a813ce020d8d2c87714ad28a6d14ac5fcb0
DIST qiskit-1.3.0rc1.gh.tar.gz 11125834 BLAKE2B 6ff50d28fa8b8d3490e5ada449bc5a8cd2549ceef9d663decc3c172a1a63600f5beaed80693bab6406fb48f6a55aa2646f99a231009eeea651e06f8cda906116 SHA512 a7c8a8920a53a9fa4ea043a8f1432d9c93443d1cb4826576f68ca81d4edd2f9575ec9e30e9230fefdab816650099d5fbeb10b92a5a0de236e1433613da8367f1
+DIST qiskit-1.3.0rc2.gh.tar.gz 11127183 BLAKE2B b7c1b9f27397f7031d449ba796d9c43e5f985869b083f8b6985008c58ea12d23eb70fd7936eebc2b67a703306d4c0cb687b53f0dae7ca0815494d36d429eb3c7 SHA512 2e5a764175a0da0f2c0be4c3ec994762b1aceb6cafc1029d49523a23f9af8e15ee76d3191c7b0fcb1f89cf130f5d2471a01e8ea7c6d1caaf064bb2991fd33196
DIST quote-1.0.36.crate 28507 BLAKE2B b93495163ed205e33543ed45f084870240d479071d643704b6e348fb9ada6e1d8401893c13348b9964f4b6b17ddb96cb5458eec540f0d761655fcb96a4cd9129 SHA512 f1f002a912692f7ffd4912ca980ec57ff4aca3a7d9e2e42e9e3409e2105c9f59d86c05719f6af309bccaef2f8843b0848a6e3afda3356e045d8e7cc5956ae685
DIST quote-1.0.37.crate 28558 BLAKE2B a7d007a69e619f853af94333e1066bb767013312bd99f147b1b153611242bcfa9c76768b1ba47278589db309a9acd61a772c8ec3b567e48439bb9d831f9326d4 SHA512 c4ed21428c1f89cf22b85d80720a7869831a9c129d694617b0ce8c258278114ab98846f3f653abf736d1c86bc9224bbd695e9a7b06aa3adf292d02e1ef14cc05
DIST ra_ap_limit-0.0.188.crate 1283 BLAKE2B 265a70d088ed76500cdbefa04d1b2778d54985aa978b806e9ebb016348556559799b8ac889c00aeff51d4ff08f3fa86cd3be3742f5896916edbbda49bca1946e SHA512 01d56844fb4437959e93fc3394d674848eaae3365d271c01ba5ff12fc05d4a1d11eb4145ee89a65eb5ba12db4075e8102ee31df55c569c8ee5ad6d383f9f451a
diff --git a/dev-python/qiskit/qiskit-1.3.0_rc2.ebuild b/dev-python/qiskit/qiskit-1.3.0_rc2.ebuild
new file mode 100644
index 000000000000..86853089155e
--- /dev/null
+++ b/dev-python/qiskit/qiskit-1.3.0_rc2.ebuild
@@ -0,0 +1,309 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+CRATES="
+ ahash@0.7.8
+ ahash@0.8.11
+ aho-corasick@1.1.3
+ allocator-api2@0.2.18
+ approx@0.4.0
+ approx@0.5.1
+ ariadne@0.3.0
+ autocfg@1.4.0
+ bitflags@1.3.2
+ bitflags@2.6.0
+ block-buffer@0.10.4
+ boolenum@0.1.0
+ bytemuck@1.19.0
+ bytemuck_derive@1.8.0
+ byteorder@1.5.0
+ cfg-if@1.0.0
+ coe-rs@0.1.2
+ concolor-query@0.3.3
+ concolor@0.1.1
+ countme@3.0.1
+ cov-mark@2.0.0
+ cpufeatures@0.2.14
+ crossbeam-deque@0.8.5
+ crossbeam-epoch@0.9.18
+ crossbeam-utils@0.8.20
+ crunchy@0.2.2
+ crypto-common@0.1.6
+ dbgf@0.1.2
+ digest@0.10.7
+ drop_bomb@0.1.5
+ dyn-stack@0.10.0
+ either@1.13.0
+ enum-as-inner@0.6.1
+ equator-macro@0.2.1
+ equator-macro@0.4.1
+ equator@0.2.2
+ equator@0.4.1
+ equivalent@1.0.1
+ faer-entity@0.19.2
+ faer-ext@0.2.0
+ faer@0.19.4
+ fixedbitset@0.4.2
+ gemm-c32@0.18.0
+ gemm-c64@0.18.0
+ gemm-common@0.18.0
+ gemm-f16@0.18.0
+ gemm-f32@0.18.0
+ gemm-f64@0.18.0
+ gemm@0.18.0
+ generic-array@0.14.7
+ getrandom@0.2.15
+ half@2.4.1
+ hashbrown@0.12.3
+ hashbrown@0.14.5
+ hashbrown@0.15.0
+ heck@0.5.0
+ hermit-abi@0.4.0
+ indexmap@2.6.0
+ indoc@2.0.5
+ is-terminal@0.4.13
+ itertools@0.10.5
+ itertools@0.11.0
+ itertools@0.13.0
+ lazy_static@1.5.0
+ libc@0.2.159
+ libm@0.2.8
+ matrixcompare-core@0.1.0
+ matrixcompare@0.3.0
+ matrixmultiply@0.3.9
+ memchr@2.7.4
+ memoffset@0.9.1
+ nano-gemm-c32@0.1.0
+ nano-gemm-c64@0.1.0
+ nano-gemm-codegen@0.1.0
+ nano-gemm-core@0.1.0
+ nano-gemm-f32@0.1.0
+ nano-gemm-f64@0.1.0
+ nano-gemm@0.1.2
+ ndarray@0.15.6
+ ndarray_einsum_beta@0.7.0
+ npyz@0.8.3
+ num-bigint@0.4.6
+ num-complex@0.4.6
+ num-integer@0.1.46
+ num-traits@0.2.19
+ numpy@0.22.1
+ once_cell@1.20.2
+ oq3_lexer@0.7.0
+ oq3_parser@0.7.0
+ oq3_semantics@0.7.0
+ oq3_source_file@0.7.0
+ oq3_syntax@0.7.0
+ paste@1.0.15
+ pest@2.7.13
+ pest_derive@2.7.13
+ pest_generator@2.7.13
+ pest_meta@2.7.13
+ petgraph@0.6.5
+ portable-atomic@1.9.0
+ ppv-lite86@0.2.20
+ priority-queue@2.1.1
+ proc-macro-error-attr@1.0.4
+ proc-macro-error@1.0.4
+ proc-macro2@1.0.87
+ pulp-macro@0.1.1
+ pulp@0.18.22
+ py_literal@0.4.0
+ pyo3-build-config@0.22.6
+ pyo3-ffi@0.22.6
+ pyo3-macros-backend@0.22.6
+ pyo3-macros@0.22.6
+ pyo3@0.22.6
+ quote@1.0.37
+ ra_ap_limit@0.0.188
+ rand@0.8.5
+ rand_chacha@0.3.1
+ rand_core@0.6.4
+ rand_distr@0.4.3
+ rand_pcg@0.3.1
+ raw-cpuid@10.7.0
+ rawpointer@0.2.1
+ rayon-cond@0.3.0
+ rayon-core@1.12.1
+ rayon@1.10.0
+ reborrow@0.5.5
+ regex-automata@0.4.8
+ regex-syntax@0.8.5
+ regex@1.11.0
+ rowan@0.15.15
+ rustc-hash@1.1.0
+ rustiq-core@0.0.10
+ rustversion@1.0.17
+ rustworkx-core@0.15.1
+ same-file@1.0.6
+ seq-macro@0.3.5
+ serde@1.0.210
+ serde_derive@1.0.210
+ sha2@0.10.8
+ smallvec@1.13.2
+ smol_str@0.2.2
+ syn@1.0.109
+ syn@2.0.79
+ sysctl@0.5.5
+ target-lexicon@0.12.16
+ text-size@1.1.1
+ thiserror-impl@1.0.65
+ thiserror@1.0.65
+ triomphe@0.1.11
+ typenum@1.17.0
+ ucd-trie@0.1.7
+ unicode-ident@1.0.13
+ unicode-properties@0.1.3
+ unicode-width@0.1.14
+ unicode-xid@0.2.6
+ unindent@0.2.3
+ version_check@0.9.5
+ walkdir@2.5.0
+ wasi@0.11.0+wasi-snapshot-preview1
+ winapi-util@0.1.9
+ windows-sys@0.45.0
+ windows-sys@0.52.0
+ windows-sys@0.59.0
+ windows-targets@0.42.2
+ windows-targets@0.52.6
+ windows_aarch64_gnullvm@0.42.2
+ windows_aarch64_gnullvm@0.52.6
+ windows_aarch64_msvc@0.42.2
+ windows_aarch64_msvc@0.52.6
+ windows_i686_gnu@0.42.2
+ windows_i686_gnu@0.52.6
+ windows_i686_gnullvm@0.52.6
+ windows_i686_msvc@0.42.2
+ windows_i686_msvc@0.52.6
+ windows_x86_64_gnu@0.42.2
+ windows_x86_64_gnu@0.52.6
+ windows_x86_64_gnullvm@0.42.2
+ windows_x86_64_gnullvm@0.52.6
+ windows_x86_64_msvc@0.42.2
+ windows_x86_64_msvc@0.52.6
+ xshell-macros@0.2.6
+ xshell@0.2.6
+ yansi@0.5.1
+ zerocopy-derive@0.7.35
+ zerocopy@0.7.35
+"
+
+inherit cargo distutils-r1
+
+MY_P=${P/_}
+DESCRIPTION="An open-source SDK for working with quantum computers"
+HOMEPAGE="
+ https://github.com/Qiskit/qiskit/
+ https://pypi.org/project/qiskit/
+"
+SRC_URI="
+ https://github.com/Qiskit/qiskit/archive/${PV/_}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+ ${CARGO_CRATE_URIS}
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+# Dependent crate licenses
+LICENSE+="
+ Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD-2 MIT
+ Unicode-DFS-2016
+ || ( LGPL-3+ MPL-2.0 )
+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+visualization"
+
+RDEPEND="
+ >=dev-python/dill-0.3[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.17[${PYTHON_USEDEP}]
+ >=dev-python/python-constraint-1.4[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/rustworkx-0.15.0[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.5[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/symengine-0.11.0[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.10)
+ visualization? (
+ >=dev-python/matplotlib-3.3[${PYTHON_USEDEP}]
+ dev-python/pydot[${PYTHON_USEDEP}]
+ >=dev-python/pillow-4.2.1[${PYTHON_USEDEP}]
+ >=dev-python/pylatexenc-1.4[${PYTHON_USEDEP}]
+ >=dev-python/seaborn-0.9.0[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ >=dev-python/cython-0.27.1[${PYTHON_USEDEP}]
+ test? (
+ app-text/poppler[png]
+ >=dev-python/ddt-1.4.4[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-4.24.3[${PYTHON_USEDEP}]
+ >=dev-python/networkx-2.2[${PYTHON_USEDEP}]
+ >=dev-python/qiskit-aer-0.14[${PYTHON_USEDEP}]
+ >=dev-python/scikit-learn-0.20.0[${PYTHON_USEDEP}]
+ )
+"
+
+# Files built without CFLAGS/LDFLAGS, acceptable for rust
+QA_FLAGS_IGNORED="
+ usr/lib.*/py.*/site-packages/qiskit/_accelerate.*.so
+ usr/lib.*/py.*/site-packages/qiskit/_qasm2.*.so
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # strip forcing -Werror from tests that also leaks to other packages
+ sed -i -e '/filterwarnings.*error/d' test/utils/base.py || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/python/circuit/test_equivalence.py::TestEquivalenceLibraryVisualization::test_equivalence_draw
+ test/python/quantum_info/operators/symplectic/test_sparse_pauli_op.py::TestSparsePauliOpConversions::test_to_matrix_zero
+ test/python/transpiler/test_unitary_synthesis_plugin.py::TestUnitarySynthesisPlugin
+ test/python/visualization/test_dag_drawer.py::TestDagDrawer::test_dag_drawer_no_register
+ test/python/circuit/test_scheduled_circuit.py::TestScheduledCircuit::test_fail_to_assemble_circuits_with_unbounded_parameters
+ test/python/circuit/test_scheduled_circuit.py::TestScheduledCircuit::test_schedule_circuit_in_sec_when_no_one_tells_dt
+ test/python/compiler/test_assembler.py::TestCircuitAssembler::test_circuit_with_global_phase
+ test/python/compiler/test_assembler.py::TestPulseAssembler::test_assemble_user_rep_time_delay
+ # tiny image differences, sigh
+ test/python/visualization/test_gate_map.py::TestGateMap::test_plot_error_map_over_100_qubit
+ )
+
+ local EPYTEST_IGNORE=(
+ # Breaks xdist
+ test/python/qasm2/test_parse_errors.py
+ test/python/transpiler/test_preset_passmanagers.py
+ )
+
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # docstring mismatches
+ test/python/utils/test_deprecation.py::AddDeprecationDocstringTest::test_add_deprecation_docstring_meta_lines
+ test/python/utils/test_deprecation.py::AddDeprecationDocstringTest::test_add_deprecation_docstring_multiple_entries
+ test/python/utils/test_deprecation.py::AddDeprecationDocstringTest::test_add_deprecation_docstring_no_meta_lines
+ )
+ ;;
+ esac
+
+ rm -rf qiskit || die
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # Run the Python test suite rather than everything under test/ which
+ # includes the 'randomized' suite. Upstream run that in a separate CI job.
+ epytest test/python
+}