summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-03-10 16:48:27 +0100
committerSam James <sam@gentoo.org>2022-04-05 03:54:49 +0100
commita0d25650bbca63f6c2469880e0b347a5f694f3f1 (patch)
treebe339eaec6afc805054c0f4717c5ced5f9a0e4e8
parentapp-forensics/yara: version bump 4.2.0 (diff)
downloadgentoo-a0d25650bbca63f6c2469880e0b347a5f694f3f1.tar.gz
gentoo-a0d25650bbca63f6c2469880e0b347a5f694f3f1.tar.bz2
gentoo-a0d25650bbca63f6c2469880e0b347a5f694f3f1.zip
dev-python/yara-python: version bump 4.2.0
adding python tests Closes: https://bugs.gentoo.org/800275 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/24465 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/yara-python/Manifest1
-rw-r--r--dev-python/yara-python/yara-python-4.2.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/yara-python/Manifest b/dev-python/yara-python/Manifest
index eaf58cf3e445..de63fb4af0d1 100644
--- a/dev-python/yara-python/Manifest
+++ b/dev-python/yara-python/Manifest
@@ -1 +1,2 @@
DIST yara-python-4.1.3.tar.gz 33712 BLAKE2B 7878d12620f2834578c98a99bc259422d8ac54efc04ebd29ffa604c15b0462607ce950b3e19f8e80db07195e61dedb4efc8c2ffb18a0c5de0bf2755fe62776d1 SHA512 9c96ae78df7694dd55b8bdde4fad49043f120b94477fa9d7090610665072626eba4fa410cd9292205e0b18bb9f384f07288c0340232e163294b91051b84dcab2
+DIST yara-python-4.2.0.tar.gz 34459 BLAKE2B fce460385eaa75dd1779fe49c7937ff36d7604433deb310b6fe9e66af9ea521952f92bee61829372cf19c7efee170329609530f1f9e863991720e4887c3c1349 SHA512 ba08d709fc51679ec9fe36165e0864b79fc241f85c681bf59823fe7bb0e34e928cded050ff296147eb5bcb837485f39949aa93425a0eb9ca8b3730e60fac93f4
diff --git a/dev-python/yara-python/yara-python-4.2.0.ebuild b/dev-python/yara-python/yara-python-4.2.0.ebuild
new file mode 100644
index 000000000000..c9eca9c95ffd
--- /dev/null
+++ b/dev-python/yara-python/yara-python-4.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python interface for a malware identification and classification tool"
+HOMEPAGE="https://github.com/VirusTotal/yara-python"
+SRC_URI="https://github.com/virustotal/yara-python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${PYTHON_DEPS}
+ =app-forensics/yara-$(ver_cut 1-2)*"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+
+src_compile() {
+ compile_python() {
+ distutils-r1_python_compile --dynamic-linking
+ }
+ python_foreach_impl compile_python
+}
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}