summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-06-29 11:42:27 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-06-30 01:56:24 +0200
commit9c46f46986c8a4e7f66d60267e69db7c92fc11bb (patch)
tree120b324f8d78c8c06f7790529ddd019a65e383ce
parentmedia-gfx/gifsicle: add 1.95 (diff)
downloadgentoo-9c46f46986c8a4e7f66d60267e69db7c92fc11bb.tar.gz
gentoo-9c46f46986c8a4e7f66d60267e69db7c92fc11bb.tar.bz2
gentoo-9c46f46986c8a4e7f66d60267e69db7c92fc11bb.zip
media-gfx/chafa: add 1.14.1
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/37347 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--media-gfx/chafa/Manifest1
-rw-r--r--media-gfx/chafa/chafa-1.14.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/media-gfx/chafa/Manifest b/media-gfx/chafa/Manifest
index a33fde395387..e71ef6feb138 100644
--- a/media-gfx/chafa/Manifest
+++ b/media-gfx/chafa/Manifest
@@ -1 +1,2 @@
DIST chafa-1.12.5.tar.xz 939792 BLAKE2B 82fbcd7b071dba8534fdd391b6ce22f6de63b1e3eb30228ba1ce6e751c442efbc4a5141d30fa767cc0789b01518da016a4245f9c560837530daa4d92534a9eca SHA512 d0b719294bdc8880f2c65c1bd777ac0eb98d47d48147bc6f883f1917d4f9a6b246c4e9365bc0128b1332d4a268611ac7e479f346f13c49d2e56ff4f446f22d94
+DIST chafa-1.14.1.tar.xz 991656 BLAKE2B 1a7ba4c7d3958396c89b7b2f2873b4c1dfcf5209ae0d53fd0b2e014c3012a316a2d197a2f593c230e02bed01ed3119d6d0659d21b5f5d02dacd7eaaa626f2cb8 SHA512 61872acc3370318ab1a363cd21839978825d722d64225f968fd12acae1b7cf4a9be0f011fa2ab69a62cf61e32f095bb47aaf9d8796b97f25844703e7dfdfea35
diff --git a/media-gfx/chafa/chafa-1.14.1.ebuild b/media-gfx/chafa/chafa-1.14.1.ebuild
new file mode 100644
index 000000000000..06484a9f1cb7
--- /dev/null
+++ b/media-gfx/chafa/chafa-1.14.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="versatile and fast Unicode/ASCII/ANSI graphics renderer"
+HOMEPAGE="https://hpjansson.org/chafa/ https://github.com/hpjansson/chafa"
+SRC_URI="https://hpjansson.org/chafa/releases/${P}.tar.xz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+tools webp"
+
+RDEPEND="
+ dev-libs/glib:2
+ tools? ( >=media-libs/freetype-2.0.0 )
+ webp? ( media-libs/libwebp:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ # bug 909429
+ use webp && append-ldflags -lwebp
+
+ econf \
+ --disable-man \
+ $(use_with tools) \
+ $(use_with webp)
+}
+
+src_install() {
+ default
+
+ use tools && doman docs/chafa.1
+
+ find "${ED}" -name '*.la' -delete || die
+}