summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-11-07 14:18:21 -0500
committerZero_Chaos <zerochaos@gentoo.org>2018-11-07 15:01:10 -0500
commit9ac001371490e83fd2e84ba585bd2c3d91c78d16 (patch)
treef56b86fdff2e1dff82988b2e33ae53903ffadbf0
parentdev-ada/gprbuild: Stabilize and remove old (diff)
downloadgentoo-9ac001371490e83fd2e84ba585bd2c3d91c78d16.tar.gz
gentoo-9ac001371490e83fd2e84ba585bd2c3d91c78d16.tar.bz2
gentoo-9ac001371490e83fd2e84ba585bd2c3d91c78d16.zip
net-wireless/soapysdr: bump
add subslot Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
-rw-r--r--net-wireless/soapysdr/Manifest1
-rw-r--r--net-wireless/soapysdr/soapysdr-0.7.0.ebuild53
-rw-r--r--net-wireless/soapysdr/soapysdr-9999.ebuild7
3 files changed, 58 insertions, 3 deletions
diff --git a/net-wireless/soapysdr/Manifest b/net-wireless/soapysdr/Manifest
index f1850570c589..51daf073add6 100644
--- a/net-wireless/soapysdr/Manifest
+++ b/net-wireless/soapysdr/Manifest
@@ -1 +1,2 @@
DIST soapysdr-0.6.1.tar.gz 112820 BLAKE2B 42376a7a43c0d5a87a5b17b7d901cc7c74885083051c433c1f22427fe07a4fb0f111ddb460867bd7f748cb3ac6858b15e3dc69ba3ecca4574802c6bd0856a8cc SHA512 80ae8d0b096139e0df70524a1ff05fa1954755177d7920dbd8acb37e45cf86729e2745dcfd4e9c7ae2d7aa564335c2f197ca25ea387daa8f376d6c3e93234106
+DIST soapysdr-0.7.0.tar.gz 122933 BLAKE2B 2bd2f8812a6258a92ca4fe82ced10e3e97e348927dfc8a1f702a7ee4900b4fbe966a32566d1640a3474734074524cf31d8850b47a9b177e6e0e4d92c531409a6 SHA512 3dc69f070a2fe7acee9239154e58b21aa9c321fe35e2de77dfed8561016a93d5e693b5288da6d05e3d8c0f9ab7552ea12c4fd74ddb8d3c118d576f58251fb632
diff --git a/net-wireless/soapysdr/soapysdr-0.7.0.ebuild b/net-wireless/soapysdr/soapysdr-0.7.0.ebuild
new file mode 100644
index 000000000000..238bf83a0e24
--- /dev/null
+++ b/net-wireless/soapysdr/soapysdr-0.7.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit cmake-utils python-r1
+
+DESCRIPTION="vendor and platform neutral SDR support library"
+HOMEPAGE="https://github.com/pothosware/SoapySDR"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapySDR.git"
+ EGIT_CLONE_TYPE="shallow"
+ KEYWORDS=""
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pothosware/SoapySDR/archive/soapy-sdr-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapySDR-soapy-sdr-"${PV}"
+fi
+
+LICENSE="Boost-1.0"
+SLOT="0/${PV}"
+
+IUSE="bladerf hackrf python rtlsdr plutosdr uhd"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig:0 )
+"
+PDEPEND="bladerf? ( net-wireless/soapybladerf )
+ hackrf? ( net-wireless/soapyhackrf )
+ rtlsdr? ( net-wireless/soapyrtlsdr )
+ plutosdr? ( net-wireless/soapyplutosdr )
+ uhd? ( net-wireless/soapyuhd )"
+
+src_configure() {
+ configuration() {
+ mycmakeargs+=( -DENABLE_PYTHON=ON )
+ if python_is_python3; then
+ mycmakeargs+=( -DBUILD_PYTHON3=ON )
+ fi
+ }
+
+ if use python; then
+ python_foreach_impl configuration
+ fi
+
+ cmake-utils_src_configure
+}
diff --git a/net-wireless/soapysdr/soapysdr-9999.ebuild b/net-wireless/soapysdr/soapysdr-9999.ebuild
index 0669ed4ac687..238bf83a0e24 100644
--- a/net-wireless/soapysdr/soapysdr-9999.ebuild
+++ b/net-wireless/soapysdr/soapysdr-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -22,9 +22,9 @@ else
fi
LICENSE="Boost-1.0"
-SLOT="0"
+SLOT="0/${PV}"
-IUSE="bladerf hackrf python rtlsdr uhd"
+IUSE="bladerf hackrf python rtlsdr plutosdr uhd"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="python? ( ${PYTHON_DEPS} )"
@@ -34,6 +34,7 @@ DEPEND="${RDEPEND}
PDEPEND="bladerf? ( net-wireless/soapybladerf )
hackrf? ( net-wireless/soapyhackrf )
rtlsdr? ( net-wireless/soapyrtlsdr )
+ plutosdr? ( net-wireless/soapyplutosdr )
uhd? ( net-wireless/soapyuhd )"
src_configure() {