summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 08:31:50 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 08:53:30 +0100
commit97fd212c9dbfac164d1ec26757b276dfb11765ec (patch)
treea9139ca3acba019f1eeb3e8a7b6417f60a5f3527
parentdistutils-r1.eclass: Fix installing scripts w/ PEP517 & single-impl (diff)
downloadgentoo-97fd212c9dbfac164d1ec26757b276dfb11765ec.tar.gz
gentoo-97fd212c9dbfac164d1ec26757b276dfb11765ec.tar.bz2
gentoo-97fd212c9dbfac164d1ec26757b276dfb11765ec.zip
distutils-r1.eclass: Do not create ${BUILD_DIR}/lib in PEP 517 mode
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--eclass/distutils-r1.eclass16
1 files changed, 8 insertions, 8 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index a5500df86937..8d03d2d1771d 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1289,15 +1289,15 @@ distutils-r1_run_phase() {
# Undo the default switch in setuptools-60+ for the time being,
# to avoid replacing .egg-info file with directory in-place.
local -x SETUPTOOLS_USE_DISTUTILS="${SETUPTOOLS_USE_DISTUTILS:-stdlib}"
- fi
- # Bug 559644
- # using PYTHONPATH when the ${BUILD_DIR}/lib is not created yet might lead to
- # problems in setup.py scripts that try to import modules/packages from that path
- # during the build process (Python at startup evaluates PYTHONPATH, if the dir is
- # not valid then associates a NullImporter object to ${BUILD_DIR}/lib storing it
- # in the sys.path_importer_cache)
- mkdir -p "${BUILD_DIR}/lib" || die
+ # Bug 559644
+ # using PYTHONPATH when the ${BUILD_DIR}/lib is not created yet might lead to
+ # problems in setup.py scripts that try to import modules/packages from that path
+ # during the build process (Python at startup evaluates PYTHONPATH, if the dir is
+ # not valid then associates a NullImporter object to ${BUILD_DIR}/lib storing it
+ # in the sys.path_importer_cache)
+ mkdir -p "${BUILD_DIR}/lib" || die
+ fi
# Set up build environment, bug #513664.
local -x AR=${AR} CC=${CC} CPP=${CPP} CXX=${CXX}