summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-10-07 11:24:46 +0200
committerHans de Graaff <graaff@gentoo.org>2022-10-08 08:26:34 +0200
commit8ed504b2325cd3fc1cd7345a2b6658430f8e410f (patch)
tree7abc3670d3581b1a59a66136358c184cc6093789
parentdev-ruby/spy: add 1.0.3 (diff)
downloadgentoo-8ed504b2325cd3fc1cd7345a2b6658430f8e410f.tar.gz
gentoo-8ed504b2325cd3fc1cd7345a2b6658430f8e410f.tar.bz2
gentoo-8ed504b2325cd3fc1cd7345a2b6658430f8e410f.zip
dev-ruby/slop: add 4.9.3
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/slop/Manifest1
-rw-r--r--dev-ruby/slop/slop-4.9.3.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/slop/Manifest b/dev-ruby/slop/Manifest
index 7b1f98b217a4..2f880167c5c0 100644
--- a/dev-ruby/slop/Manifest
+++ b/dev-ruby/slop/Manifest
@@ -1 +1,2 @@
DIST slop-4.9.2.tgz 16633 BLAKE2B 8907314016066569279dbab6b52f50cee58044b46c1a88c7cfab3a31e1bd7e702f63da170a42f113c5611080d5d212b970dddd1e3aeb2bc8e86d5ea577b9f163 SHA512 dbecbc5edaf257131edf54fb5577531a962a6ed64f9414342b5060bee479cf7e4c9cfb891af3553644fbe7817a2067de3c83b379651a62da5983f0c42cd68fd6
+DIST slop-4.9.3.tgz 16887 BLAKE2B 10ce02eec161fa12a1f6078047c5461476a45e02ea6e27f4e9c888611cc24a8f74e7cf90607a93a9510b41577e70e344caeb7d865eaf0bc9f980cc34d73899d4 SHA512 fbbf9aa5e12ee6b5d3c1e2bbe55c160e196fb201ff50c266f035e7150b9ec3bc223c89e354e16b9cd4cecabaa71935334722e53b0363d5a2a59f6c0e50c2dc97
diff --git a/dev-ruby/slop/slop-4.9.3.ebuild b/dev-ruby/slop/slop-4.9.3.ebuild
new file mode 100644
index 000000000000..af101924120c
--- /dev/null
+++ b/dev-ruby/slop/slop-4.9.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="slop.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple option parser with an easy to remember syntax and friendly API"
+HOMEPAGE="https://github.com/injekt/slop"
+SRC_URI="https://github.com/injekt/${PN}/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' slop.gemspec || die
+}