summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-24 07:06:35 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-24 07:16:29 +0200
commit7ef2f050b4df7d6d73ae67b3d8b4d797a483325a (patch)
tree1bb626dee7b93c70ff587048c64ff57136ca3d76
parentdev-python/mygpoclient: Bump to 1.9 (diff)
downloadgentoo-7ef2f050b4df7d6d73ae67b3d8b4d797a483325a.tar.gz
gentoo-7ef2f050b4df7d6d73ae67b3d8b4d797a483325a.tar.bz2
gentoo-7ef2f050b4df7d6d73ae67b3d8b4d797a483325a.zip
dev-python/pytest-qt: Bump to 4.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-qt/Manifest1
-rw-r--r--dev-python/pytest-qt/pytest-qt-4.1.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/pytest-qt/Manifest b/dev-python/pytest-qt/Manifest
index 82b75962d056..b2b6f18692fd 100644
--- a/dev-python/pytest-qt/Manifest
+++ b/dev-python/pytest-qt/Manifest
@@ -1 +1,2 @@
DIST pytest-qt-4.0.2.tar.gz 113466 BLAKE2B 73ba6571958f3f4cd76c3e891eaa014d464b94a7965afac6cee5b43bafdc63d4d640f84c7bfa1666146ab5139f79c760bd9f5a2a44f788b6384df200ac48ad0d SHA512 7f59c499e1395460c2ff20a969cec16ca104f742c648faa0d7eb1528c04d8ee52c04c52798478bc01c5467bee33d3389b141424491ba5442f9df4e82f0dff173
+DIST pytest-qt-4.1.0.tar.gz 119702 BLAKE2B 7c906c94761df6472ae65a6ebb38dff07de8156730e3e10615ea8e08f0bd9f9fee07127ee6e8616055117b1db1911bc9b4486345d84b249664d317561195ad77 SHA512 bfb56abbaac47bf9da26eb19d6913d59872f2a9923da339e9a30a2145d0a094ddec36bcfa21d39c4cf318f95a83c72c249fe70034294a6791f9d84345f77451d
diff --git a/dev-python/pytest-qt/pytest-qt-4.1.0.ebuild b/dev-python/pytest-qt/pytest-qt-4.1.0.ebuild
new file mode 100644
index 000000000000..69dbc6a6d79f
--- /dev/null
+++ b/dev-python/pytest-qt/pytest-qt-4.1.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+PYSIDE2_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Pytest plugin for PyQt5 and PySide2 applications"
+HOMEPAGE="
+ https://pypi.org/project/pytest-qt/
+ https://github.com/pytest-dev/pytest-qt/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/QtPy[gui,testlib,widgets(+),${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/PyQt5[gui,testlib,widgets,${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pyside2[gui,testlib,widgets,${PYTHON_USEDEP}]
+ ' "${PYSIDE2_COMPAT[@]}")
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ # warnings from other plugins cause the test output matchers to fail
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytestqt.plugin
+
+ local EPYTEST_DESELECT=(
+ # requires the window to be activated; that doesn't seem
+ # to be possible inside Xvfb
+ "tests/test_basics.py::test_wait_window[waitActive-True]"
+
+ # we are forcing a specific module via envvar, effectively
+ # overriding the config
+ tests/test_basics.py::test_qt_api_ini_config
+ tests/test_basics.py::test_qt_api_ini_config_with_envvar
+ )
+
+ einfo "Testing with PyQt5"
+ PYTEST_QT_API="pyqt5" epytest || die
+ # Pyside2 is not compatible with python3.11
+ if has "${EPYTHON}" "${PYSIDE2_COMPAT[@]/_/.}"; then
+ einfo "Testing with PySide2"
+ PYTEST_QT_API="pyside2" epytest || die
+ fi
+}