summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-09 01:50:48 +0100
committerSam James <sam@gentoo.org>2022-07-09 01:50:56 +0100
commit7a2328ba9ebd19c17f98cc52e7d14dd9cfcb4bea (patch)
tree03fae900371531290d73fc82c83b947bfd7e2bc1
parentmedia-sound/mpd: add 0.23.8 (diff)
downloadgentoo-7a2328ba9ebd19c17f98cc52e7d14dd9cfcb4bea.tar.gz
gentoo-7a2328ba9ebd19c17f98cc52e7d14dd9cfcb4bea.tar.bz2
gentoo-7a2328ba9ebd19c17f98cc52e7d14dd9cfcb4bea.zip
net-misc/pulseaudio-dlna: treeclean
Bug: https://bugs.gentoo.org/813990 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/pulseaudio-dlna/files/pulseaudio-dlna.desktop9
-rw-r--r--net-misc/pulseaudio-dlna/metadata.xml11
-rw-r--r--net-misc/pulseaudio-dlna/pulseaudio-dlna-9999.ebuild73
-rw-r--r--profiles/package.mask7
4 files changed, 0 insertions, 100 deletions
diff --git a/net-misc/pulseaudio-dlna/files/pulseaudio-dlna.desktop b/net-misc/pulseaudio-dlna/files/pulseaudio-dlna.desktop
deleted file mode 100644
index dd6bcde58487..000000000000
--- a/net-misc/pulseaudio-dlna/files/pulseaudio-dlna.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Name=Pulseaudio DLNA
-Type=Application
-Comment=A lightweight streaming server which brings DLNA / UPNP and Chromecast support to PulseAudio and Linux
-Exec=sh -c "pkill pulseaudio-dlna; pulseaudio-dlna --request-timeout=30"
-Terminal=false
-Categories=
-NoDisplay=true
-StartupNotify=false
diff --git a/net-misc/pulseaudio-dlna/metadata.xml b/net-misc/pulseaudio-dlna/metadata.xml
deleted file mode 100644
index 27696bfc5aa6..000000000000
--- a/net-misc/pulseaudio-dlna/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>prometheanfire@gentoo.org</email>
- <name>Matthew Thode</name>
- </maintainer>
- <upstream>
- <remote-id type="github">masmu/pulseaudio-dlna</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/net-misc/pulseaudio-dlna/pulseaudio-dlna-9999.ebuild b/net-misc/pulseaudio-dlna/pulseaudio-dlna-9999.ebuild
deleted file mode 100644
index 6fc29c68a643..000000000000
--- a/net-misc/pulseaudio-dlna/pulseaudio-dlna-9999.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_7 python3_8 python3_9 )
-
-inherit desktop distutils-r1
-
-DESCRIPTION="A lightweight DLNA/UPNP/Chromecast streaming server for PulseAudio"
-HOMEPAGE="https://github.com/masmu/pulseaudio-dlna"
-
-if [[ ${PV} == *9999 ]];then
- inherit git-r3
- SRC_URI=""
- EGIT_REPO_URI="https://github.com/masmu/pulseaudio-dlna"
- EGIT_BRANCH="python3"
-else
- SRC_URI="https://github.com/masmu/pulseaudio-dlna/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE=""
-
-RDEPEND=">=dev-python/protobuf-python-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
- >=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
- >=dev-python/setproctitle-1.1.10[${PYTHON_USEDEP}]
- >=dev-python/notify2-0.3[${PYTHON_USEDEP}]
- >=dev-python/psutil-5.4.7[${PYTHON_USEDEP}]
- >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
- >=dev-python/pyroute2-0.3.5[${PYTHON_USEDEP}]
- >=dev-python/netifaces-0.10.0[${PYTHON_USEDEP}]
- >=dev-python/lxml-3[${PYTHON_USEDEP}]
- >=dev-python/pychromecast-2.3.0[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- >=dev-python/dbus-python-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/zeroconf-0.17.4[${PYTHON_USEDEP}]
- dev-python/pygobject[cairo,${PYTHON_USEDEP}]
- gnome-base/librsvg[introspection]
- x11-libs/gtk+:3[introspection]
- || (
- || (
- media-video/ffmpeg[encode,mp3,opus,vorbis]
- media-video/ffmpeg[encode,fdk,mp3,opus,vorbis]
- )
- (
- media-libs/flac
- media-sound/lame
- media-sound/opus-tools
- media-sound/sox
- media-sound/vorbis-tools
- )
- )"
-
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- || ( media-sound/pulseaudio-daemon media-sound/pulseaudio[daemon(+)] )"
-
-python_prepare_all() {
- sed -i '/dbus-python/d' setup.py || die
- sed -i '/notify2/d' setup.py || die
- sed -i '/docopt/d' setup.py || die
- sed -i '/pychromecast/d' setup.py || die
- distutils-r1_python_prepare_all
-}
-
-src_install() {
- distutils-r1_src_install
-
- domenu "${FILESDIR}/${PN}.desktop"
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index 07bf31c5be30..eec0265b9551 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -238,13 +238,6 @@ dev-python/editdistance-s
# w/ no hope of them being upstreamed. Bug #850958.
dev-cpp/commoncpp2
-# Michał Górny <mgorny@gentoo.org> (2022-06-08)
-# pulseaudio-dlna has not seen any upstream activity since 2017,
-# and has had its last release in 2016. It does not feature a non-live
-# ebuild.
-# Removal on 2022-07-08. Bug #813990.
-net-misc/pulseaudio-dlna
-
# Matt Turner <mattst88@gentoo.org> (2022-05-30)
# libwacom-2 broke ABI compatibility; reverse dependencies need to be updated.
# Bug #848501