summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-28 17:18:41 +0100
committerSam James <sam@gentoo.org>2022-10-28 18:01:49 +0100
commit75b201bb72b3f4fde70f4053d11c65e0123de01d (patch)
treeb0a3064af692c91f065ef4c01ba84d06a186f73a
parentmedia-libs/taglib: add 1.13 (diff)
downloadgentoo-75b201bb72b3f4fde70f4053d11c65e0123de01d.tar.gz
gentoo-75b201bb72b3f4fde70f4053d11c65e0123de01d.tar.bz2
gentoo-75b201bb72b3f4fde70f4053d11c65e0123de01d.zip
net-misc/vmnet: fix build w/ Clang 16
Closes: https://bugs.gentoo.org/871171 Closes: https://bugs.gentoo.org/712470 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/vmnet/files/vmnet-0.4-Fix-build-with-Clang-16.patch33
-rw-r--r--net-misc/vmnet/vmnet-0.4-r1.ebuild (renamed from net-misc/vmnet/vmnet-0.4.ebuild)5
2 files changed, 36 insertions, 2 deletions
diff --git a/net-misc/vmnet/files/vmnet-0.4-Fix-build-with-Clang-16.patch b/net-misc/vmnet/files/vmnet-0.4-Fix-build-with-Clang-16.patch
new file mode 100644
index 000000000000..058d2f2d5ddb
--- /dev/null
+++ b/net-misc/vmnet/files/vmnet-0.4-Fix-build-with-Clang-16.patch
@@ -0,0 +1,33 @@
+From 6c4416e8c266c7dc10eb3f3af8f913ace1da84e2 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Fri, 28 Oct 2022 17:16:17 +0100
+Subject: [PATCH] Fix build with Clang 16
+
+Bug: https://bugs.gentoo.org/871171
+--- a/vmnet.c
++++ b/vmnet.c
+@@ -49,12 +49,15 @@
+ * to set up the SLIP connection and parse/generated SLIP packets.
+ */
+
++#define _GNU_SOURCE
+ #include <errno.h>
+ #include <fcntl.h>
+ #include <pwd.h>
+ #include <signal.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
++#include <unistd.h>
+ #include <termios.h>
+ #include <sys/ioctl.h>
+ #include <sys/select.h>
+@@ -251,7 +254,7 @@ void tty_setup(slipconn *sc)
+ }
+ }
+
+-int slip_setup(slipconn *sc)
++void slip_setup(slipconn *sc)
+ {
+ int disc, sencap = 0;
+
diff --git a/net-misc/vmnet/vmnet-0.4.ebuild b/net-misc/vmnet/vmnet-0.4-r1.ebuild
index 5eaff92b3467..1fadcfdf151c 100644
--- a/net-misc/vmnet/vmnet-0.4.ebuild
+++ b/net-misc/vmnet/vmnet-0.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,10 +20,11 @@ KEYWORDS="~amd64 ~ppc x86"
IUSE=""
RDEPEND="sys-apps/net-tools"
-DEPEND=${RDEPEND}
+DEPEND="${RDEPEND}"
PATCHES=(
"${WORKDIR}"/${P/-/_}-1.diff
+ "${FILESDIR}"/${PN}-0.4-Fix-build-with-Clang-16.patch
)
src_compile() {