summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-15 17:59:38 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-15 18:27:54 +0100
commit741e223b6194918335e235cd43b2ce5bf6ba7f54 (patch)
tree62ca08f8f6e7e0c75cc7ab14e043e248e571721d
parentdev-python/oslo-utils: 3.41.3 bump (diff)
downloadgentoo-741e223b6194918335e235cd43b2ce5bf6ba7f54.tar.gz
gentoo-741e223b6194918335e235cd43b2ce5bf6ba7f54.tar.bz2
gentoo-741e223b6194918335e235cd43b2ce5bf6ba7f54.zip
dev-python/future: Modernize, fix tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/future/future-0.17.1.ebuild31
1 files changed, 20 insertions, 11 deletions
diff --git a/dev-python/future/future-0.17.1.ebuild b/dev-python/future/future-0.17.1.ebuild
index e99e2709bfab..0aee1d1a9313 100644
--- a/dev-python/future/future-0.17.1.ebuild
+++ b/dev-python/future/future-0.17.1.ebuild
@@ -14,25 +14,38 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
+IUSE="doc"
+distutils_enable_tests pytest
+
+# TODO: make numpy unconditional when it supports py3.8
BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-bootstrap-theme[${PYTHON_USEDEP}]
+ $(python_gen_any_dep '
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-bootstrap-theme[${PYTHON_USEDEP}]
+ ' python{2_7,3_{5,6,7}})
)
test? (
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' \
+ python{2_7,3_{5,6,7}})
)
"
-PATCHES=(
-)
+python_check_deps() {
+ use doc || return 0
+ has_version "dev-python/sphinx[${PYTHON_USEDEP}]" &&
+ has_version "dev-python/sphinx-bootstrap-theme[${PYTHON_USEDEP}]"
+}
python_prepare_all() {
sed -i "/'sphinx.ext.intersphinx'/d" docs/conf.py || die
+ # tests requiring network access
+ rm tests/test_future/test_requests.py || die
+ sed -i -e 's:test.*request_http:_&:' \
+ tests/test_future/test_standard_library.py || die
+
distutils-r1_python_prepare_all
}
@@ -42,7 +55,3 @@ python_compile_all() {
HTML_DOCS=( docs/_build/html/. )
fi
}
-
-python_test() {
- pytest -vv || die "Tests failed under ${EPYTHON}"
-}