summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2024-09-02 15:20:23 +0200
committerAgostino Sarubbo <ago@gentoo.org>2024-09-02 15:20:59 +0200
commit7327908c4e2d8fbcd6fdec5c17d9426e91c486b0 (patch)
tree005fd49ba3f12c86a07e1d8f0cd6907d38485633
parentdev-python/watchfiles: Remove old (diff)
downloadgentoo-7327908c4e2d8fbcd6fdec5c17d9426e91c486b0.tar.gz
gentoo-7327908c4e2d8fbcd6fdec5c17d9426e91c486b0.tar.bz2
gentoo-7327908c4e2d8fbcd6fdec5c17d9426e91c486b0.zip
dev-python/huawei-lte-api: add 1.10
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
-rw-r--r--dev-python/huawei-lte-api/Manifest1
-rw-r--r--dev-python/huawei-lte-api/huawei-lte-api-1.10.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/huawei-lte-api/Manifest b/dev-python/huawei-lte-api/Manifest
index 78eaa5f3bb82..0bc4f96c5d70 100644
--- a/dev-python/huawei-lte-api/Manifest
+++ b/dev-python/huawei-lte-api/Manifest
@@ -1 +1,2 @@
+DIST huawei-lte-api-1.10.gh.tar.gz 43853 BLAKE2B 568da364ecc709716a040a5f6c32f79b028ceca42ffce29949d064115279a4653544df50e30ac07ad873a1e98ba203093fcf000bca65b4b1ea6f4f009217d4c8 SHA512 7ffe128817bf38d60ee5dcbdb6668516a3ab47a02d34868ab9c9cc6b26cfae10c334a779b4ba63f0ec635b834fce46b12409b913f7c9b45a746ff5ba875e1758
DIST huawei-lte-api-1.9.3.gh.tar.gz 41344 BLAKE2B 3812c2dd5404320eb24bbe6e1e5819effad06641e96289ac279e5fe96add8880d837bf6770816f1bdce553cbf1aad73d370377c7f0713428d6ac46906d88602c SHA512 4f5f00dd416b017422753940ae69a1c24b424692fdf9e6ea29073035d381b5434462b022ebe44bf4d911eafe07f9ff57b8d349bf7140e0f33daba6384a73cd24
diff --git a/dev-python/huawei-lte-api/huawei-lte-api-1.10.ebuild b/dev-python/huawei-lte-api/huawei-lte-api-1.10.ebuild
new file mode 100644
index 000000000000..4315d293fdf2
--- /dev/null
+++ b/dev-python/huawei-lte-api/huawei-lte-api-1.10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="API For huawei LAN/WAN LTE Modems"
+HOMEPAGE="
+ https://github.com/Salamek/huawei-lte-api/
+ https://pypi.org/project/huawei-lte-api/
+"
+SRC_URI="
+ https://github.com/Salamek/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # make cryptodome-friendly
+ sed -i -e 's:pycryptodomex:pycryptodome:' setup.py || die
+ find -name '*.py' -exec \
+ sed -i -e 's:Cryptodome:Crypto:g' {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+distutils_enable_tests pytest