summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-04-21 00:27:02 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-04-21 00:27:02 +0200
commit5f8aa3a255481a7a3bf44ca0d6470a6bcb61cf7f (patch)
tree77d8248bdec345552f5046dc0018913c8bb4290b
parentdev-python/aiohttp: version bump to 1.3.5 (diff)
downloadgentoo-5f8aa3a255481a7a3bf44ca0d6470a6bcb61cf7f.tar.gz
gentoo-5f8aa3a255481a7a3bf44ca0d6470a6bcb61cf7f.tar.bz2
gentoo-5f8aa3a255481a7a3bf44ca0d6470a6bcb61cf7f.zip
net-print/hplip-plugin: Version bump to 3.17.4
Package-Manager: Portage-2.3.5, Repoman-2.3.1
-rw-r--r--net-print/hplip-plugin/Manifest1
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.17.4.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index f24a26a491f8..120e1c7c8bc4 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1,2 +1,3 @@
DIST hplip-3.16.11-plugin.run 2059585 SHA256 af2b06696dedffcba416e4af92bef4ce219df6a11c90b8506bd32c2eba6a7cf8 SHA512 579c00523f711c0e7601a825562242545c72f711a5fe19733604d9c55515bb50826f11941b6a5ab65e66f45d4610f4f0732fee069d3e8eaff96b99cf92d45482 WHIRLPOOL ace95bcda1ba22c07d9a808450f576935d2f214a85a925f18874f104c023362428ab7e1c61e2ed5f24907950ef271f09466d10a9dc3fa82d62729f297cdb399e
DIST hplip-3.16.3-plugin.run 2084271 SHA256 b7edef2a1c5c0a5e001deb4a18c0ef7202e653596e97144b8908ae093818070f SHA512 2ae8aeb40c2604a2c6b9725700f9addf7a82e819d603631158a5d5feac931248e53e7533178100df1fc12b0dc2340cb3ae0d85f145cd023a311f77bbe67e7c7f WHIRLPOOL 928117f862030eca9c3e5813eb8c4db66570923695b0c7af17df1992f339d2478f42af67ca0e0eb8cfa1d7425b522082fde3b8c829c3f5167e1ec503c95a986b
+DIST hplip-3.17.4-plugin.run 2059636 SHA256 d7fc1bd64a6b8c2ff87605ea92bf65a42a0702261800712892d8f14d247e430b SHA512 59e326178cac54380b2c1d0b645922537866aa765644d2b590019956f793638cf384f09a0259230ff8fb4d597eabba5a9c58822c60ef3d7ad6fba9f52e5a3fe3 WHIRLPOOL 91a8f02c04955d581d573bc3ca0094043b1b6f839f9d21a2d0a2d9fde8e8579e9a4cf7d8ed6c1b252aa4efea9c5b6a4361abaf59ded74899c37e8489e8df8b2b
diff --git a/net-print/hplip-plugin/hplip-plugin-3.17.4.ebuild b/net-print/hplip-plugin/hplip-plugin-3.17.4.ebuild
new file mode 100644
index 000000000000..1ec0d66dba46
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.17.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit udev unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="http://hplipopensource.com/hplip-web/index.html"
+SRC_URI="http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-${PV}-plugin.run"
+
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/udev
+"
+DEPEND=""
+
+S=${WORKDIR}
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PRESTRIPPED="
+ /usr/share/hplip/fax/plugins/fax_marvell.so
+ /usr/share/hplip/prnt/plugins/hbpl1.so
+ /usr/share/hplip/prnt/plugins/lj.so
+ /usr/share/hplip/scan/plugins/bb_marvell.so
+ /usr/share/hplip/scan/plugins/bb_soapht.so
+ /usr/share/hplip/scan/plugins/bb_soap.so
+"
+
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+src_unpack() {
+ unpack_makeself "hplip-${PV}-plugin.run"
+}
+
+src_install() {
+ local hplip_arch=$(use amd64 && echo 'x86_64' || echo 'x86_32')
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ fax_*) plugin_type=fax ;;
+ bb_*) plugin_type=scan ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ mkdir -p "${ED}/var/lib/hp/"
+ cat >> "${ED}/var/lib/hp/hplip.state" <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}