summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2019-03-22 23:59:23 +0000
committerAndrey Utkin <andrey_utkin@gentoo.org>2019-03-24 19:17:42 +0000
commit5b4558dddb387d62aff37e6ca64e8ad1592616c1 (patch)
treed149ee06c756a0043705bc0005951c8a5f24197d
parentsys-boot/raspberrypi-firmware: drop unused global vars (diff)
downloadgentoo-5b4558dddb387d62aff37e6ca64e8ad1592616c1.tar.gz
gentoo-5b4558dddb387d62aff37e6ca64e8ad1592616c1.tar.bz2
gentoo-5b4558dddb387d62aff37e6ca64e8ad1592616c1.zip
sys-boot/raspberrypi-firmware: add logic for non-live releases
This allows to add release ebuilds by copying the file verbatim. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
-rw-r--r--sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild
index 6037eca917bf..ad0ee67fad5d 100644
--- a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild
+++ b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild
@@ -3,14 +3,22 @@
EAPI=7
-inherit git-r3 mount-boot readme.gentoo-r1
+inherit mount-boot readme.gentoo-r1
DESCRIPTION="Raspberry PI boot loader and firmware"
HOMEPAGE="https://github.com/raspberrypi/firmware"
LICENSE="GPL-2 raspberrypi-videocore-bin"
SLOT="0"
-EGIT_REPO_URI="https://github.com/raspberrypi/firmware"
-EGIT_CLONE_TYPE="shallow"
+
+if [[ "${PV}" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/raspberrypi/firmware"
+ EGIT_CLONE_TYPE="shallow"
+else
+ SRC_URI="https://github.com/raspberrypi/firmware/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="-* ~arm ~arm64"
+ S="${WORKDIR}/firmware-${PV}"
+fi
RESTRICT="binchecks strip"