summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-10-31 19:16:54 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-10-31 19:39:09 +0100
commit51d8b40a82fd1fed175855a1020703cb10c195f3 (patch)
tree7a887effe127fd5c78ae407624a1083d481beb6a
parentsys-apps/iproute2: disable color again (diff)
downloadgentoo-51d8b40a82fd1fed175855a1020703cb10c195f3.tar.gz
gentoo-51d8b40a82fd1fed175855a1020703cb10c195f3.tar.bz2
gentoo-51d8b40a82fd1fed175855a1020703cb10c195f3.zip
app-emulation/qtrvsim: add 0.9.8
Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--app-emulation/qtrvsim/Manifest1
-rw-r--r--app-emulation/qtrvsim/qtrvsim-0.9.8.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-emulation/qtrvsim/Manifest b/app-emulation/qtrvsim/Manifest
index 762a7e2d5b7d..470f96e3d424 100644
--- a/app-emulation/qtrvsim/Manifest
+++ b/app-emulation/qtrvsim/Manifest
@@ -1 +1,2 @@
DIST qtrvsim-0.9.7.tar.gz 1421805 BLAKE2B 9128dbe513860eafd01e0f37a99547797d385b57a404e06aea310404012e66e6be802920cdea62acb914d355fc842cd3759fc794d2cd417257b941f9ec62fbec SHA512 0d53e21681630cbf97db472472bd96dfe4914e0d275a1094cb18a7f0372cef23b0dea3c33092b6ab6d2403737070ef0b6f2b1f5d9d35eea8923b24a80ac6adfe
+DIST qtrvsim-0.9.8.tar.gz 1442156 BLAKE2B d1e98f5cf0706c2d6cd1edcfdb92d60b4dcd9f74f05e4992f13fc30a11384a25e64af62dbda55a2a3befadbbb6c74d827d8316c392686212c9086487e5adf4c9 SHA512 88efbd3663faadff3f1df44edf518fa9c2f769339d336947cf61c9a9b359b264877f1062a3611b2c3446dbb26a5766316eeb2a861d9e325ca4587705eaddcf15
diff --git a/app-emulation/qtrvsim/qtrvsim-0.9.8.ebuild b/app-emulation/qtrvsim/qtrvsim-0.9.8.ebuild
new file mode 100644
index 000000000000..b1faa86770f2
--- /dev/null
+++ b/app-emulation/qtrvsim/qtrvsim-0.9.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="RISC-V CPU simulator for education"
+HOMEPAGE="https://github.com/cvut/qtrvsim"
+SRC_URI="https://github.com/cvut/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-qt/qtbase:6[gui,widgets]
+ virtual/libelf:=
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DQT_VERSION_MAJOR=6
+ )
+ cmake_src_configure
+}