summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-19 15:35:38 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-19 18:43:10 +0100
commit51540cf4f0ac9eb8dda0d753bd11a25fbcfcdb88 (patch)
tree9a21273b8959e40f9b81cf8c44f98e7740dca251
parentdev-python/cloudpickle: Bump to 2.2.1 (diff)
downloadgentoo-51540cf4f0ac9eb8dda0d753bd11a25fbcfcdb88.tar.gz
gentoo-51540cf4f0ac9eb8dda0d753bd11a25fbcfcdb88.tar.bz2
gentoo-51540cf4f0ac9eb8dda0d753bd11a25fbcfcdb88.zip
dev-python/openapi-core: Bump to 0.16.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/openapi-core/Manifest1
-rw-r--r--dev-python/openapi-core/openapi-core-0.16.5.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/openapi-core/Manifest b/dev-python/openapi-core/Manifest
index b74df1a3c818..913fcdaa2d64 100644
--- a/dev-python/openapi-core/Manifest
+++ b/dev-python/openapi-core/Manifest
@@ -2,3 +2,4 @@ DIST openapi-core-0.14.5.gh.tar.gz 57645 BLAKE2B c5c9c308b93a37e32708677cc7c7a2c
DIST openapi-core-0.16.1.gh.tar.gz 79002 BLAKE2B 2b64a28c80b64294cdbef2e4fcd08bfdc739c53a6baf0aeacc9e082bc01c8bf1b58da53a8c9b5b80a38600e4ab8bfb67b1d7ebb3a759d60d43748c9cc09c8eba SHA512 87cd47871a939b9f0ab23deafac067d16ba88146e140e7602b8bec5498ea6ed2213ceb530c9448718c5f94b944a954f2d46fab3fb18cacc2764a5cd7bf056dff
DIST openapi-core-0.16.2.gh.tar.gz 79801 BLAKE2B abe2e1521eb27431b386452b0826a99603f35551fca263bdc0e415865c88ba98216bab07f713b50a3ece35493b46d51496a541f1b10787ae27cac155673e5956 SHA512 d70369de21ffecc618fb8b3620f55510dd805304fb27742b48dc6603e03cb9322e2358a349d86de325307b99b26099879aac2f45c8a3d42ad8d464b43f2c5caa
DIST openapi-core-0.16.3.gh.tar.gz 103275 BLAKE2B 72a848ca4793a2a33a0cd78397c1030b09e2e271f24f5fb18064892d8ab30d282bd39062187da91cab76ea722ac2287341205e90ae9e0179505d160c4a5d8d64 SHA512 4b967c343ae20ee19df0cbf046762fd2e40ce6dcc4d54fd20a1c321f87eb513c51b9aa4224eb73d21497211612f39cc8bb12ef4dfd33bbf5c83e97f535ea3fcb
+DIST openapi-core-0.16.5.gh.tar.gz 104046 BLAKE2B 7dcda69b6d548a0df8c7727b184c7f7ec6d645e14ab4b4a256f188c6cc4ae9e351bc06ae03770782d81a11dfb5ebc08c20daabbd2151cfe62f84b05f80a47a16 SHA512 59db6d39a950079739b2df4114f26d85be55dc1f42d1661e8e6c17cf878cd8167f29ba4d3b6f40e06e85bb144c68286cb50adf4403091461798144cac05d5bc0
diff --git a/dev-python/openapi-core/openapi-core-0.16.5.ebuild b/dev-python/openapi-core/openapi-core-0.16.5.ebuild
new file mode 100644
index 000000000000..5f16bc813f6d
--- /dev/null
+++ b/dev-python/openapi-core/openapi-core-0.16.5.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Client-side and server-side support for the OpenAPI Specification v3"
+HOMEPAGE="
+ https://github.com/p1c2u/openapi-core/
+ https://pypi.org/project/openapi-core/
+"
+SRC_URI="
+ https://github.com/p1c2u/openapi-core/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pathable-0.4.0[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-spec-0.1.1[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/parse[${PYTHON_USEDEP}]
+ <dev-python/openapi-schema-validator-0.5[${PYTHON_USEDEP}]
+ >=dev-python/openapi-schema-validator-0.3[${PYTHON_USEDEP}]
+ <dev-python/openapi-spec-validator-0.6[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.5[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/asgiref[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.23.0[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/starlette-0.21.0[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # falcon is not packaged
+ tests/integration/contrib/falcon
+
+ # TODO: these tests fail to collect
+ tests/integration/validation/test_security_override.py
+ tests/integration/validation/test_read_only_write_only.py
+
+ # unhappy about modern django
+ tests/integration/contrib/django/test_django_project.py
+ tests/unit/contrib/django/test_django.py
+)
+
+src_prepare() {
+ sed -i -e '/--cov/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}