summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-04-26 12:12:57 +0200
committerDavid Seifert <soap@gentoo.org>2018-04-26 12:12:57 +0200
commit5022c3ce1d8a5d7dbb60a2d4a427a9379dbaf7c0 (patch)
tree46af26414d04eeb5fb5505c9d0bcf187551bbb2f
parentsci-libs/jama: Port to EAPI 6 (diff)
downloadgentoo-5022c3ce1d8a5d7dbb60a2d4a427a9379dbaf7c0.tar.gz
gentoo-5022c3ce1d8a5d7dbb60a2d4a427a9379dbaf7c0.tar.bz2
gentoo-5022c3ce1d8a5d7dbb60a2d4a427a9379dbaf7c0.zip
sci-libs/io_lib: Ebuild cleanup
Package-Manager: Portage-2.3.31, Repoman-2.3.9
-rw-r--r--sci-libs/io_lib/io_lib-1.14.7.ebuild22
-rw-r--r--sci-libs/io_lib/metadata.xml26
2 files changed, 25 insertions, 23 deletions
diff --git a/sci-libs/io_lib/io_lib-1.14.7.ebuild b/sci-libs/io_lib/io_lib-1.14.7.ebuild
index f1475e779918..61c5170f0012 100644
--- a/sci-libs/io_lib/io_lib-1.14.7.ebuild
+++ b/sci-libs/io_lib/io_lib-1.14.7.ebuild
@@ -1,27 +1,26 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils
-
DESCRIPTION="General purpose trace and experiment file reading/writing interface"
HOMEPAGE="http://staden.sourceforge.net/"
SRC_URI="mirror://sourceforge/staden/${P}.tar.gz"
LICENSE="BSD"
-SLOT="0"
+SLOT="0/11"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
IUSE="static-libs"
-DEPEND="
- net-misc/curl
- sys-libs/zlib"
-RDEPEND="${DEPEND}"
+RDEPEND="
+ app-arch/bzip2:=
+ app-arch/xz-utils:=
+ net-misc/curl:=
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}"
# tests fails and might need sci-biology/staden from
# the science overlay
-
RESTRICT="test"
src_configure() {
@@ -30,6 +29,9 @@ src_configure() {
src_install() {
default
- use static-libs || prune_libtool_files
dodoc docs/{Hash_File_Format,ZTR_format}
+
+ if ! use static-libs; then
+ find "${D}" \( -name '*.la' -o -name '*.a' \) -delete || die
+ fi
}
diff --git a/sci-libs/io_lib/metadata.xml b/sci-libs/io_lib/metadata.xml
index a88279ec5d96..e4325132e2d2 100644
--- a/sci-libs/io_lib/metadata.xml
+++ b/sci-libs/io_lib/metadata.xml
@@ -1,17 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription>
- io_lib is a library of file reading and writing code to provide a
- general purpose trace file (and Experiment File) reading interface. The
- programmer simply calls the (eg) read_reading to create a "Read" C structure
- with the data loaded into memory.
-</longdescription>
- <upstream>
- <remote-id type="sourceforge">staden</remote-id>
- </upstream>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>
+ io_lib is a library of file reading and writing code to provide a
+ general purpose trace file (and Experiment File) reading interface. The
+ programmer simply calls the (eg) read_reading to create a "Read" C structure
+ with the data loaded into memory.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">staden</remote-id>
+ </upstream>
</pkgmetadata>