summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2022-05-03 19:17:57 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2022-05-03 19:17:57 +0000
commit4a566d27bfd2eaf953f678b3d89c43cb79952b4e (patch)
tree5bb617c4937ab38a2abbf6d4cb8ce1dc9ec1cc6e
parent2022-05-03 19:03:08 UTC (diff)
parentsys-apps/smartmontools: Stabilize 7.3 arm, #841650 (diff)
downloadgentoo-4a566d27bfd2eaf953f678b3d89c43cb79952b4e.tar.gz
gentoo-4a566d27bfd2eaf953f678b3d89c43cb79952b4e.tar.bz2
gentoo-4a566d27bfd2eaf953f678b3d89c43cb79952b4e.zip
Merge updates from master
-rw-r--r--app-text/libspectre/Manifest1
-rw-r--r--app-text/libspectre/libspectre-0.2.10.ebuild46
-rw-r--r--dev-lang/spidermonkey/spidermonkey-91.8.0.ebuild2
-rw-r--r--dev-util/debugedit/debugedit-5.0-r1.ebuild2
-rw-r--r--net-wireless/bluez/bluez-5.64.ebuild1
-rw-r--r--sys-apps/smartmontools/smartmontools-7.3.ebuild2
-rw-r--r--sys-auth/polkit/polkit-0.120_p20220221.ebuild2
-rw-r--r--sys-power/upower/upower-0.99.17.ebuild2
-rw-r--r--x11-libs/libnotify/Manifest1
-rw-r--r--x11-libs/libnotify/libnotify-0.7.11.ebuild63
-rw-r--r--x11-libs/libnotify/metadata.xml4
11 files changed, 121 insertions, 5 deletions
diff --git a/app-text/libspectre/Manifest b/app-text/libspectre/Manifest
index 45abcebe3af8..5a0e02e4ad89 100644
--- a/app-text/libspectre/Manifest
+++ b/app-text/libspectre/Manifest
@@ -1 +1,2 @@
+DIST libspectre-0.2.10.tar.gz 436690 BLAKE2B 8c1d25225a212b7e8d2bab7cffa4298509450cf727e38d0be22d27ed5fb161a0f838967afa3f8aa265c2bd243431bbfb92976cf51ee52ee7d3b0479000215546 SHA512 01738f452f99878beaa528b15d8df463ca22d625306d636e1a6199ade9f068d284f1def3882e954a06e5f066937343f79d0c2197fbb19ab53ef1ab0540c72f2f
DIST libspectre-0.2.9.tar.gz 433384 BLAKE2B ed75a7013763a86c0f0702e0e47dcfb8401db6c957ed4851ecc85e27db6a49c8d4dae6443b302bcce5b0ae0da18dce3294a010eee5531a253020a650c19388c5 SHA512 7c24b5c83c6d356c89417d09dc76566afbe886ec189fe80d030a239c23ad25b061db071768117fa06805aa3d86f749fb232b7491bd7d467f26a40e348e74d5d2
diff --git a/app-text/libspectre/libspectre-0.2.10.ebuild b/app-text/libspectre/libspectre-0.2.10.ebuild
new file mode 100644
index 000000000000..04e44d862e05
--- /dev/null
+++ b/app-text/libspectre/libspectre-0.2.10.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Library for rendering Postscript documents"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libspectre"
+SRC_URI="https://libspectre.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="debug doc"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+RDEPEND=">=app-text/ghostscript-gpl-9.53.0:="
+DEPEND="${RDEPEND}"
+
+# does not actually test anything, see bug 362557
+RESTRICT="test"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug asserts)
+ $(use_enable debug checks)
+ --disable-static
+ --disable-test
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake
+ if use doc; then
+ doxygen || die
+ fi
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}
diff --git a/dev-lang/spidermonkey/spidermonkey-91.8.0.ebuild b/dev-lang/spidermonkey/spidermonkey-91.8.0.ebuild
index 2b6274d3f894..9ed5ddb8cf19 100644
--- a/dev-lang/spidermonkey/spidermonkey-91.8.0.ebuild
+++ b/dev-lang/spidermonkey/spidermonkey-91.8.0.ebuild
@@ -61,7 +61,7 @@ SRC_URI="${MOZ_SRC_BASE_URI}/source/${MOZ_P}.source.tar.xz -> ${MOZ_P_DISTFILES}
DESCRIPTION="SpiderMonkey is Mozilla's JavaScript engine written in C and C++"
HOMEPAGE="https://spidermonkey.dev https://firefox-source-docs.mozilla.org/js/index.html "
-KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~x86"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ppc64 ~riscv ~x86"
SLOT="91"
LICENSE="MPL-2.0"
diff --git a/dev-util/debugedit/debugedit-5.0-r1.ebuild b/dev-util/debugedit/debugedit-5.0-r1.ebuild
index e2131f16185e..18f1e7b7cde5 100644
--- a/dev-util/debugedit/debugedit-5.0-r1.ebuild
+++ b/dev-util/debugedit/debugedit-5.0-r1.ebuild
@@ -14,7 +14,7 @@ SRC_URI="
LICENSE="GPL-2+ LGPL-2+"
SLOT="0"
-KEYWORDS="amd64 arm ~arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
RDEPEND="
>=dev-libs/elfutils-0.176-r1
diff --git a/net-wireless/bluez/bluez-5.64.ebuild b/net-wireless/bluez/bluez-5.64.ebuild
index 9b4e71de94ac..739c0968b690 100644
--- a/net-wireless/bluez/bluez-5.64.ebuild
+++ b/net-wireless/bluez/bluez-5.64.ebuild
@@ -20,6 +20,7 @@ IUSE="btpclient cups doc debug deprecated extra-tools experimental +mesh midi +o
# again in the future.
# btpclient needs mesh, bug #790587
REQUIRED_USE="
+ btpclient? ( mesh )
extra-tools? ( deprecated readline )
test? ( ${PYTHON_REQUIRED_USE} )
test-programs? ( ${PYTHON_REQUIRED_USE} )
diff --git a/sys-apps/smartmontools/smartmontools-7.3.ebuild b/sys-apps/smartmontools/smartmontools-7.3.ebuild
index a905b133b6b9..16b77165a5d8 100644
--- a/sys-apps/smartmontools/smartmontools-7.3.ebuild
+++ b/sys-apps/smartmontools/smartmontools-7.3.ebuild
@@ -10,7 +10,7 @@ if [[ ${PV} == "9999" ]] ; then
inherit subversion
else
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
- KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ppc64 ~riscv sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+ KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ~ppc ppc64 ~riscv sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
fi
DESCRIPTION="Tools to monitor storage systems to provide advanced warning of disk degradation"
diff --git a/sys-auth/polkit/polkit-0.120_p20220221.ebuild b/sys-auth/polkit/polkit-0.120_p20220221.ebuild
index 82e672a67854..4c0e8acae1fb 100644
--- a/sys-auth/polkit/polkit-0.120_p20220221.ebuild
+++ b/sys-auth/polkit/polkit-0.120_p20220221.ebuild
@@ -17,7 +17,7 @@ fi
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ppc64 ~riscv ~s390 ~sparc ~x86"
IUSE="+duktape examples gtk +introspection kde pam selinux systemd test"
#RESTRICT="!test? ( test )"
# Tests currently don't work with meson. See
diff --git a/sys-power/upower/upower-0.99.17.ebuild b/sys-power/upower/upower-0.99.17.ebuild
index 9593e91adfa8..b180827e1b1e 100644
--- a/sys-power/upower/upower-0.99.17.ebuild
+++ b/sys-power/upower/upower-0.99.17.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/v${PV}/${PN}-v${PV
LICENSE="GPL-2"
SLOT="0/3" # based on SONAME of libupower-glib.so
-KEYWORDS="~alpha amd64 arm ~arm64 ~ia64 ~mips ~ppc ppc64 ~riscv sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~mips ~ppc ppc64 ~riscv sparc x86"
# gtk-doc files are not available as prebuilt in the tarball
IUSE="doc +introspection ios selinux test"
diff --git a/x11-libs/libnotify/Manifest b/x11-libs/libnotify/Manifest
index bc7c99eeb75d..ac48bb595cc4 100644
--- a/x11-libs/libnotify/Manifest
+++ b/x11-libs/libnotify/Manifest
@@ -1,2 +1,3 @@
+DIST libnotify-0.7.11.tar.xz 101616 BLAKE2B 202456000bc092707e171dfd3ba06b46ac2bd7b222e2dd70540c17eda32639369cf9af2e275a49ea3a0859598d271cdd733b68ff66ed2c30d3c0987fa6de6a97 SHA512 1e96b88278fb5e941dc691a7bbb83ea7fbc46d7873e7e10d988cd44dd83fcd678956bf9e5cd2f5533cf316b2a23354161c80a5b12299eb119a3f5697e4935ed7
DIST libnotify-0.7.8.tar.xz 108436 BLAKE2B 0a73eabe58faca55e16774cda6f649ab3187bd73a1f87b538d5098f390571a6a34078883dbd2447731d6e4cae315d8286e9e8acc06e85590c8b05a693a83e7f7 SHA512 9973d7a1af5dd7cfbaa0d0d2c9e72a40df9d814967fde47e95763a69690cc4ed32ecf713d75f91f3dff99a693eff9dab963be124e0530ebf231d517a44e75e94
DIST libnotify-0.7.9.tar.xz 98148 BLAKE2B 4728d00a204cd1003e8171a54c23bb975c0477c245c1175558f27555763113ec8bd7abd7ef81f6bad2b98604efe436d843958e77473436e68560775804473383 SHA512 8a842b50777279efdb7d96a836a546c47decad158a4f03f7ffc818860d1f6276a657619e4f4a19a4e2f5ad55e0371c793420d50d802983700e8c342273b73874
diff --git a/x11-libs/libnotify/libnotify-0.7.11.ebuild b/x11-libs/libnotify/libnotify-0.7.11.ebuild
new file mode 100644
index 000000000000..b2f00994e9f7
--- /dev/null
+++ b/x11-libs/libnotify/libnotify-0.7.11.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson-multilib xdg-utils
+
+DESCRIPTION="A library for sending desktop notifications"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libnotify"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="gtk-doc +introspection test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.26:2[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-libs/gobject-introspection-common-1.32
+ dev-util/glib-utils
+ virtual/pkgconfig
+ app-text/docbook-xsl-ns-stylesheets
+ dev-libs/libxslt
+ gtk-doc? ( dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.1.2 )
+ test? ( x11-libs/gtk+:3[${MULTILIB_USEDEP}] )
+"
+IDEPEND="app-eselect/eselect-notify-send"
+PDEPEND="virtual/notification-daemon"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ $(meson_native_use_feature introspection)
+ $(meson_native_use_bool gtk-doc gtk_doc)
+ -Ddocbook_docs=disabled
+ )
+ meson_src_configure
+}
+
+multilib_src_install() {
+ meson_src_install
+
+ mv "${ED}"/usr/bin/{,libnotify-}notify-send || die #379941
+}
+
+pkg_postinst() {
+ eselect notify-send update ifunset
+}
+
+pkg_postrm() {
+ eselect notify-send update ifunset
+}
diff --git a/x11-libs/libnotify/metadata.xml b/x11-libs/libnotify/metadata.xml
index 76d4eb294b39..63b6d8453c24 100644
--- a/x11-libs/libnotify/metadata.xml
+++ b/x11-libs/libnotify/metadata.xml
@@ -2,6 +2,10 @@
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <maintainer type="project">
<email>freedesktop-bugs@gentoo.org</email>
<name>Gentoo Freedesktop Project</name>
</maintainer>