summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-02-11 21:21:55 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-02-11 22:05:19 -0500
commit47c12dd527ebeccfc2d454efb584c7177f3eaaf9 (patch)
tree342868c73f2eb1b66779c8de4e15137056b729a1
parentgames-puzzle/pingus: enable py3.10 + respect EPREFIX (diff)
downloadgentoo-47c12dd527ebeccfc2d454efb584c7177f3eaaf9.tar.gz
gentoo-47c12dd527ebeccfc2d454efb584c7177f3eaaf9.tar.bz2
gentoo-47c12dd527ebeccfc2d454efb584c7177f3eaaf9.zip
games-rpg/adonthell: enable py3.10
Turns out enabling py3.10 on this was simpler than it looked. Unsure if entirely fine, but games-rpg/wastesedge seems to work. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-rpg/adonthell/adonthell-0.3.8.ebuild8
-rw-r--r--games-rpg/adonthell/files/adonthell-0.3.8-python3.10.patch7
2 files changed, 11 insertions, 4 deletions
diff --git a/games-rpg/adonthell/adonthell-0.3.8.ebuild b/games-rpg/adonthell/adonthell-0.3.8.ebuild
index 55a6d24270f2..4a48d53e89f0 100644
--- a/games-rpg/adonthell/adonthell-0.3.8.ebuild
+++ b/games-rpg/adonthell/adonthell-0.3.8.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8,9} )
-
+PYTHON_COMPAT=( python3_{8..10} )
inherit autotools python-single-r1
DESCRIPTION="Roleplaying game engine"
@@ -39,7 +38,8 @@ BDEPEND="
DOCS=( AUTHORS NEWBIE NEWS README )
PATCHES=(
- "${FILESDIR}/${P}-ar.patch"
+ "${FILESDIR}"/${P}-ar.patch
+ "${FILESDIR}"/${P}-python3.10.patch
)
src_prepare() {
diff --git a/games-rpg/adonthell/files/adonthell-0.3.8-python3.10.patch b/games-rpg/adonthell/files/adonthell-0.3.8-python3.10.patch
new file mode 100644
index 000000000000..21bba839a271
--- /dev/null
+++ b/games-rpg/adonthell/files/adonthell-0.3.8-python3.10.patch
@@ -0,0 +1,7 @@
+node.h was removed in python3.10 but this does not actually use it
+--- a/src/python_class.h
++++ b/src/python_class.h
+@@ -38,3 +38,2 @@
+ #include "eval.h"
+-#include "node.h"
+ #include "fileops.h"