diff options
author | Sam James <sam@gentoo.org> | 2021-04-19 06:14:26 +0100 |
---|---|---|
committer | Sam James <sam@gentoo.org> | 2021-04-19 20:09:31 +0100 |
commit | 4152ee38b5fc05b8c5d71c00d7769e0c0a7d518a (patch) | |
tree | e9357e48be6af2d986309e73376db4e4e71dd060 | |
parent | app-antivirus/clamav: remove unused patches/files (diff) | |
download | gentoo-4152ee38b5fc05b8c5d71c00d7769e0c0a7d518a.tar.gz gentoo-4152ee38b5fc05b8c5d71c00d7769e0c0a7d518a.tar.bz2 gentoo-4152ee38b5fc05b8c5d71c00d7769e0c0a7d518a.zip |
app-misc/hexcompare: port to EAPI 7, respect ${PKG_CONFIG}
* Port to EAPI 7
* Add ncurses slot dep
* Respect ${PKG_CONFIG}
* Add virtual/pkgconfig (B)DEPEND (which is from the original patch!)
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r-- | app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch | 6 | ||||
-rw-r--r-- | app-misc/hexcompare/hexcompare-1.0.4.ebuild | 18 |
2 files changed, 14 insertions, 10 deletions
diff --git a/app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch b/app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch index 5ccef2047bc7..2af79a1d2967 100644 --- a/app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch +++ b/app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch @@ -1,5 +1,5 @@ ---- hexcompare-1.0.4/Makefile -+++ hexcompare-1.0.4/Makefile +--- a/Makefile ++++ b/Makefile @@ -1,9 +1,9 @@ -CFLAGS = -O3 -Wall -Wextra -pedantic -Wformat-security -std=gnu89
+CFLAGS += -Wall -Wextra -pedantic -Wformat-security -std=gnu89
@@ -8,7 +8,7 @@ hexcompare: main.c gui.c
- $(CC) $(CFLAGS) -o hexcompare main.c gui.c -lncurses
-+ $(CC) $(CFLAGS) `pkg-config --cflags ncurses` -o hexcompare main.c gui.c `pkg-config --libs ncurses`
++ $(CC) $(CFLAGS) `${PKG_CONFIG} --cflags ncurses` -o hexcompare main.c gui.c `${PKG_CONFIG} --libs ncurses`
clean:
rm -f *.o
diff --git a/app-misc/hexcompare/hexcompare-1.0.4.ebuild b/app-misc/hexcompare/hexcompare-1.0.4.ebuild index 1dfa265504c5..597e96bc2ffb 100644 --- a/app-misc/hexcompare/hexcompare-1.0.4.ebuild +++ b/app-misc/hexcompare/hexcompare-1.0.4.ebuild @@ -1,9 +1,9 @@ # Copyright 1999-2021 Gentoo Authors # Distributed under the terms of the GNU General Public License v2 -EAPI=5 +EAPI=7 -inherit epatch toolchain-funcs +inherit toolchain-funcs DESCRIPTION="ncurses-based visual comparison of binary files" HOMEPAGE="http://hexcompare.sourceforge.net/" @@ -12,14 +12,18 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz" LICENSE="GPL-3" SLOT="0" KEYWORDS="~amd64 ~x86" -IUSE="" -RDEPEND="sys-libs/ncurses:0" +RDEPEND="sys-libs/ncurses:0=" DEPEND="${RDEPEND}" +BDEPEND="virtual/pkgconfig" -src_prepare() { - epatch "${FILESDIR}"/${P}-Makefile.patch - tc-export CC +PATCHES=( + "${FILESDIR}"/${P}-Makefile.patch +) + +src_configure() { + tc-export CC PKG_CONFIG + default } src_install() { |